Как пользоваться справочником

Здесь могла быть ваша реклама.
Цены низкие.
По вопросам размещения рекламы обращайтесь по электронной почте

Для удобства пользования справочником используется следующая система, позволяющая наглядно представить все возможности реестра.

Используемые сокращения

  • HKLM = HKEY_LOCAL_MACHINE
  • HKCU = HKEY_CURRENT_USER
  • HKCR = HKEY_CLASSES_ROOT

Разделы реестра обозначаются синим цветом

HKLM\System\CurrentControlSet\Control\Lsa

Все настройки даны для текущего пользователя (раздел HKEY_CURRENT_USER) . Если существует аналогичная запись в HKEY_LOCAL_MACHINE (для всей системы), то HKCU выделяется желтым цветом.

Если установки вступают в силу без перезагрузки, то параметры реестра обозначаются зеленым цветом

RestrictAnonymous

Если установки вступают в силу после перезагрузки или смены пользователя, то параметры реестра обозначаются красным цветом
RestrictAnonymous

Данная система вступает в силу с мая 2003 года. Все параметры, которые были включены в справочник раньше этой даты, будут исправляться постепенно при наличии у автора свободного времени.

С февраля 2010 года некоторые параметры будут дополняться примерами из групповой политики. Образец ниже.

Политика: Конфигурация компьютера (Конфигурация пользователя) → Административные шаблоны → Компоненты Windows → Диспетчер окон рабочего стола → Не разрешать вызов Flip3D


Что такое реестр? Общая теория

Реестр Windows Vista не претерпел существенных изменений, поэтому читатели, умеющие работать с реестром предыдущих версий Windows, смогут работать и с реестром Windows Vista. Единственное, что изменилось в Windows Vista, и на что все-таки нужно обратить внимание:
Добавились новые файлы кустов
Программа reg.exe поддерживает новые возможности
Программа regini.exe теперь входит в стандартную поставку операционной системы.

Реестр - это иерархически построенная база данных в составе операционной системы Windows, содержащая конфигурационные сведения. Физически вся информация реестра разбита на несколько файлов. Реестры разных версий Windows частично различаются. В Windows XP реестр хранится во многих файлах. Основная часть хранится в файлах sam, security, software, system, default (все файлы без расширения).

По замыслу Microsoft он должен был полностью заменить файлы ini, которые были оставлены только для совместимости со старыми программами, ориентированными на более ранние версии операционной системы Windows 3.x.

В реестре хранятся данные, которые необходимы для правильного функционирования Windows. К ним относятся профили всех пользователей, сведения об установленном программном обеспечении и типах документов, которые могут быть созданы каждой программой, информация о свойствах папок и значках приложений, а также установленном оборудовании и используемых портах.

Основным средством для просмотра и редактирования записей реестра служит специализированная утилита "Редактор реестра". Для ее запуска выберите Пуск и в строке поиска введите команду

regedit

Откроется окно программы, в которой слева отображается дерево реестра, похожее по виду на отображение структуры диска в Проводнике, а справа выводятся ключи, содержащиеся в выбранном (активном) разделе. С помощью редактора Вы можете редактировать значения, импортировать или экспортировать реестр, осуществлять поиск.

Существует пять разделов реестра верхнего уровня (так называемые «кусты»). Название каждого из них начинается словом «HKEY». В следующем примере HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft HKEY_LOCAL_MACHINE является кустом, SOFTWARE — разделом, а Microsoft — подразделом:

  • HKEY_CLASSES_ROOT - в этом разделе содержится информация о зарегистрированных типах файлов, порядке обработки этих файлов, содержимом их контекстного меню, содержимом диалога Свойства, значке файла и управление основными настройками интерфейса. Кроме того, содержимое данного корневого раздела хранит описание всех зарегистрированных в операционной системе ActiveX-объектов.

    Фактически, корневой раздел HKEY_CLASSES_ROOT не существует в реестре. Данный корневой раздел является ссылкой на содержимое двух других ветвей реестра: ветвей HKLM\SOFTWARE\Classes и HKCU\Software\Classes. При этом данные, содержащиеся в ветви реестра HKCU\Software\Classes, заменяют собой данные из ветви реестра HKLM\SOFTWARE\Classes.

    Нет никакой разницы, содержимое какой ветви реестра редактировать. Любые изменения, которые будут внесены в ветви реестра HKLM\SOFTWARE\Classes или HKCU\Software\Classes, будут сразу же отображаться и в корневом разделе HKEY_CLASSES_ROOT. Если же вы изменяете содержимое корневого раздела HKEY_CLASSES_ROOT, то фактически вы изменяете содержимое ветви реестра HKLM\SOFTWARE\Classes.

    Содержимое корневого раздела HKEY_CLASSES_ROOT доступно для редактирования только операционной системе и администратору (администратору доступны не все ветви реестра). Однако администратор может самостоятельно изменить разрешения для конкретной ветви реестра.

  • HKEY_CURRENT_USER - В этом разделе содержится информация о пользователе, работающем с Windows в текущем сеансе, а также о различных настройках системы, которые относятся к текущему пользователю.

    Как и корневой раздел HKEY_CLASSES_ROOT, данный корневой раздел физически отсутствует в реестре. Он является ссылкой на ветвь реестра HKEY_USERS\«SID учетной записи пользователя».

    Практически все содержимое данного корневого раздела могут редактировать не только администраторы, но и пользователь, которому принадлежит профиль. Исключение составляют только настройки ограничений в ветвях реестра, используемых групповыми политиками (ветви реестра HKCU\Software\Microsoft\Windows\CurrentVersion\Policies и HKCU\Software\Policies), а также ветвь реестра HKCU\Software\Microsoft\Protected Storage System Provider, в которой почтовый клиент Windows Mail хранит пароли своих пользователей. Эти ветви реестра доступны только администраторам.

  • HKEY_LOCAL_MACHINE - раздел содержит информацию об аппаратной конфигурации локального компьютера и установленном программном обеспечении: сведения о драйверах, портах, службах и самой операционной системе), а также глобальные настройки различных программ.

    Многие параметры, которые хранятся в подразделах ветви реестра HKLM\SOFTWARE\Microsoft данного корневого раздела, могут дублироваться в ветви HKCU\SOFTWARE\Microsoft. Как правило, в этих случаях операционная система будет использовать значения из корневого раздела HKEY_CURRENT_USER, так как они относятся к настройкам конкретного пользователя.

    Большую часть содержимого данного корневого раздела могут редактировать только администраторы, хотя некоторые настройки могут быть доступны и обычным пользователям.

  • HKEY_USERS - в этом разделе находится информация обо всех пользователях данного компьютера (профили). Имеется определенная связь данного раздела с разделом HKEY_CURRENT_USER, который дублирует один из его подразделов, который относится к текущему пользователю.

    Также в данном корневом разделе содержатся загруженные классы пользователей. Данный корневой раздел разрешено редактировать только администратору и учетной записи локальной системы.

  • HKEY_CURRENT_CONFIG - данный раздел содержит информацию о настройках оборудования, которое используется локальным компьютером в текущем сеансе работы. Этот раздел тесно связан с подразделом HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet. Как и корневые разделы HKEY_CLASSES_ROOT и HKEY_CURRENT_USER, данный корневой раздел физически не существует в реестре.

Типы данных, используемых в реестре

  • REG_BINARY - двоичные данные. Этот тип выводится в шестнадцатириченом формате. Как правило, если размер значения параметра типа REG_BINARY не больше 4 байт, его можно заменить на параметр, имеющий тип REG_DWORD. Однако при этом не следует забывать, что значения параметров типа REG_DWORD хранятся в противоположном порядке, чем значения параметров типа REG_BINARY. Например, если значение параметра типа REG_BINARY равно 12 34 56 78, то аналогичное значение в параметре типа REG_DWORD будет равно 0x78563412.
  • REG_DWORD - целое число. Параметры данного типа содержат в себе двоичные данные, длина которых составляет 4 байта. Большинство параметров реестра числового типа имеют именно этот тип. Этот тип может быть представлен в двоичном, десятичном и шестнадцатеричном формате. Параметры типа REG_DWORD отличаются от параметров типа REG_BINARY не только максимальной длиной параметра (для REG_BINARY длина не ограничена, а для REG_DWORD — четыре байта), но и порядком хранения этих данных в памяти. Разновидностью параметров типа REG_DWORD являются параметры типов REG_DWORD_LITTLE_ENDIAN и REG_DWORD_BIG_ENDIAN. Отличие данных параметров от параметра REG_DWORD и между собой заключается только в одном. Если параметр REG_DWORD_LITTLE_ENDIAN хранит самый младший байт своего значения на первом месте в памяти, то параметр REG_DWORD_BIG_ENDIAN хранит младший байт на последнем месте в памяти.
  • REG_QWORD - Параметры данного типа содержат в себе двоичные данные, длина которых составляет 8 байт. Во всем остальном параметры данного типа аналогичны параметрам типа REG_DWORD
  • REG_EXPAND_SZ - Параметры данного типа представляют собой строковые параметры (содержат одну строку текста), которые могут содержать в себе различные переменные окружения
  • REG_MULTI_SZ - многострочный текст (массив строк)
  • REG_SZ - обычные строковые параметры. Они не могут содержать переменных окружения (переменные интерпретируются как обычный текст).
  • REG_RESOURCE_LIST - Параметры данного типа хранят в себе последовательность вложенных массивов в двоичном виде и служат для хранения списка ресурсов. Например, параметры данного типа можно встретить в подразделах ветви реестра HKLM\HARDWARE\RESOURCEMAP. Дочерние подразделы данной ветви реестра не содержат параметров других типов, кроме параметров типа REG_RESOURCE_LIST и REG_RESOURCE_REQUIREMENTS_LIST
  • REG_RESOURCE_REQUIREMENTS_LIST - Параметры данного типа хранят в себе последовательность вложенных массивов в двоичном виде и служат для хранения списка драйверов, которые могут быть использованы другим драйвером устройства. Например, параметры данного типа также можно встретить в подразделах ветви реестра HKLM\HARDWARE\RESOURCEMAP
  • REG_FULL_RESOURCE_DESCRIPTOR - последовательность вложенных массивов для хранения списка ресурсов устройств или драйверов. Например, параметры данного типа также можно встретить в подразделах ветви реестра HKLM\HARDWARE\DESCRIPTION
  • Тип REG_NONE - Параметры данного типа не имеют определенного двоичного или строкового типа. В редакторах реестра они отображаются в виде параметров двоичного типа.
  • REG_LINK - строковый тип данных для указания пути к файлам.
  • существует ряд других типов данных

Редактирование реестра

ПРЕДУПРЕЖДЕНИЕ: НИКОГДА не удаляйте или не меняйте информацию в реестре, если Вы не уверены что это именно то, что нужно, так как редактор реестра не предусматривает отмены выполненных действий. Некорректное изменение данных может привести к сбоям в работе Windows и, в лучшем случае, информацию придется восстанавливать из резервной копии.

Реестр 64-разрядных версий Windows XP и Windows Server 2003 подразделяется на 32- и 64-разрядные разделы. Большинство 32-разрядных разделов имеют те же имена, что и их аналоги в 64-разрядном разделе, и наоборот. По умолчанию редактор реестра 64-разрядных версий Windows XP и Windows Server 2003 отображает 32-разрядные разделы в следующем узле: HKEY_LOCAL_MACHINE\Software\WOW6432

Дополнительные сведения о просмотре реестра в 64-разрядных версиях Windows см. в следующей статье базы знаний Майкрософт: 305097 (http://support.microsoft.com/kb/305097/) Просмотр системного реестра с помощью 64-разрядной версии Windows.

Более подробно о реестре и о программе Редактор реестра читайте в справке к этой программе.

В Windows XP и Windows Server 2003 также имеется программа regedt32.exe, которая оставлена в целях совместимости. На самом деле она просто запускает программу regedit.exe.


Windows 8

Все настройки действительны для предварительных версий Windows 8. Нет никаких гарантий, что в следующей сборке эти же настройки будут работать. Даны исключительно для полноты информации. Пробуйте сами.

Вклчить ленточный интерфейс Windows Explorer

Чтобы включить новый ленточный интерфейс Windows Explorer, создайте раздел реестра HKEY_CLASSES_ROOT\CLSID\{4F12FF5D-D319-4A79-8380-9CC80384DC08}. Далее внутри созданного раздела создайте строковой параметр AppID со значением {9198DA45-C7D5-4EFF-A726-78FC547DFF53}. Запустите Проводник (Windows Explorer).

Обновленный диспетчер задач

Чтобы запустить обновленный диспетчер задач, создайте раздел реестра HKLM\Software\Microsoft\Windows\CurrentVersion\TaskUI. Далее создайте DWORD-параметр TaskUIEnabled со значением 1.

Запустите программу taskui.exe

PDF-ридер

Чтобы запустить приложение для чтения PDF-документов, в разделе HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Applets\Paint\Capabilities создайте строковой параметр с именем CLSID со значением {D3E34B21-9D75-101A-8C3D-00AA001A1652}.

Запустие приложение glcnd.exe

Webcam Capture Application

Чтобы запустить приложение для захвата изображения с веб-камеры, в разделе HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\GRE_Initialize создайте DWORD-параметр RemoteFontBootCacheFlags с шестнадцатеричным значением 0x100f или десятичным значением 4111.

Запустите приложение webcam.exe


Внешний вид кнопки Пуск

Удаление фиксированного списка программ

В контекстном меню исполняемых файлов есть пункт Закрепить в меню "Пуск", который добавляет программу в фиксированный список данного меню. Также там могут находится две программы интернета и электронной почты (Пуск | Панель управления | Панель задачи меню "Пуск" | вкладка Меню "Пуск" | кнопка Настроить | рамка Отображать в меню "Пуск")
Для удаление данного списка из меню откройте раздел HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer и создайте DWORD-параметр NoStartMenuPinnedList со значением, равным 1. Также будет удален и пункт Закрепить в меню "Пуск" из контекстного меню программ.

Удаление списка часто используемых программ

Если вы хотите удалить список часто используемых программ кнопки Пуск, то откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
и создайте параметр типа DWORD NoStartMenuMFUprogramsList со значением, равным 1.

Политика: Конфигурация пользователя → Административные шаблоны → Меню Пуск и панель задач → Удалить список часто используемых программ в меню "Пуск"

Если удалять данный список не входит в ваши планы, то можно указать список программ, которые не будут отображаться в нем. Для этого достаточно воспользоваться параметрами строкового типа в разделе HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\FileAssociation:

AddRemoveApps
содержит список названий программ (перечисленных через точку с запятой), которые никогда не будут добавляться в список популярных программ;
AddRemoveNames
хранит список строк (перечисленных через точку с запятой). Если файлы содержат эти строки, то они никогда не будут добавляться в список популярных программ.

Запрет на попадание приложения в список часто используемых программ (еще один способ)

Можно не удалять список часто используемых программ (смотри совет выше), а запретить отдельным программам попадать в этот список. Для этого откройте раздел HKCR\Applications\Имя_Программы.exe и создайте пустой строковый параметр NoStartPage.

Всплывающие подсказки в меню Пуск

Чтобы отключить всплывающие подсказки в меню кнопки, в разделе HKCR\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer создайте DWORD-параметр NoSMBalloonTip со значением 1.

Отключить всплывающие подсказки можно через редактор групповой политики gpedit.msc (Конфигурация пользователя | Административные шаблоны | Меню Пуск и панель задач | параметр "Удалить всплывающие подсказки для элементов главного меню")

Удаление команды Все программы

Если вы хотите удалить команду Все программы кнопки Пуск, то откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте DWORD-параметр NoStartMenuMorePrograms со значением 1.

Политика: Конфигурация пользователя → Административные шаблоны → Меню Пуск и панель задач → Удалить список всех программ в меню «Пуск»

Восстановление системы

Чтобы удалить команду Восстановление системы из меню кнопки Пуск (Пуск-Все программы-Стандартные-Служебные), то откройте раздел

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\SystemRestore
и создайте параметр типа DWORD DisableSR со значением, равным 1

Удаление пункта Мой компьютер

Чтобы удалить пункт Мой компьютер и заблокировать соответствующий флажок в диалоговом окне настройки, добавьте параметр типа DWORD {20D04FE0-3AEA-1069-A2D8-08002B30309D} со значением, равным 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\NonEnum

Удаление пункта Сетевые соединения

Чтобы удалить пункт Сетевые соединения, добавьте параметр типа DWORD NoNetworkConnections со значением, равным 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Принтеры и факсы

Чтобы удалить пункт Принтеры и факсы, добавьте параметр типа DWORD Start_ShowPrinters со значением, равным 0 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced Чтобы вернуть пункт обратно, используйте значение 1 (по умолчанию).
C помощью командной строки:

  1. Запустите командную строку (CMD.EXE)
  2. Введите команду одной строкой и нажмите Enter:
    REG ADD "HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced" /V Start_ShowPrinters /T REG_DWORD /F /D 0
  3. Перезагрузите систему

Без использования реестра: Правый щелчок мыши на кнопке Пуск - Свойства - вкладка Меню Пуск - кнопка Настроить - вкладка Дополнительно - список Элементы меню "Пуск". Снимите в этом списке флажок с пункта Принтеры и факсы.

Удаление пункта Выход из системы

Ключ StartmenuLogoff типа DWORD, равный 1, раздела

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
удаляет пункт Выход из системы

Удаление вышеприведенных параметров или установка в 0 возвращает прежнее поведение

Как сохранить закрепленные элементы меню Пуск

Раздел реестра, в котором содержится информация о закрепленных элементах меню Пуск:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\StartPage2

Подробнее о сохранении элементов, закрепленных в меню Пуск, читайте в справочнике Народные советы.Windows.


Настройка окна свойств меню кнопки Пуск

Если щелкнуть правой кнопкой мыши на кнопке Пуск и выбрать команду Свойства, а затем на вкладке Меню "Пуск" щелкнуть на кнопке Настроить, то откроется диалоговое окно Настройка меню кнопки Пуск. В этом окне мы можем видеть множество настроек. Чтобы помешать пользователю пользоваться применять некоторымие настройками, воспользуемся реестром. Еще раз обращаю внимание, что мы будем скрывать разделы и команды именно в окне свойств меню кнопки Пуск. При этом соответственно будут скрыты и одноименные команды в самом меню. Все настройки проводятся в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer при помощи параметров DWORD, которым присваиваются значения 1. Чтобы восстановить скрытые пункты, нужно либо присвоить значение 0 или удалить параметр.

Игры

Для скрытия раздела Игры из окна настроек меню кнопки Пуск используется параметр NoStartMenuMyGames. При этом будет удален соответствующий пункт из меню кнопки Пуск.

Политика: Конфигурация пользователя → Административные шаблоны → Меню Пуск и панель задач → Удалить ссылку "Игры" из меню "Пуск"

Выполнить

По умолчанию, команда Выполнить уже не входит в меню кнопки Пуск, как это было раньше в Windows XP. При желании можно вернуть команду обратно, если поставить флажок у соответствующего пункта в окне настроек кнопки Пуск. Но можно скрыть там флажок Выполнить, лишив пользователя этой настройки. Для этого нужно создать параметр NoRun со значением, равным 1. При этом после перезагрузки компьютера окно Запуска программ больше не вызывается через комбинацию клавиш Win+R (появится окно с предупреждением).

Политика: Конфигурация пользователя → Административные шаблоны → Меню Пуск и панель задач → Удалить команду "Выполнить" из меню "Пуск"

Скрытие флажка Сеть

Для скрытия команды Сеть из окна настроек меню кнопки Пуск используйте параметр NoStartMenuNetworkPlaces. При этом будет удален соответствующий пункт из меню кнопки Пуск.

Политика: Конфигурация пользователя → Административные шаблоны → Меню Пуск и панель задач → Удалить команду "Сеть" из меню "Пуск"

Скрытие флажка Подключение к

Чтобы скрыть флажок Подключение к из окна настроек меню кнопки Пуск, используйте параметр NoNetworkConnections. При этом будет удален соответствующий пункт из меню кнопки Пуск.

Политика: Конфигурация пользователя → Административные шаблоны → Меню Пуск и панель задач → Удалить "Сетевые подключения" из меню "Пуск"

Скрытие флажка Недавние документы

Чтобы скрыть флажок Недавние документы из окна настроек меню кнопки Пуск, используйте параметр NoRecentDocsMenu. При этом будет удален соответствующий пункт из меню кнопки Пуск.

Политика: Конфигурация пользователя → Административные шаблоны → Меню Пуск и панель задач → Удалить меню "Недавние документы" из меню "Пуск"

К слову сказать, мы можем настроить число элементов, выводимых в списке Недавние документы. По умолчанию, система запоминает 10 последних открытых документов, но при помощи параметра типа DWORD MaxRecentDocs можно задать значение, соответствующее желаемому количеству элементов в списке.

Скрытие раздела Документы

Чтобы скрыть раздел Документы из окна настроек меню кнопки Пуск, используйте параметр NoSMMyDocs (сокращенно от слов No Start Menu My Documents). При этом будет удален соответствующий пункт из меню кнопки Пуск.

Политика: Конфигурация пользователя → Административные шаблоны → Меню Пуск и панель задач → Удалить значок "Документы" из меню "Пуск"

Скрытие раздела Изображения

Для скрытия раздела Изображения из окна настроек меню кнопки Пуск, нужно использовать параметр NoSMMyPictures (сокращенно от No Start Menu My Pictures). При этом будет удален соответствующий пункт из меню кнопки Пуск.

Политика: Конфигурация пользователя → Административные шаблоны → Меню Пуск и панель задач → Удалить значок "Изображения" из меню "Пуск"

Скрытие раздела Музыка

Для скрытия раздела Музыка из окна настроек меню кнопки Пуск используйте параметр NoStartMenuMyMusic. При этом будет удален соответствующий пункт из меню кнопки Пуск.

Политика: Конфигурация пользователя → Административные шаблоны → Меню Пуск и панель задач → Удалить значок "Музыка" из меню "Пуск"

Скрытие раздела Искать в других файлах и библиотеках

Чтобы скрыть целый раздел Искать в других файлах и библиотеках из окна настроек меню кнопки Пуск, нужно создать параметр NoStartMenuSearchFiles.

Скрытие флажка Искать программы и компоненты панели управления

Чтобы скрыть флажок Искать программы и компоненты панели управления из окна настроек меню кнопки Пуск, нужно создать параметр NoStartMenuSearchPrograms. При этом будет удален соответствующий пункт из меню кнопки Пуск.

Скрытие раздела Личная папка

Для скрытия раздела Личная папка из окна настроек меню кнопки Пуск, нужно создать параметр NoUserFolderInStartMenu. При этом из меню кнопки Пуск будет удалена ссылка, открывающая персональную папку текущего пользователя.

Политика: Конфигурация пользователя → Административные шаблоны → Меню Пуск и панель задач → Удалить ссылку на папку пользователя из меню "Пуск"

Скрытие флажка Избранное

Чтобы скрыть флажок Избранное из окна настроек меню кнопки Пуск, нужно создать параметр NoFavoritesMenu. При этом будет удален соответствующий пункт из меню кнопки Пуск.

Политика: Конфигурация пользователя → Административные шаблоны → Меню Пуск и панель задач → Удалить меню "Избранное" из главного меню

Скрытие раздела Панель управления

Чтобы скрыть раздел Панель управления из окна настроек меню кнопки Пуск, нужно создать параметр NoControlPanel. При этом из меню кнопки Пуск будет удалена соответствующая команда. Также вы не сможете вызывать любые программы из Панели управления любым способом, например, через командную строку (будет выводиться окно с предупреждением).

Скрытие флажка Программы по умолчанию

Чтобы скрыть флажок Программы по умолчанию из окна настроек меню кнопки Пуск, нужно создать параметр NoSMConfigurePrograms. При этом будет удален соответствующий пункт из меню кнопки Пуск.

Политика: Конфигурация пользователя → Административные шаблоны → Меню Пуск и панель задач → Удалить ссылку "Программы по умолчанию" из меню "Пуск"

Скрытие флажка Справка

Чтобы скрыть флажок Справка из окна настроек меню кнопки Пуск, нужно создать параметр NoSMHelp. При этом будет удален пункт Справка и поддержка из меню кнопки Пуск. Этот параметр влияет только на вид меню «Пуск». Он не удаляет меню «Справка» из проводника Windows и не запрещает использовать справку.

Политика: Конфигурация пользователя → Административные шаблоны → Меню Пуск и панель задач → Удалить справку из главного меню


Меню кнопки Пуск: Подпапки

Меню кнопки Пуск: Папки

Существует возможность скрывать папки и файлы из верхней части меню кнопки Пуск, которые были скопированы из других мест (Папки при этом не удаляются). Откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр типа DWORD NoStartMenuSubFolders со значением 1.


Все программы

По умолчанию, меню Все программы содержит элементы не только из профиля текущего пользователя, но и из профиля Пользователи. Таким образом, если на компьютере работают несколько пользователей с разными вкусами, то меню сильно засоряется.

Небольшая подсказка: Значки к программам для меню Все программы располагаются по адресу: %SYSTEMDRIVE%\ProgramData\Microsoft\Windows\Start Menu\Programs.

Вы можете скрыть чужие значки из меню при помощи параметра типа DWORD NoCommonGroups в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer, если присвоите ему значение 1.


Документы

Управление количеством запоминаемых документов

Windows помнит список из 15 последних открытых документов, доступ к которому можно получить через Пуск | Документы. Если вы хотите изменить это значение по умолчанию, то откройте раздел HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer и создайте DWORD-параметр MaxRecentDocs со значением от 0x0 - 0xFFFFFFFF (0xF = 15 документам).

Политика: Конфигурация пользователя → Административные шаблоны → Компоненты Windows → Проводник Windows → Максимальная длина списка "Недавние документы"

Автоматическое очищение списка недавно открытых документов

Чтобы очищать список недавно открытых документов каждый раз при выключении компьютера, добавьте ключ ClearRecentDocsOnExit типа DWORD со значением 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer

Не запоминать открываемые документы

Если Вы хотите, чтобы открываемые Вами документы не запоминались в этом списке, надо добавить ключ NoRecentDocsHistory типа DWORD со значением 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer

Также эти настройки доступны через редактор групповых политик gpedit.msc: Конфигурация пользователя - Административные шаблоны - Панедь задач и меню Пуск


Настройка

Скрытие пунктов подменю из меню Настройка

Если вы хотите скрыть пункты Панель управления, Принтеры, Удаленный доступ к сети и др. из меню Настройка, то откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр типа DWORD NoSetFolders со значением 1.

Установка этого ключа также удалит эти папки из окна "Мой компьютер".

Примечание: Если нужно скрыть только один пункт Панель управления, не трогая остальные пункты, то смотри NoControlPanel


Выполнить

Добавить команду «Выполнить» в меню «Пуск»

По умолчанию команда «Выполнить» не отображается в меню «Пуск». Чтобы ее добавить, создайте DWORD-параметр ForceRunOnStartMenu со значением 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer.

Политика: Конфигурация пользователя → Административные шаблоны → Меню Пуск и панель задач → Добавить команду «Выполнить» в меню «Пуск»

Если параметр отключен или не задан, команда «Выполнить» по умолчанию не отображается в меню «Пуск», однако ее можно добавить из окна «Свойства панели задач и меню "Пуск"». Если включена политика «Удалить команду "Выполнить" из меню "Пуск"», то политика «Добавить команду "Выполнить" в меню "Пуск"» пропускается.

Флажок "Запустить в отдельной области памяти"

Параметр DWORD MemCheckBoxInRunDlg, равный 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer добавляет флажок "Запустить в отдельной области памяти" в диалоговое окно "Запуск программы", который позволяет выполнить 16-разрядные приложения в отдельных виртуальных DOS-машинах.

Политика: Конфигурация пользователя → Административные шаблоны → Меню Пуск и панель задач → Добавить флажок «Запустить» в отдельной области памяти в окно команды «Выполнить»

Очистка списка недавно использованных команд

Команда Выполнить содержит список недавно использованных команд (MRU list)

Этот список содержится в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Explоrer\RunMRU.

Параметр MRUList содержит строку, определяющую порядок, в котором остальные записи будут появляться в списке. Например, запись "bca" говорит о том, что первым элементом в списке Открыть будет команда с именем b, потом c, а следом a

Сами команды хранятся как строки с оканчивающимися символами \1 в параметрах a, b, c, d и т.д. Всего допускается 26 записей

Для очистки списка нужно заменить параметры MRUList и все команды пустой строкой (""), либо отредактируйте по своему вкусу

Смотри также

Удаление пункта Выполнить из меню кнопки Пуск


Завершение работы

Выключить компьютер можно двумя способами

  • Используя команду Выключение меню кнопки Пуск
  • Открывая окно Диспетчер задач Windows нажатием кнопок Ctrl+Alt+Del и выбирая пункт меню Завершение работы | Выключение
Windows позволяет запретить выключение этими способами для текущего пользователя

Для этого откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр типа DWORD NoClose со значением 1.

Сразу же после изменения в реестре станут недоступны несколько пунктов в меню Выключение диалогового окна Диспетчер задач Windows. После перезагрузки пункт Выключение исчезнет из меню кнопки Пуск.

Это относится только к стандартным средствам Windows. Специальные программы или утилиты по-прежнему могут выключать компьютер


Контекстное меню кнопки Пуск

Если вы хотите запретить контекстное меню кнопки Пуск, позволяющее удалять, переименовывать и т.д., а также возможность перемещения пунктов меню методом drag-n-drop, то откройте раздел HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer и создайте DWORD-параметр NoChangeStartMenu со значением 1.

Политика: Конфигурация пользователя → Административные шаблоны → Меню Пуск и панель задач → Удалить контекстные меню и меню перетаскивания для элементов меню "Пуск"


Поиск в меню кнопки Пуск

Поиск в Интернете

По умолчанию ссылка "Поиск в Интернете" не отображается в меню "Пуск". Чтобы ее отобразить, нужно в разделе HKCU\Software\Policies\Microsoft\Windows\Explorer добавить DWORD-параметр AddSearchInternetLinkInStartMenu со значением 1. В этом случае при выполнении пользователем поиска в поле поиска меню "Пуск" ссылка "Поиск в Интернете" будет отображаться. С помощью этой ссылки открывается установленный по умолчанию браузер с соответствующим поисковым запросом.

Политика: Конфигурация пользователя → Административные шаблоны → Меню Пуск и панель задач → Добавить ссылку "Поиск в Интернете" в меню "Пуск"

Запретить поиск программ и элементов панели управления

Чтоб запретить поиск программ или элементов панели управления через поиск в меню "Пуск", в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer присвоить параметру NoSearchProgramsInStartMenu значение 1.

Политика: Конфигурация пользователя → Административные шаблоны → Меню Пуск и панель задач → Запретить поиск программ и элементов панели управления

Запретить поиск файлов

По умолчанию, при выполнении пользователем поиска в поисковом поле меню "Пуск" происходит и поиск файлов. Чтобы отключить поиск файлов, нужно в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer присвоить параметру NoSearchFilesInStartMenu значение 1. В этом случае при выполнении пользователем поиска в поисковом поле меню "Пуск" не будет отображаться ссылка "Просмотреть все результаты" /"Поиск в других местах".

Политика: Конфигурация пользователя → Административные шаблоны → Меню Пуск и панель задач → Запретить поиск файлов

Удалить ссылку «Ознакомиться с другими результатами» или «Поиск везде» (Windows 7)

По умолчанию, при выполнении пользователем поиска в поле поиска меню "Пуск" появляется ссылка "Ознакомиться с другими результатами" или "Поиск везде". Если вы хотите, чтобы ссылка не отображалась при выполнении пользователем поиска в поле поиска меню "Пуск", то в разделе HKCU\Software\Policies\Microsoft\Windows\Explorer присвойте DWORD-параметру NoSearchEverywhereLinkInStartMenu значение 1.

Примечание: Если установлен обработчик протокола стороннего производителя, вместо ссылки "Ознакомиться с другими результатами" отображается ссылка "Поиск везде".

Политика: Конфигурация пользователя → Административные шаблоны → Меню Пуск и панель задач → Удалить ссылку «Ознакомиться с другими результатами» или «Поиск везде»


Корзина

Всплывающая подсказка

Когда вы подводите курсор к значку Корзина на Рабочем столе, то появляется всплывающая подсказка следующего содержания: "Используется для временного сохранения файлов и папок, которые были удалены". Для изменения этой надписи используйте строковый параметр InfoTip в разделе

HKCR\CLSID\{645FF040-5081-101B-9F08-00AA002F954E},
в которой укажите желаемую строку (например, "Здесь хранится мусор")

Если вы хотите вернуть первоначальное значение, то запишите в указанный параметр строку @%SystemRoot%\system32\SHELL32.dll,-22915

Новое имя для корзины

Чтобы изменить имя для Корзины, достаточно вызвать контекстное меню и выбрать команду Переименовать.

Для разработчиков: новое имя корзины содержится в разделе HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}. Присваиваем значению по умолчанию нужную строку, чтобы получить имя корзины.

Удаление значка с Рабочего стола

Чтобы удалить значок Корзины с Рабочего стола, необходимо зайти в раздел HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace и удалить подраздел {645FF040-5081-101B-9F08-00AA002F954E}

Использование Корзины для съемных дисков

По умолчанию Корзина не создается на съемных дисках, однако с помощью параметра RecycleBinDrives в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer вы можете изменить это поведение операционной системы. Данный параметр является битовой маской, каждый бит которой определяет букву диска, на котором будет создаваться файл Корзины. Если присвоить данному параметру значение 0хffffffff, то файл Корзины будет создаваться на всех дисках.

Пункт Свойства

Если вы хотите убрать пункт Свойства из контекстного меню Корзины, то создайте DWORD-параметр NoPropertiesRecycleBin со значением 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Политика: Конфигурация компьютера (Конфигурация пользователя) → Административные шаблоны → Рабочий стол → Удалить пункт «Свойства» из контекстного меню компонента «Корзина»

Также можно настроить различные параметры в свойствах Корзины

Блокировка флажка Запрашивать подтверждение на удаление

Чтобы блокировать флажок Запрашивать подтверждение на удаление в свойствах Корзины, в разделе HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer присвойте DWORD-параметру ConfirmFileDelete значение 1 (см. рис).

Удаление файлов, минуя Корзину

Если в разделе HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer присвоить параметру типа DWORD NoRecycleFiles значение 1, то система не будет использовать Корзину для хранения удаленных файлов – файлы и папки будут сразу удаляться, минуя ее. При этом в свойствах Корзины будет заблокирована возможность изменения размера Корзины и состояния флажка Уничтожать файлы сразу после удаления, не помещая их в корзину

Добавление собственных команда в контекстное меню Корзины

Вы можете добавить свою команду в контекстное меню элемента Корзина. Откройте раздел

HKCR\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\shell
и создайте новый раздел, который и будет отображаться в меню (например, Запустить блокнот). В созданном разделе создайте подраздел command, в котором пропишите программу для запуска в параметре по умолчанию. В нашем случае это будет строка notepad.exe

Смотри также

Добавить значок Корзины в Мой компьютер


Рабочий стол

Версия Windows на Рабочем столе

Существует возможность вывода номера версии и номер сборки Windows в нижнем правом углу Рабочего стола. Для этого создайте ключ типа DWORD PaintDesktopVersion со значением 1 в разделе HKCU\Control Panel\Desktop

Предустановленные значки

На Рабочий стол можно вывести предустановленные значки:

  • Компьютер
  • Файлы пользователя
  • Сеть
  • Панель управления

Стандартный способ для пользователя: вызовите контекстное меню Рабочего стола и выберите команду Персонализация. В левой области открывшего окна нажмите на ссылку Изменение значков рабочего стола и в диалоговом окне Параметры значков рабочего стола установите флажки возле тех значков, которые хотите видеть на рабочем столе.

Для разработчиков: данные настройки хранятся в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\NewStartPanel в виде DWORD-параметров со значением 0:

  • {20D04FE0-3AEA-1069-A2D8-08002B30309D} - Компьютер
  • {59031a47-3f72-44a7-89c5-5595fe6b30ee} - Файлы пользователя
  • {F02C1A0D-BE21-4350-88B0-7367FC96EF3C} - Сеть
  • {5399E694-6CE5-4D6C-8FCE-1D8870FDCBA0} - Панель управления

Скрытие всех значков на Рабочем столе

Существует возможность сразу скрыть все значки рабочего стола. В контекстном меню Рабочего стола выберите команду Вид, и снимите флажок с команды Отображать значки рабочего стола.

Для разработчиков: Cоздайте DWORD-параметр NoDesktop со значением 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Скрыть значок Сеть на Рабочем столе

Чтобы скрыть значок Сеть на Рабочем столе, присвойте параметру типа DWORD NoNetHood значение 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Этот параметр затрагивает только значок на рабочем столе. Он не запрещает пользователям подключаться к сети и просматривать общие компьютеры сети. В операционных системах более ранних, чем Windows Vista, этот параметр применяется к значку «Сетевое окружение».

Политика: Конфигурация пользователя → Административные шаблоны → Рабочий стол → Скрыть значок "Сеть" на рабочем столе

Папка Принтеры на Рабочем столе

Можно поместить на рабочий стол папку Принтеры, в котором будут присутствовать установленные в системе принтеры. В разделе HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace создайте новый подраздел {2227a280-3aea-1069-a2de-08002b30309d}. Присвойте созданному подразделу в параметре по умолчанию какое-нибудь понятное значение, например, Принтеры. После данных действий на рабочем столе появится папка Принтеры (в случае необходимости обновите рабочий стол), в котором будут присутствовать установленные в системе принтеры.


Обои для Рабочего стола

За картинку, используемую в качестве обоев для Рабочего стола отвечает строковый параметр Wallpaper, который содержит путь bmp-файла в HKCU\Control Panel\Desktop

Чтобы ваша картинка на Рабочем столе располагалась в строго заданном месте, а не в центре, нужно в разделе HKCU/Control Panel/Desktop создать строковые параметры с названиями WallpaperOriginX и WallpaperOriginY и установите их значения так, чтобы они соответствовали нужным вам координатам X и Y левого верхнего угла картинки в пикселях.

Сохранение обоев рабочего стола при изменении темы оформления

При изменении темы оформления Windows Vista или Windows XP, изменяются многие визуальные элементы, в том числе и рисунок рабочего стола. Чтобы оставить прежний рисунок при смене стиля нужно изменить значение параметра Desktop wallpaper на 0 в разделе HKCU\Software\Microsoft\Plus!\Themes\Apply. Теперь при смене темы оформления все визуальные элементы будут изменены за исключением рисунка рабочего стола.


Панель задач

Управление временем задержки перед показом эскизов на панели задач

Вы можете управлять временем задержки перед показом эскизов при наведении мышкой на значок на панели задач. Для этого в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced создайте параметр DWORD ExtendedUIHoverTime и установите нужное значение в миллисекундах, например 20000. После этого превьюшки будут показываться через 20 секунд после наведения курсора на кнопку на панели задач. Полностью отключить превью нельзя.

Изменение размеров эскизов окна на панели задач

Если вам хочется иметь большие эскизы, например это удобно для окна Windows Media Player со списком воспроизведения, то в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Taskband создайте параметр DWORD MinThumbSizePx с любым подходящим значением (попробуйте, например, 300), которое задает размер эскиза в пикселах.

Контекстное меню панели задач

Если вы хотите запретить контекстное меню панели задач, то откройте раздел HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer и создайте параметр типа DWORD NoTrayContextMenu со значением 1.

Политика: Конфигурация пользователя → Административные шаблоны → Меню Пуск и панель задач → Запретить доступ к контекстному меню для панели задач

Закрепить панель задач

Чтобы включить задачу Закрепить панель задач через реестр, нужно в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced присвоить DWORD-параметру TaskbarSizeMove значение 0

Запрет на перемещение Панели задач

Чтобы запретить перемещение Панели задач по экрану, нужно в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer присвоить параметру типа DWORD LockTaskbar значение 1. При этом в контекстном меню Панели задач пункт Закрепить панель задач будет заблокирован.

Запрет на стыковку по разным сторонам экрана

При помощи параметра типа DWORD TaskbarNoRedock со значением 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer можно запретить пользователю стыковать панель задач к разным сторонам экрана. Бывает очень неприятно, когда приходишь на работу после отпуска, а кто-то поменял расположение панели задач. С помощью данной настройки вы можете защититься от такой проблемы.

Запрет на изменение размера панели задач

Если подвести указатель мыши к границе панели задач и потянуть ее, то можно увеличить высоту панели задач (предварительно сняв галочку с пункта Закрепить панель задач). При помощи параметра TaskbarNoResize со значением, равным 1, в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer можно запретить пользователю изменять размеры панели задач.

Как сохранить элементы, закрепленные на панели задач

Раздел реестра, в котором содержится информация о закрепленных элементах на панели задач:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Taskband

Подробнее о сохранении элементов, закрепленных на панели задач, читайте в справочнике Народные советы.Windows.


Панель инструментов на панели задач

Скрытие панели инструментов

Если вы хотите скрыть пункт Панели, блокируя тем самым возможность работать с панелями инструментов, то воспользуйтесь параметром типа DWORD NoToolbarsOnTaskbar со значением 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer. После перезагрузки компьютера пункт Панели исчезнет из контекстного меню Панели задач.

Блокировка панели инструментов

Можно пойти по другому пути. Мы не будем скрывать пункт меню Панели, но заблокируем его, лишая возможности добавлять или удалять уже существующие панели инструментов. Для этой цели нужно создать параметр DWORD TaskbarNoAddRemoveToolbar со значением 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer. После перезагрузки компьютера вы увидите, что все элементы панели инструментов недоступны для работы.

Запрет на перетаскивание и закрытие панели инструментов

Есть еще одна интересная возможность блокировки панели инструментов. При помощи параметра типа DWORD NoCloseDragDropBands со значением 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer мы можем запретить операции перетаскивания и закрытия панелей инструментов. После перезагрузки компьютера вы увидите, что все в меню все элементы панели инструментов недоступны для работы и вы также не сможете мышкой перетаскивать панели инструментов на панели задач.

Запрет на изменение длины панелей инструментов

Если в меню панели задач снять флажок Закрепить панель задач, то у пользователя появляется возможность перемещать и изменять размеры размещенных на панели задач панелей инструментов. Чтобы ограничить свободу пользователю, оставив ему возможность перемещать только значки приложений, воспользуйтесь параметром типа DWORD NoMovingBands со значением, равным 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer.


Область уведомлений

Изменение времени задержки диалоговых окон уведомлений

Можно установить время, в течение которого уведомления остаются на экране, прежде чем будут закрыты. Для этого находим в разделе HKCU\Control Panel\Accessibility параметр MessageDuration и меняем его значение. По умолчанию оно равно 5 секундам.

Эту операцию можно проделать при помощи компонента Панели управления Центр специальных возможностей: ссылка Использование компьютера без экрана | список Как долго должны оставаться открытыми диалоговые окна уведомлений Windows?

Запрет на настройку значков и уведомлений в области уведомлений

Пользователь имеет возможность настраивать значки в области уведомлений по своему вкусу – можно не выводить значки, выводить значки и уведомления и т.д.

Можно заблокировать доступ к настройкам области уведомлений. Для этого в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer нужно создать параметр типа DWORD NoAutoTrayNotify и присвоить ему значение 1. Если теперь пользователь щелкнет в области уведомлений на треугольнике и выберет команду Настроить, то увидит заблокированное диалоговое окно с сообщением, что некоторые настройки определяются системным администратором.

Отключение всплывающих уведомлений

Для того, чтобы отключить уведомления компонентов области уведомления при помощи реестра, нужно в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer установить для параметра типа DWORD TaskbarNoNotification значение 1.

Скрытие часов в области уведомлений

Если в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer создать параметр HideClock со значением, равным 1, то после перезагрузки компьютера на панели задач в области уведомлений часы не будут отображаться.

Скрытие значка регулятора громкости

Очень часто в области уведомлений можно увидеть значок регулятора громкости. Можно скрыть данный значок при помощи параметра типа DWORD HideSCAVolume со значением 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer. После применения изменений в реестре данный значок исчезнет из окна настроек Значки области уведомлений.

Скрытие значка "Центр поддержи"

В области уведомлений можно видеть также значок Центр поддержки. Чтобы его отключить, требуется найти в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer параметр типа DWORD HideSCAHealth и присвоить ему значение 1.

Скрытие значка сети

При помощи параметра типа DWORD HideSCANetwork, который должен быть равен 1 и находиться в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer можно скрыть значок сети, который обычно отображается у компьютеров, подключенных к локальной сети.

Скрытие значка "Батарея"

У владельцев ноутбуков в области уведомлений присутствует значок Батарея. Для его удаления используйте параметр типа DWORD HideSCAPower со значением 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer.

Очистка устаревших значков из окна настройки значков и уведомлений

После установки множества программ, которые во время работы размещаются в области уведомлений, список значков в окне настроек значков и уведомлений увеличивается. Чтобы оставить в данном окне только те значки, которые расположены в области уведомлений на данный момент, нужно в разделе HKCU\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\TrayNotify удалить подразделы PastIconsStream и IconStreams и перезагрузить компьютер.

Смотри также

Скрытие области уведомлений


Контекстное меню рабочего стола

Меняем пункты Разрешение экрана, Гаджеты, Персонализация в контекстном меню Рабочего стола

В Windows 7 в контекстном меню рабочего стола появились три новые команды: Разрешение экрана, Гаджеты, Персонализация. Я расскажу, как можно поменять данные пункты под себя. Так как изменяемые значения находятся в защищенной области, то необходимо поменять разрешения на разделы. Подробнее процесс описан на сайте

Заходим в раздел HKCR\DesktopBackground\Shell\Display

Сейчас здесь находится запись @%SystemRoot%\System32\display.dll,-4. Введите слово по желанию, например, HABR и щелкните OK. При желании вы можете ввести аксселератор при помощи символа & перед нужным символом, например, &HABR.

Данные изменения не требуют перезагрузки компьютера. Щелкните правой кнопкой мыши на пустом месте Рабочего стола и убедитесь, что новая команда появилась в контекстом меню.

Возможно, для большинства пользователей это покажется бесполезной настройкой. Тем не менее, здесь можно найти рациональное зерно. Например. у меня по умолчанию установлена английская раскладка клавиатуры. Если вызвать контекстное меню Рабочего стола в русской версии Windows, то горячие клавиши для команд меню тоже расчитаны на русские символы, т.е. Гаджеты. Фактически, при английской раскладке горячие клавиши оказываются бесполезными. При варианте, &HABR вы можете задействовать клавишу H (эйч).

Гаджеты и Персонализация

Для изменения команд Гаджеты и Персонализация действуем аналогичными способом в соседних разделах реестра HKEY_CLASSES_ROOT\DesktopBackground\Shell\Gadgets и HKEY_CLASSES_ROOT\DesktopBackground\Shell\Personalize


Панель быстрого запуска

Открытие папки в панели быстрого запуска в виде меню

Когда в панели быстрого запуска скапливается большое количество ярлыков, для их упорядочивания можно создать папки, поместив в них программы определенной тематики. Это экономит пространство, но и при нажатии на эту папку откроется окно проводника с содержимым папки. Можно избежать открытия папки при щелчке и отобразить меню со списком содержащихся в ней ярлыков.

В разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced создайте параметр DWORD CascadeFolderBands и присвойте ему значение 1. После перезагрузки рядом с папками, расположенными в панели быстрого запуска появится немного пустого пространства. Если щелкнуть на нем мышью, то увидите выпадающее меню.

Смотри также в справочнике Народные советы.Windows совет Панель быстрого запуска


Computer

Компьютер

CLSID: {20D04FE0-3AEA-1069-A2D8-08002B30309D}

Подсказка

Для изменения текста подсказки, возникающей при подведении курсора к значку Компьютер, необходимо изменить текст в строковом параметре InfoTip в разделе HKCR\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}. Значение по умолчанию: @%SystemRoot%\system32\shell32.dll,-22913

Добавление команды в контекстное меню

Вы можете добавить свою команду в контекстное меню элемента Компьютер. Откройте раздел

HKCR\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell
и создайте новый раздел, который и будет отображаться в меню (например, Запустить блокнот). В созданном разделе создайте подраздел command, в котором пропишите программу для запуска в параметре по умолчанию. В нашем случае это будет строка notepad.exe

Управление

Чтобы скрыть пункт Управление из контекстного меню значка Компьютер, создайте параметр типа DWORD NoManageMyComputerVerb со значением 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Политика: Конфигурация пользователя → Административные шаблоны → Компоненты Windows → Проводник Windows → Скрыть команду «Управление» из контекстного меню проводника Windows

Примечание: Данный пункт запускает утилиту compmgmt.msc. Удаление пункта не удаляет саму программу

Можно пойти более радикальным путем - удалите раздел HKCR\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Manage

Пункт меню Свойства

Можно запретить отображение команды Свойства в контекстном меню значка Компьютер. Для этого нужно параметру типа DWORD NoPropertiesMyComputer присвоить значение 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer.

Политика: Конфигурация пользователя → Административные шаблоны → Рабочий стол → Удалить пункт «Свойства» из контекстного меню значка «Компьютер»

Файлы, хранящиеся на этом компьютере

По умолчанию Компьютер показывает категорию Файлы, хранящиеся на этом компьютере, в которой отображаются Общие документы, Документы - (Имя пользователя). Чтобы удалить эту категорию, нужно удалить параметр {59031a47-3f72-44a7-89c5-5595fe6b30ee} в разделе

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\DelegateFolders

Добавить корзину в папку Компьютер

Чтобы добавить значок Корзины в Компьютер, необходимо зайти в раздел

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace
и добавить подраздел {645FF040-5081-101B-9F08-00AA002F954E}

Мобильное устройство

Если вы хотите убрать значок Мобильное устройство из папки Компьютер, то удалите его идентификатор из раздела HKLM\Software\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\Namespace. Определение идентификатора - ваша задача.


Disk utilities

Дисковые утилиты

Если выбрать пункт Свойства в контекстном меню диска в окне Компьютер и перейти на вкладку Сервис, то там присутствует возможность запуска некоторых дисковых утилит. Можно прописать туда свои программы вместо установленных по умолчанию. Откройте раздел HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer. В этом разделе уже могут находиться некоторые подразделы, отвечающие за дисковые утилиты. Если их нет, то создайте их сами и в значениях по умолчанию этих разделов задайте путь к вашему приложению.

  • Для утилиты Очистка диска создать подраздел cleanuppath
    По умолчанию используется %SystemRoot%\System32\cleanmgr.exe /D %c
  • Для утилиты Проверка диска - подраздел ChkDskPath
    По умолчанию используется %SystemRoot%\system32\chkdsk.exe %c:
  • Для утилиты Дефрагментация диска - подраздел DefragPath
    По умолчанию используется %systemroot%\system32\dfrgui.exe
  • Для утилиты Архивация данных используется подраздел BackupPath
    По умолчанию используется %SystemRoot%\system32\sdclt.exe

Чтобы вернуться к прежнему состоянию, нужно либо установить значения по умолчанию (приводятся выше), либо удалить эти подразделы.


Мои документы

Запрет на изменение пользователем местоположения папки Мои документы

Если вы не хотите, чтобы пользователь мог перемещать и переименовывать папку Мои документы в Проводнике и Мой компьютер, то создайте параметр типа DWORD DisablePersonalDirChange со значением 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer (не путайте папку Мои документы с элементом ActiveX Мои документы). После перезагрузки компьютера три кнопки (По умолчанию, Переместить, Найти папку) исчезнут, а сама текстовая строка, указывающая на путь, будет доступна только для чтения.

Подсказка

Когда вы подводите курсор к значку Мои документы на Рабочем столе, то появляется всплывающая подсказка. Для ее изменения в разделе

HKCR\CLSID\{450D8FBA-AD25-11D0-98A8-0800361B1103}\
используйте строковый параметр InfoTip, в котором укажите желаемую строку (например, "Здесь хранятся секретные материалы")

Удаление значка Мои документы из Рабочего стола, Проводника и диалоговых окон открытия и открытия файлов

Чтобы удалить значок Мои документы из Рабочего стола, Проводника и диалоговых окон открытия и открытия файлов, добавьте параметр типа DWORD {450D8FBA-AD25-11D0-98A8-0800361B1103} со значением 1 в раздел HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\NonEnum


Оболочка Windows

Отключение анимации общих элементов управления и окон

Если ваш компьютер не слишком мощный, то можно отключить все эффекты, связанные с анимацией окон, которые потребляют дополнительные ресурсы. Присвойте параметру типа DWORD TurnOffSPIAnimations значение 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer.

Политика: Конфигурация пользователя → Административные шаблоны → Компоненты Windows → Проводник Windows → Отключить анимацию общих элементов управления и окон

Значок открытой папки

В Проводнике в левой панели стандартные папки отображаются в двух состояниях: папка открыта или закрыта. Кроме того, папка, содержимое которой открыто в правой части панели Проводника, считается активной и имеет выделенное состояние. Но, при большом количестве папок активная папка не сразу бросается в глаза. Можно поступить следующим образом – присвоить папке, имеющей статус Активная, свой заметный значок. Обратите внимание, что данная настройка будет работать не только в Проводнике, но и в меню Все программы кнопки Пуск, а также в редакторе реестра, который также использует древовидный интерфейс Проводника.

Откройте раздел HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer и создайте новый раздел Shell Icons (если данный раздел у вас уже существует, то пропустите данный шаг). В созданном разделе создайте новый строковый параметр 4. Созданному параметру необходимо присвоить значение, указывающее на путь к значку. Вы можете указать местоположение к своему файлу на диске или использовать уже имеющиеся значки, которые зашиты во многие DLL-библиотеки. В качестве примера попробуйте использовать строку C:\Windows\System32\shell32.dll,-246. В этому случае для активной папки будет использоваться красивая зеленая круглая кнопка со стрелкой.

Чтобы изменения вступили полностью, желательно полностью перезагрузить компьютер. Если вы захотите восстановить прежнюю функциональность, то удалите строковый параметр 4 в разделе Shell Icons.

Оболочка Windows

Надоел Проводник в качестве оболочки Windows? Можно поставить любую программу, которая будет служить в качестве такой оболочки, например, progman.exe, входящий в стандартную поставку Windows. Для этого поменяйте значение параметра Shell на progman.exe в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System Когда захочется вернуть все назад, поменяйте указанное значение на explorer.exe


Панель навигации

Скрытие значка Библиотеки

Если вы хотите убрать значки Библиотеки из панели навигации, то в разделе реестра HKEY_CLASSES_ROOT\CLSID\{031E4825-7B94-4dc3-B131-E946B44C8DD5}\ShellFolder измените значение параметра типа DWORD Attributes на b090010d. После перезагрузки компьютера в панели навигации Проводника вы уже не увидите значка Библиотеки, хотя сами библиотеки останутся на месте и будут доступны. Если вы хотите восстановить значение по умолчанию и вернуть значки Библиотеки на место, то используйте значение b080010d.

Скрытие значка Домашняя группа

Чтобы скрыть значок Домашняя группа из панели навигации Проводника, необходимо в разделе реестра HKEY_CLASSES_ROOT\CLSID\{B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}\ShellFolder изменить значение параметра типа DWORD Attributes на b094010c. После перезагрузки компьютера значок из панели навигации Проводника исчезнет. Чтобы вернуть значок на место, установите для данного параметра значение b084010c.

Скрытие значка Компьютер

Мы можем скрыть также значок Компьютер из панели навигации Проводника. Для данной операции необходимо в разделе HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\ShellFolder изменить значение параметра типа DWORD Attributes на b094010c. После перезагрузки компьютера значок из панели навигации Проводника исчезнет. Чтобы вернуть значок на место, установите для данного параметра значение b084010c.

Следует отметить, что при использовании описанного трюка исчезнет значок Компьютер и с Рабочего стола.

Скрытие значка Сеть

Теперь займемся удалением значка Сеть из панели навигации. В разделе HKEY_CLASSES_ROOT\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}\ShellFolder изменить значение параметра типа DWORD Attributes на b0940064. После перезагрузки компьютера значок из панели навигации Проводника исчезнет. Чтобы вернуть значок Сеть на место, установите для данного параметра значение b0040064.

Скрытие значка Избранное

Следующим объектом для экспериментов станет значок Избранное. В разделе HKEY_CLASSES_ROOT\CLSID\{323CA680-C24D-4099-B94D-446DD2D7249E}\ShellFolder вам нужно изменить значение параметра типа DWORD Attributes на a9400100. После перезагрузки компьютера значок из панели навигации Проводника исчезнет. Чтобы вернуть значок Избранное на место, установите для данного параметра значение a0900100.


Настройка предварительного просмотра

Настройка предварительного просмотра (Windows Vista)

Панель предварительного просмотра, появившаяся в операционной системе Vista, отображает содержимое файлов непосредственно в окне Проводника. Однако это доступно для текстовых файлов и документов из пакета MS Office, а также графических файлов. Можно ли добавить свои типы файлов в этот список?

Чтобы расширить этот перечень, нужно внести изменения в реестр. Например, если вы хотите, чтобы файлы CSS отображались в окне предварительного просмотра в виде текста, зайдите в раздел HKCR\.css и посмотрите на значение - он ссылается на раздел CSSfile. Переходим в этот раздел и создаем в нем новый раздел shellex и подраздел {8895b1c6-b41f-4c1c-a562-0d564250836}. Это имя означает создание нового параметра для предварительного просмотра. Чтобы задать текстовый редактор для предпросмотра, нужно посмотреть его значение в разделе HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\PreviewHandlers. Так например, значение {1531d583-8375-4d3f-b5fb-d23bbd169f22} соответствует значению текстового редактора. Если указать этот параметр в качестве значения по умолчанию в созданном нами разделе, файлы с расширением CSS будут отображаться в виде текста в окне предпросмотра. То же самое можно проделать и с другими типами файлов, которые вы хотели бы видеть в окне предпросмотра.

Источник: журнал Chip


Системные папки

Системные и специальные папки

Пользовательские папки

Если в Проводнике открыть пользовательскую папку (C:\Пользователи\ИмяПользователя), то можно увидеть в ней ряд специальных папок с собственными значками, например, папки Контакты, Загрузки, Сохраненные игры и т.д.

Мы можем настроить значки для некоторых папок по собственному вкусу, но Windows не предоставляет механизма для прямого вмешательства в настройки папки. Поэтому нам на помощь снова придет редактор реестра.

Контакты

Стандартными средствами мы не сможем установить свой значок для папки Контакты, так как в свойствах папки отсутствует вкладка Настройки. Чтобы вернуть вкладку на место, нужно в разделе HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions\{56784854-C6CB-462B-8169-88E350ACB882}\PropertyBag поменять у параметра типа DWORD NoCustomize значение на 0. Теперь если вы вызовите контекстное меню у папки и выберите команду Свойства, то в открывшемся диалоговом окне Свойства: Контакты увидите новую вкладку Настройка, при помощи которой сможете выбрать новое изображение для папки. Соответственно, чтобы снова скрыть вкладку Настройка, нужно присвоить параметру NoCustomize значение 1.

Рабочий стол

Папка Рабочий стол также не имеет вкладки Настройка в диалоговом окне Свойства: Рабочий стол. Поэтому поступаем аналогичным способом – находим раздел, соответствующий этой папке и меняем в подразделе PropertyBag значение параметра NoCustomize на 0. Полный путь к подразделу выглядит следующим образом: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions\{B4BFCC3A-DB2C-424C-B029-7FE99A87C641}\PropertyBag. Соответственно, чтобы снова скрыть вкладку Настройка, присвойте обратно параметру NoCustomize значение 1.

Смена размещения специальных папок

В Windows можно поменять место расположения системных и специальных папок (Принтеры, Рабочий стол, Избранное, SendTo и т.п.). Но просто так перенести их в другое место не удастся - при следующей загрузке они опять восстановятся на старом месте. Это связано с тем, что пути к этим папкам прописаны в реестре. Чтобы настроить расположение этих папок на вашем жестком диске, зайдите в раздел HKCU\Software\ Microsoft\Windows\CurrentVersion\Explorer\Shell Folders или HKCU\Software\ Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders и поменяйте путь для нужных вам папок. Затем их можно будет спокойно перенести по прописанному вами адресу.

После перезагрузки изменения вступят в силу

Изменение пути для папки Program Files

Если вы хотите сохранять приложения в отдельный раздел, надо изменить стандартный путь папки "Program Files". Для этого в разделе HKLM\Software\ Microsoft\Windows\CurrentVersion укажите в параметре ProgramFilesDir букву диска, соответствующую разделу приложений. То же самое необходимо проделать со значением ProgramFilesPath.


Библиотеки

Как поменять значок у Библиотеки в Windows 7

Если у вас возникло желание поменять стандартный значок Библиотеки Windows, то перейдите в раздел HKCR\CLSID\{031E4825-7B94-4dc3-B131-E946B44C8DD5}\DefaultIcon, далее выберите в нем значение по умолчанию и пропишите для него полный путь к вашему значку.

В качестве значка нужно использовать стандартные значки размером 256x256, которые используются в Windows 7. Как вариант, вы можете использовать уже имеющиеся значки системы, которые зашиты в файлах библиотек или исполняемых файлах. Для удобства можно использовать различные приложения для просмотра таких значков в файлах, в частности очень удобна для этих целей программа IconViewer. Вам остается только узнать номер значка, под которым он прописан в файле и установить это значение для параметра по умолчанию. В частности, система использует для Библиотеки значок под номером 1023 из файла C:\Windows\System32\imageres.dll. Попробуйте установить другие значения для экспериментов. Вот один из вариантов:

%SystemRoot%\system32\imageres.dll,-1027

Как отключить значок Библиотеки в Windows 7

Для решения этой задачи достаточно удалить идентификатор Библиотеки {031E4825-7B94-4dc3-B131-E946B44C8DD5} из раздела HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace.

Отключение Библиотек

Отключение Библиотек потребует больших усилий. Нужно не только скрыть значки всех библиотек, но и удалить некоторые дополнительные параметры в разных разделах реестра. Пример для REG-файла:

Windows Registry Editor Version 5.00

; Отключение Библиотек в Windows 7

[-HKEY_CLASSES_ROOT\CLSID\{031E4825-7B94-4dc3-B131-E946B44C8DD5}]

[-HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{031E4825-7B94-4dc3-B131-E946B44C8DD5}]

[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace\{031E4825-7B94-4dc3-B131-E946B44C8DD5}]

[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions\{2112AB0A-C86A-4ffe-A368-0DE96E47012E}]

[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions\{491E922F-5643-4af4-A7EB-4E7A138D8174}]

[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions\{7b0db17d-9cd2-4a93-9733-46cc89022e7c}]

[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions\{A302545D-DEFF-464b-ABE8-61C8648D939B}]

[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions\{A990AE9F-A03B-4e80-94BC-9912D7504104}]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\NewStartPanel]
“{031E4825-7B94-4dc3-B131-E946B44C8DD5}”=-

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\ClassicStartMenu]
"{031E4825-7B94-4DC3-B131-E946B44C8DD5}"=-

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\NewStartPanel]
"{031E4825-7B94-4DC3-B131-E946B44C8DD5}"=-

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\ClassicStartMenu]
"{031E4825-7B94-4DC3-B131-E946B44C8DD5}"=-

Значок Новая библиотека

Когда вы находитесь в папке Библиотеки, то при помощи кнопки меню Создать библиотеку (или через контекстное меню Создать | Библиотека) вы можете создать значок Новая библиотека. Вы можете при помощи реестра настроить вид создаваемого значка для новых библиотек. Идем в раздел HKEY_CLASSES_ROOT\CLSID\{14074e0b-7216-4862-96e6-53cada442a56}\Instance\InitPropertyBag и меняем значение параметра DefaultIcon, в котором нужно указать полный путь к вашему значку. Также вы можете использовать системные значки Windows 7 из DLL-файлов (например, из файла C:\Windows\System32\imageres.dll). Для эксперимента можете воспользоваться значением:

%SystemRoot%\system32\imageres.dll,-1008

Если вы хотите вернуться к настройкам по умолчанию, то используйте значок под номером 1001:

%SystemRoot%\system32\imageres.dll,-1001

Смотри также

Скрыть значок Библиотеки в панели навигации Проводника

Для смены значков в самой Библиотеке использовать реестр не нужно, можно обойтись обычным Блокнотом. О том, как поменять значки Библиотек, можно узнать из электронного справочника Windows.Народные советы, который доступен для скачивания с моего сайта http://user.alexanderklimov.ru


Default Icon for Unknown File Types

Значок для неизвестных типов файлов

Для неизвестных типов файлов используется специальный значок из ресурсов файла shell32.dll,0.

Чтобы изменить этот значок на любой свой, нужно в разделе HKCR\Unknown\DefaultIcon для параметра по умолчанию вместо %SystemRoot%\System32\shell32.dll,0 выбрать другой путь к значку или к ресурсу в файле, например, shell32.dll, 224


Правильная настройка вида папок в Windows Vista

В проводнике Windows Vista произошло множество улучшений по сравнению с Windows XP. Однако некоторые болячки предыдущей операционной системы перекочевали в Vista. В частности одной из наиболее раздражающих проблем является неспособность ОС отображать вид папок таким, каким хотят его видеть пользователи. В первую очередь речь о "забывчивости" Vista, теряющей пользовательские настройки вида. К этому примешивается и не всегда верное определение шаблона папки в зависимости от находящихся в ней файлов, что является нововведением в Vista. О том, как настроить вид папок и избежать неудобств при работе с ними, пойдет речь ниже.

Сброс вида папок Windows Vista

Если вы уже столкнулись с тем, что Vista не запоминает устанавливаемый вами вид папок, то придется сбросить его и начать все сначала. Проблема тут в том, что ОС может запомнить настройки лишь ограниченного количества папок, которое, впрочем, можно увеличить. Сбросить настройки вида папок можно двумя способами.

Способ 1 - В панели управления откройте Свойства папки, перейдите на вкладку Вид и нажмите кнопку Сброс вида папок.

Способ 2 - Этот способ сводится к удалению параметров реестра, в которых хранятся настройки вида папок. В частности, требуется удалить параметры Bags и BagMRU из разделов:

HKCU\Software\Microsoft\Windows\ShellNoRoam
HKCU\Software\Microsoft\Windows\Shell
HKCU\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\

Отключение автоматического присвоения шаблонов для папок Windows Vista

Речь о шаблонах, которые вы можете задать для папки в ее свойствах на вкладке Настройка. Windows Vista автоматически присваивает папкам шаблон на основании их содержимого. Иногда ОС определяет шаблон правильно, иногда ошибается. Когда ошибается - это раздражает. Поэтому автоопределение можно отключить через реестр. Для этого в разделе HKCU\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags необходимо создать подраздел AllFolders, а в нем подраздел Shell, в котором нужно создать строковой параметр FolderType и присвоить ему значение NotSpecified.

Вместо параметра NotSpecified можно указать некоторые другие, и тогда ОС будет автоматически присваивать указанный шаблон.

Параметр | Описание
NotSpecified | Все элементы
Contacts | Контакты
Music | Подробности о записи
MusicIcons | Значки музыки
Documents | Документы
Pictures | Изображения и видео

Увеличение кэша памяти для вида папок Windows Vista

Можно увеличить количество папок, для которых Vista будет запоминать настройки вида. В разделе HKCU\Software\Classes\Local Settings \Software\Microsoft\Windows\Shell\Bags\AllFolders\Shell необходимо создать параметр DWORD BagMRU Size и присвоить ему десятичное значение, скажем, 20000.

Запоминание параметров отображения каждой папки Windows Vista

По умолчанию Vista запоминает параметры отображения каждой папки. Впрочем, убедитесь, что у вас в Панель управления - Свойства папки - Вид установлен флажок Помнить параметры отображения каждой папки.

В реестре за это отвечает параметр DWORD NoSaveSettings в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer, для которого нужно установить значение 0.

Автор: Вадим Стеркин
Источник: vadikan.spaces.live.com


Контекстное меню Проводника

Блокировка контекстного меню

Чтобы сделать недоступным контекстное меню Проводника при щелчке правой кнопкой мыши, в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer создайте DWORD-параметр NoViewContextMenu со значением 1.

Удаление команды Создать

Если вы хотите удалить команду Создать из контекстного меню Проводника, то удалите строковый параметр {D969A300-E7FF-11d0-A93B-00A0C90F2719} в разделе

HKCR\Directory\Background\shellex\ContextMenuHandlers\New

Новые пункты "Копировать в папку" и "Переместить в папку" (Windows 2000/XP)

Зачастую, возможностей стандартного контекстного меню файлов не хватает для различных задач пользователей. В Windows 2000/XP можно добавить еще пару пунктов, которые заложены в самой операционной системе, но по умолчанию не включены.

В реестре Windows существует два раздела {C2FBB630-2971-11d1-A18C-00C04FD75D13} и {C2FBB631-2971-11d1-A18C-00C04FD75D13}, которые отвечают за копирование и перемещение файлов в Windows. Эти две возможности, Копировать в папку и Переместить в папку, можно включить в контекстное меню файлов.

Эти два пункта вызывают стандартное окно для копирования или перемещения файла, пользоваться которыми порой гораздо удобнее, чем открывать отдельное окно с нужным каталогом, а потом перетаскивать в него файлы.

Чтобы включить новые пункты в контекстное меню надо создать разделы и параметры в реестре:

для копирования: установить значение по умолчанию равным {C2FBB630-2971-11d1-A18C-00C04FD75D13} в разделе

HKCR\*\shellex\ContextMenuHandlers\Copyto

для перемещения: установить значение по умолчанию равным {C2FBB631-2971-11d1-A18C-00C04FD75D13} в разделе

HKCR\*\shellex\ContextMenuHandlers\Moveto

В этом случае пункты меню появятся у всех файлов и папок. Чтобы добавить их только в файлы с конкретным расширением, надо добавлять записи в раздел shellex этих файлов. Так, для текстовых файлов это будет выглядеть таким образом:

для копирования
[HKCR\txtfile\shellex\ContextMenuHandlers\Copyto]
@="{C2FBB630-2971-11d1-A18C-00C04FD75D13}"

для перемещения
[HKCR\txtfile\shellex\ContextMenuHandlers\Moveto]
@="{C2FBB631-2971-11d1-A18C-00C04FD75D13}"

Изначально раздела shellex там нет. Надо создать его и все подразделы самостоятельно.

Запуск от имени администратора

Если щелкнуть правой кнопкой мыши в Проводнике на исполняемом файле или его ярлыке, то в контекстном меню появляется команда Запуск от имени администратора (Run as... ). Чтобы запретить появление этой команды, нужно в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer создать DWORD-параметр HideRunAsVerb со значением 1

Отправить

Удаление команды Отправить

Если вы хотите скрыть команду Отправить, то присвойте пустое значение параметру по умолчанию в разделе HKCR\AllFilesystemObjects\shellex\ContextMenuHandlers\Send To.

Удаление списка дисков из меню Отправить

Меню Отправить обычно используется для пересылки файлов по электронной почте, но редко используется для перенаправления файлов на другие диски. Поэтому список дисков является для многих лишним. Однако в папке Отправить записей, отвечающих за диски, не существует. Для удаления списка дисков в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer создайте параметр DWORD NoDrivesInSendToMenu со значением 1.


Вкладка "Подробно"

У файлов и папок при вызове диалогового окна Свойства через контекстное меню есть вкладка Подробно.

Удаление вкладки Подробно

Чтобы удалить вкладку Подробно, нужо удалить подраздел {883373C3-BF89-11D1-BE35-080036B11A03} из ветви реестра HKCR\*\shellex\PropertySheetHandlers

Тонкая настройка

Вы можете настроить содержимое, которое будет выводиться на вкладке Подробно для определенного файла. Чтобы определить поля, которые будут отображаться на вкладке Подробно определенного файла, достаточно воспользоваться параметром строкового типа FullDetails. Данный параметр имеет следующий формат:

prop:«отображаемые метаданные;отображаемые метаданные;отображаемые метаданные»

В качестве метаданных параметр FullDetails поддерживает ключевые слова, добавляющие определенные поля на вкладку Подробно:

System.Attributes — атрибуты файла или папки;
System.Author — автор файла;
System.Capacity — общий объем папки;
System.ComputerName — имя компьютера;
System.Comment — комментарий;
System.Copyright — авторские права на файл;
System.DateModified — дата изменения файла;
System.DateCreated — дата создания файла;
System.DateAccessed — дата последнего доступа к файлу;
System.DisplayName — имя файла;
System.DisplayFolder — путь к папке, в которой хранится файл;
System.DisplayType — описание типа файла;
System.FileCount — количество файлов в папке;
System.FreeSpace — количество свободного места на диске;
System.Keywords — теги файла;
System.Language — язык, на котором создан файл;
System.OfflineAvailability — доступен ли файл автономно;
System.PercentFull — количество использованного места на диске;
System.Rating — рейтинг;
System.Size — размер;
System.TotalFileSize — общий размер папки;
System.Audio.EncodingBitrate — битрейт музыкального файла;
System.Document.PageCount — количество страниц текстового файла;
System.DRM.IsProtected — защищен ли файл механизмом DRM;
System.Link.Target — путь к файлу, на который указывает ссылка;
System.Link.Description — описание ссылки;
System.Link.DateVisited — дата последнего использования ссылки;
System.File.Owner — владелец файла;
System.File.Description — описание файла;
System.File.Version — версия файла;
System.Image.HorizontalSize — ширина изображения;
System.Image.VerticalSize — высота изображения;
System.Image.BitDepth — глубина изображения;
System.Music.Artist — исполнитель музыкального файла;
System.Music.AlbumTitle — альбом, в который входит данный музыкальный файл;
System.Music.TrackNumber — номер музыкального файла в альбоме;
System.Music.Genre — жанр музыкального файла.

Параметр FullDetails может находиться в одной из следующих ветвей реестра:

  • HKEY_CLASSES_ROOT\* — метаданные отображаются для всех файлов;
  • HKEY_CLASSES_ROOT\Unknown — для незарегистрированных файлов;
  • HKEY_CLASSES_ROOT\AllFilesystemObjects — для всех возможных файлов и объектов операционной системы;
  • HKEY_CLASSES_ROOT\Folder — для всех папок;
  • HKEY_CLASSES_ROOT\Directory — для всех папок, содержащих файлы.

А также в конкретных расширениях файлов, например, в разделе HKCR\SystemFileAssociations\.xps хранится информация для файлов XPS


Вкладка "Предыдущие версии"

В контекстном меню свойств папки и документов также имеется вкладка Предыдущие версии, с помощью которой можно восстановить папку или файл к тому состоянию, которое они имели до создания точки отката. Можно использовать несколько настроек параметров в реестре для управления вкладкой Предыдущие версии. Все настройки они хранятся в разделе реестра HKCU\Software\Policies\Microsoft\PreviousVersions, который может содержать следующие параметры типа DWORD (для включения настроек используем значение 1):

  • DisableBackupRestore — запрещается использование вкладки Предыдущие версии для восстановления файла из резервной копии;
  • DisableLocalPage — запрещается отображение вкладки для локальных файлов и папок;
  • DisableLocalRestore — запрещается использование вкладки Предыдущие версии для восстановления файла с помощью копий, расположенных на локальном диске;
  • DisableRemotePage — запрещается отображать вкладку Предыдущие версии для сетевых папок и файлов;
  • DisableRemoteRestore — запрещается использование вкладки Предыдущие версии для восстановления файла с помощью копий, расположенных на сетевых каталогах;
  • HideBackupEntries — запрещается использование вкладки Предыдущие версии для восстановления файла из копий, хранящихся на съемных носителях.
Политика: Конфигурация компьютера (Конфигурация пользователя) → Административные шаблоны → Компоненты Windows → Проводник Windows
→ Запретить восстановление предыдущих версий из резервных копий
→ Скрыть список предыдущих версий для локальных файлов
→ Запретить восстановление локальных предыдущих версий
→ Скрыть список предыдущих версий для удаленных файлов
→ Запретить восстановление удаленных предыдущих версий
→ Скрыть предыдущие версии файлов в архиве

Вкладку можно скрыть "грубым способом": в разделе HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\PropertySheetHandlers нужно удалить подраздел {596AB062-B4D2-4215-9F74-E9109B0A8153} и перезагрузить компьютер.


Добавление нового пункта в меню "Создать"

Общая теория

За команды в контекстном меню Создать отвечает раздел ShellNew в разделе HKEY_CLASSES_ROOT. Вам нужно найти необходимое расширение файла (напр.. .doc) и изучить раздел ShellNew. Вы можете либо удалить ее, чтобы скрыть команду из контекстного меню, либо добавить свои команды.

Пункт контекстного меню "Создать" появляется, если щелкнуть на Рабочем столе или в Проводнике на свободном месте открытой папки. Существует возможность добавления нового пункта в это меню. Например, если вы веб-дизайнер, то было бы удобно иметь пункт Документ HTML, который позволит вам сразу создать заготовку для вашей странички.

Разобъем работу на несколько этапов. Для начала найдем каталог ShellNew в папке Windows. Там хранятся заготовки для файлов, которые создаются с помощью контекстного меню. Например, если у вас установлен Microsoft Office, то вы увидите в этом каталоге файлы-заготовки для Word и Exce.

Следующий шаг - создайте в папке файл, например index.html. Внутри него напишите шаблон вашей странички. Например, так:

<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=windows-1251">
<title>Мой заголовок</title>
</head>
<body>

</body>
</html>

Третий этап. Работаем с реестром. Итак, ищем раздел HKEY_CLASSES_ROOT\.html и создаем раздел ShellNew. В этом разделе создаем строковый параметр FileName в качестве значения которого надо указать имя созданного нами шаблона (index.html). После перезагрузки в контекстном меню появится новый пункт.

Существуют и другие способы. Можно не создавать шаблон файла. Он может быть и пустым, но тогда вместо параметра FileName надо создать пустой строковый параметр NullFile.

Еще FileName можно заменить параметром Data. Тип у него может быть любой - строковый или двоичный, в зависимости от данных шаблона. Содержимое параметра Data будет записано в файл. Фактически, это полный аналог FileName, только в нем шаблон хранится в виде файла, а тут шаблон хранится в реестре. Лучше, конечно, не раздувать реестр и пользоваться FileName, но если размер шаблона всего несколько байтов, то уместнее использовать параметр Data.

Следующий вариант - предоставить возможность создания файла программе. Указываем строковый параметр Command. В Command просто пишем в кавычках полный путь к файлу программы, пробел и (тоже в кавычках) макрос %1 (он будет заменён на имя только что созданного файла), например, "c:\windows\notepad.exe" "%1". Теперь созданный файл будет сразу открываться в указанной программе.

Параметры FileName, Data, NullFile, Command все вместе использовать нельзя, можно применять только один из них.

Смотри также

Добавление нового пункта в меню "Создать"


Новый ярлык

В Проводнике или Мой компьютер через меню Файл-Создать-Ярлык вы можете получить доступ к дискам компьютера, даже если вы отключили контекстное меню Проводника. Чтобы не допустить появления мастера создания нового ярлыка, удалите или переименуйте раздел:

HKCR\.lnk\ShellNew

Возможность создания нового ярлыка сохранится, но доступ к дискам будет перекрыт


Панель инструментов

Настройка панели инструментов

Если щелкнуть правой кнопкой мыши на панели инструментов, то появлятся всплывающее меню, содержащее пункт Настройка, который позволяет настраивать панель инструментов. Чтобы скрыть этот пункт, создайте параметр типа DWORD NoToolbarCustomize со значением 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Подобный пункт будет удален также и в Internet Explorer

Замена фона в панели инструментов в Проводнике

Существует возможность установки своего фона для панели инструментов в Проводнике. Для этого в разделе реестра

HKCU\SOFTWARE\Microsoft\Internet Explorer\Toolbar
создайте строковый параметр BackBitmapShell, значением которого будет полное имя BMP-файла с нужной картинкой - она и замостится мозаикой на панелях окон.

Для замены фона не только в Проводнике, но и в Internet Explorer смотрите Замена фона в панели инструментов в Internet Explorer

Удаление кнопки Поиск из Проводника

Проводник Windows содержит кнопку Поиск на панели инструментов. Для удаления данной кнопки используйте параметр DWORD NoShellSearchButton со значением равным 1 в разделе

HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer

Также будет удалена эта кнопка из окна Мои документы, и других мест, использующих оболочку Windows


Меню Проводника

Удаление пункта меню Файл из Проводника

Для удаления пункта меню Файл из Проводника используйте DWORD-параметр NoFileMenu со значением 1 в разделе HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer

Также будет удален этот пункт из окна Мои документы, Internet Explorer и других мест, использующих оболочку Windows

Политика: Конфигурация пользователя → Административные шаблоны → Компоненты Windows → Проводник Windows → Удалить меню "Файл" из проводника Windows

Вкладка Настройка

Чтобы скрыть вкладку Настройка из свойств папки, используйте параметр типа DWORD NoCustomizeWebView со значением 1 в разделе HKCU\Software\Microsoft\Windows\ CurrentVersion\Policies\Explorer


Установка классического вида

Установка классического вида в Проводнике

Проводник Windows содержит пункты меню, как Переход и Избранное, которые отражают новые Web-возможности Windows. Если нет необходимости использовать новые возможности, то можно использовать классический стиль окон оболочки и проводника, добавив параметр ClassicShell со значением DWORD равным 0x00000001 в раздел

HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer


Связанные документы

В последних версиях Windows появилось понятие сопоставленных файлов. Например, если вы собираетесь переместить или удалить html-документ, то будут также перемещены или удалены и сопоставленные с этим документом файлы, которые содержаться в папке ИмяДокумента.files. Если вы хотите отключить подобное поведение, то создайте параметр DWORD NoFileFolderConnection со значением 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer


Проводник как два отдельных процесса

Как известно, Проводник выступает и в качестве оболочки Windows, и в качестве файл-менеджера. И хотя это повышает удобство, на использовании памяти это сказывается отнюдь не лучшим образом. При нормальных условиях Проводник отнимает целых 8 Мбайт памяти Windows. Из-за проблем с выделением памяти Windows использует двойную квоту памяти для Проводника, считая ее используемой разными программами. Чтобы избавиться от этой проблемы, "интегрированной" в систему, надо запустить Проводник как два отдельных процесса вместо одного. Для этого нужно изменить значение параметра DWORD SeparateProcess в разделе

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Advanced
("0" - один процесс, "1" - два процесса)


HotTrackingColor

Изменение цвета файла при подведении мыши

Если в Проводнике используется веб-вид (в Windows XP этот стиль стоит по умолчанию), то при подведении курсора мыши к значку и имени файла или папки изменяется цвет текста. По умолчанию этот цвет совпадает со цветом выделенного файла. Можно задать другой цвет, отличающийся от цвета выделенного файла. Создайте строковый параметр HotTrackingColor в разделе

HKCU\Control Panel\Colors
Данный параметр должен содержать цвет в формате RGB, который является комбинацией трех цветов: красного, зеленого и голубого (например, 255 0 0).
Ниже приводится список некоторых цветов:
красный | 255 0 0
желтый | 255 255 0
зеленый | 0 255 0
голубой | 0 255 255
синий | 0 0 255
сиреневый | 255 0 255

После перезагрузки вы увидите, как изменяется цвет имени файла при наведении на него мыши.


Перезагрузка Windows

Перезагрузка после краха

Чтобы принудительно заставить Windows перегрузиться после краха в системе, измените значение параметра DWORD AutoReboot в разделе

HKLM\SYSTEM\CurrentControlSet\Control\CrashControl
с 0 на 1

Перезагрузка оболочки

По умолчанию при ошибках оболочки (Explorer) в Windows перезагружается вся операционнная система. Однако, существует возможность перезагружать только саму оболочку, тем самым не теряя данных, обрабатываемых другими приложениями. Для этого в разделе

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Winlogon
надо изменить параметр DWORD AutoRestartShell
  • 0 - перезагружается операционная система
  • 1 - перезагружается только оболочка


Диски

Порядок отображения названия и буквы диска

По умолчанию буква диска отображается справа от его метки, например, Локальный диск (C:). Можно настроить данное поведение при помощи параметра типа DWORD ShowDriveLettersFirst в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer. Данный параметр может принимать следующие значения:

  • 1 – отображать букву диска справа от его метки (по умолчанию);
  • 2 – не выводить букву диска;
  • 4 – отображать букву диска слева от метки

Изменение значков для разделов диска

Можно изменить вид значков и описание диска в окне Мой компьютер и Проводник. Для этого откройте раздел HKLM\Software\Microsoft\Windows\CurrentVersion\Explоrer и создайте новый подраздел DriveIcons. Далее в созданном подразделе необходимо создать подразделы с буквами дисков, чьи значки и описания вы собираетесь менять. Следующий шаг - создание в подразделах диска двух новых подразделов DefaultIcon и DefaultLabel. В этих подразделах нужно изменить значения по умолчанию. В первом случае нужно указать путь к значку,а во втором - описание диска. Например, вот как будет выглядеть параметры в реестре для диска С

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\DriveIcons\C\DefaultIcon]
@="explorer.exe,8"
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\DriveIcons\C\DefaultLabel]
@="Мой системный диск"

Скрытие значков дисков в окне Мой компьютер и Проводник

Если вы хотите скрыть значки дисков в окне Мой компьютер и Проводник, то откройте раздел HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer и создайте параметр NoDrives типа DWORD с требуемым значением. Также будут скрыты эти значки и в стандартных окнах Открытия и Сохранения файлов. Тем не менее, пользователь по-прежнему имеет доступ к этим дискам (через команду Выполнить или печатая вручную адрес в адресной строке Проводника)

Данный параметр является набором битовых флагов. Каждый бит соответствует одному из 26 возможных имен дисков. Каждому диску присваиваются значения (hex): A -1; B - 2; C - 4 и т.д. Чтобы скрыть нужные вам диски, нужно сложить эти биты. Сложность состоит в переводе двоичного значения в шестнадцатиричное. Здесь приводится небольшой список возможных значений

0x03FFFFFF | Скрывает все значки
0x3 | Скрывает только диски A и B
0x4 | Скрывает только диск C
0x8 | Скрывает только диск D
0x7 | Скрывает только диски A, B и C
0xF | Скрывает только диски A, B, C и D
0x0 | Видны все диски

Можно использовать и десятичную систему. Смотри совет ниже.

Запрет на доступ к содержимому выбранных дисков

Можно не скрывать сами значки дисков, но запретить пользователю доступ к файлам заданных дисков через Проводник, Мой компьютер, Выполнить или команду Dir. Откройте реестр и создайте параметр NoViewOnDrive типа DWORD в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer, содержащий битовую маску для дисков. Например, диск A имеет бит 1, диск С - 4, диск D - 8. Таким образом, чтобы скрыть диски A и D, нужно сложить их значения 1 (A) + 8 (D) и установить значение 9.
Список всех дисков:
A: 1, B: 2, C: 4, D: 8, E: 16, F: 32, G: 64, H: 128, I: 256, J: 512, K: 1024, L: 2048, M: 4096, N: 8192, O: 16384, P: 32768, Q: 65536, R: 131072, S: 262144, T: 524288, U: 1048576, V: 2097152, W: 4194304, X: 8388608, Y: 16777216, Z: 33554432, Все диски: 67108863

Вкладка Оборудование

Чтобы удалить вкладку Оборудование при просмотре свойств локального диска, создайте параметр типа DWORD NoHardwareTab со значением 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer.


Панель управления

Используем классический стиль Windows

Чтобы использовать Панель управления без визуальных стилей Windows XP, используйте параметр типа DWORD ForceClassicControlPanel со значением 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Запрет за запуск Панели управления и ее апплетов

Чтобы запретить запуск Control.exe, а также апплетов Панели управления, используйте параметр типа DWORD NoControlPanel со значением 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer Также будет удален пункт Панель управления из меню кнопки Пуск. При попытке запустить апплет будет выводиться соответствующее предупреждение.

Подсказка для Панели управления

Для изменения текста подсказки, возникающей при подведении курсора к значку Панель управления, необходимо изменить текст в строковом параметре InfoTip в разделе HKCR\CLSID\{21EC2020-3AEA-1069-A2DD-08002B30309D}. Значение по умолчанию: @%SystemRoot%\system32\shell32.dll,-31361

Смена значков компонентов Панели управления

Вы можете изменить любые значки компонентов, которые находятся на Панели управления. Делается это достаточно просто. Переходим в раздел HKEY_CLASSES_ROOT\CLSID и находим нужный раздел, который совпадает с номером идентификатора для компонента. У каждого такого раздела имеется подраздел DefaultIcon. Ваша задача – прописать для параметра по умолчанию путь к значку, который вы хотите видеть вместо стандартного значка. Ниже приводится справочная таблица идентификаторов, которая поможет вам быстро определить, к какому компоненту он относится:

{BB64F8A7-BEE7-4E1A-AB8D-7D8273F7FDB6} Action Center
{D20EA4E1-3957-11d2-A40B-OC5020524153}  Administrative Tools
{9C60DE1E-E5FC-4of4-A487-460851A8D915} Autoplay
{B98A2BEA-7D42-4558-8BD1-832F41BAC6FD} Backup and Restore
{D9EF8727-CAC2-4e60-809E-86F80A666C91} BitLocker Drive Encryption
{B2C761C6-29BC-4f19-9251-E6195265BAF1}  Color Management
{1206F5F1-0569-412C-8FEC-3204630DFB70} Credential Manager
{E2E7934B-DCE5-43C4-9576-7FE4F75E7480} Date and Time
{17cd9488-1228-4b2f-88ce-4298e93e0966}  Default Programs
{37efd44d-ef8d-41b1-940d-96973a50e9eo} Desktop Gadgets
{74246bfc-4c96-11d0-9bef-0020afgb0b7a}  Device Manager
{A8A91A66-3A7D-4424-8D24-04E180695C7A} Devices and Printers
  {C555438B-3C23-4769-A71F-B6D3D9B6053A} Display
{D555645E-D4F8-4c29-A827-D93C859C4F2A} Ease of Access Center
{6DFD7C5C-2451-11d3-A299-00C04F8EF6AF}  Folder Options
{BD84B380-8CA2-1069-AB1D-08000948F534} Fonts
{CB1B7F8C-C50A-4176-B604-9E24DEE8D4D1} Getting Started
{67CA7650-96E6-4fDD-BB43-A8E774F73A57} HomeGroup
{87D66A43-7B11-4A28-9811-C86EEE395ACF7} Indexing Options
{A3DD4F92-658A-410F-84FD-6FBBBEF2FFFE} Internet Options
{725BE8F7-668E-4C7B-8F90-46BDB0936430} Keyboard
{E9950154-C418-419e-A90A-20C5287AE24B} Location and Other Sensors
{5ea4f148-308c-46d7-98a9-49041b1dd468} Mobility Center
{6C8EEC18-8D75-41B2-A177-8831D59D2D50} Mouse
{8E908FC9-BECC-40f6-915B-F4CAOE70D03D} Network and Sharing Center
{05d7b0f4-2121-4eff-bf6b-ed3f69b894d9} Notification Area Icons
{96AE8D84-A250-4520-95A5-A46A7E3C548B}  Parental Controls
{78F3955E-3B90-4184-BD14-5397C15F1EFC}  Performance Information and Tools
{ED834ED6-485A-4bfe-8F11-A626DCB6A921}  Personalization
{40419485-C444-4567-851A-2DD7BFA1684D} Phone and Modem
{025A5937-A6BE-4686-A844-36FE4BEC8B6D}  Power Options
{7b81be6a-ce2b-4676-a29e-eb907a5126c5}  Programs and Features
{9FE63AFD-59CF-4419-9775-ABCC3849F861} Recovery
{62D8ED13-C9D0-4CE8-A914-47DD628FB1B0} Region and Language
{241D7C96-F8BF-4F85-B01F-E2B043341A4B} RemoteApp and Desktop Connections
{F2DDFC82-8F12-4CDD-B7DC-D4FE1425AA4D} Sound
{58E3C745-D971-4081-9034-86E34B30836A}  Speech Recognition
{9C73F5E5-7AE7-4E32-A8E8-8D23B85255BF}  Sync Center
{BB06C0E4-D293-4f75-8A90-CB05B6A77EEE}  System
{0DF44EAA-FF21-4412-828E-260A8728E7F1}  Taskbar and Start Menu
{C58C4893-3BE0-4B45-ABB5-A63E4B8C8651} Troubleshooting
{60632754-c523-4b62-b45c-4172da012619}  User Accounts
{78CB147A-98EA-4AA6-B0DF-C8681F69341C}  Windows Cardspace
{D8559EB9-20C0-410E-BEDA-7ED416AECC2A}  Windows Defender
{4026492F-2F69-46B8-B9BF-5654FC07E423}  Windows Firewall
{36eef7db-88ad-4e81-ad49-0e313f0c35f8} Windows Update


Панель управления: Скрытие и показ значков апплетов

Данные настройки позволяют скрыть отдельные значки апплетов Панели управления, либо наоборот, показать только разрешенные значки. Начнем с первого варианта. Он состоит из двух частей.

Если вы хотите скрыть отдельные значки в папке Панели управления, то создайте параметр DWORD DisallowCpl со значением 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
. Затем в этом же разделе нужно создать подраздел с таким же названием DisallowCpl. В созданном подразделе вы перечисляете апплеты, которые нужно скрыть при помощи строковых параметров следующего формата:
Номер REG_SZ Applet.cpl, т.е. сначала создаете строковый параметр, начиная с 1 и присваиваете ему имя апплета:
1 main.cpl
2 mmsys.cpl
и так далее

Существует другой вариант. Вы запрещаете показ всех значков апплетов, кроме некоторых. Настройка схожа с вышеприведенным примером. В этом же разделе создается параметр RestrictCpl со значением 1 и создается подраздел RestrictCpl, в котором вы перечисляете апплеты, которые разрешаете показывать в папке Панели управления.

Примечание: Данные настройки просто скрывают значки, но сами файлы присутствуют на компьютере и их можно запускать любым доступным способом.


Администрирование

Чтобы удалить апплет Панели управления Администрирование, откройте раздел

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel\NameSpace
и найдите там подраздел {D20EA4E1-3957-11d2-A40B-0C5020524153} и переименуйте данный подраздел, поставив минус перед ним -{D20EA4E1-3957-11d2-A40B-0C5020524153}


Дата и время

Украшение часиков

Украшаем часы. Идем в раздел HKCU\Control Panel\International и создаем строковый параметр sTimeFormat. Присвойте этому параметру слово, не превышающее 8 символом (например, свою фамилию), и оно отобразится вместо часов. Если вы не готовы к такому радикальному изменению, то предлагаю более мягкий вариант. В указанный параметр пишите "HH:mm Рыжик". В этом случае будет показываться и время и имя вашего любимого кота. Кстати, вместо стандартного разделителся -двоеточия (:) можете использовать и другие символы, например звездочку(*) или вообще обойтись без разделителя. Заодно можете поменять и формат - сначала минуты, потом часы - mm*HH

Можно применить и другой интересный эффект. В этом же разделе создаем еще два строковых параметра - s1159 и s2359 и присваиваем им слова, напр. Еще не вечер и Утро вечера мудреней. А в уже знакомом параметре sTimeFormat пишем HH:mm:ss tt (по-прежнему можно использовать другой разделитель). Теперь в утренние часы рядом с часиками будет надпись Еще не вечер, а с 12 до 24 часов соответственно Утро вечера мудреней

Примечание: Данные изменения могут проявиться и в других местах. Например, в Outlook Express при получении и отправке писем

Часовой пояс

В компоненте Панели управления Дата и время вы видите, что у вас часовой пояс Москвы, Санкт-Петербурга и Волгограда (или что-то в этом роде). Хотите, чтобы Windows знала о существовании вашей деревни Гадюкино? В разделе реестра HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Time Zones\Russian Standard Time меняем строковый параметр Display, введя название своей деревни. Щелкните на часиках в правом углу экрана и вы увидите в часовом поясе свою малую родину. Своей подружке скажите, что Билл Гейтс специально по вашей просьбе внес на карту название вашей деревни! :-)

Дополнительные часы

Вкладка «Дополнительные часы» компонента панели управления «Дата и время» предназначена для отображения времени других часовых поясов наряду с вашим. В операционной системе Windows 7 для установки дополнительных часов других часовых поясов, установите флажок «Показать эти часы», в раскрывающемся списке выберите нужный для вас часовой пояс и в текстовом поле «Отображаемое имя» введите название нового часового пояса. Для примера на следующем скриншоте видно, что добавлены двое дополнительных часовых пояса для Москвы и Нью-Йорка.

Добавлять дополнительные часы также можно при помощи реестра. В следующем примере, добавим дополнительные часы для часового пояса UTC +03:00 с названием «Москва»:

[HKEY_CURRENT_USER\Control Panel\TimeDate\AdditionalClocks\1]
"Enable"=dword:00000001
"DisplayName"="Москва"
"TzRegKeyName"="Russian Standard Time"

Параметр Enable указывает на то, что дополнительные часы будут отображаться.
Параметр DisplayName определяет строку, отображаемую напротив данных часов.
Параметр TzRegKeyName определяет часовой пояс, на основе которого работают данные дополнительные часы.

Автоматический переход на летнее время

При настройке часового пояса вы можете включить или отключить функцию перехода на летнее время. Для этого существует опция с флажком «Автоматически переходить на летнее время и обратно». Если флажок установлен, то при наступлении даты перехода на летнее или зимнее время, операционная система автоматически изменит время.

Для установки автоматического перехода на летнее время вы также можно воспользоваться параметром DynamicDaylightTimeDisabled со значением 0 или 1 в разделе HKLMA\SYSTEM\CurrentControlSet\Control\TimeZoneInformation.

Синхронизация с сервером времени в Интернете

В диалоговом окне «Настройка времени по Интернету» установите флажок на опции «Синхронизировать с сервером времени в Интернете», выберите нужный сервер времени или введите имя домена, и нажмите на кнопку «ОК».

Помимо этого, синхронизацию времени можно настроить при помощи некоторых параметров системного реестра, расположенных в разделе HKLM\SYSTEM\CurrentControlSet\Services\W32Time\ (смотри ниже)

Служба W32Time

W32Time — это встроенная служба Microsoft Windows, выполняющая синхронизацию авторизованного сервера времени с внешним источником времени. Авторизованный сервер времени — это контроллер домена, использующий службу W32Time для обеспечения синхронизации параметров даты и времени на компьютерах в пределах организации.

Чтобы внесенные изменения вступили в силу, службу W32Time необходимо остановить и запустить повторно.

Описываемые параметры находятся в разделе HKLM\SYSTEM\CurrentControlSet\Services\W32Time\Parameters

Параметры реестра, управляющие работой службы W32Time

  • AvoidTimeSyncOnWan - Необязательный параметр типа DWORD. Предотвращает синхронизацию с компьютером, который находится в другом узле. Может принимать два значения:
    0 - синхронизация выполняется независимо от узла источника времени [по умолчанию].
    1 - компьютер не синхронизируется с источником времени, который находится в другом узле.
  • GetDcBackoffMaxTimes - Необязательный параметр типа DWORD. Максимальное число попыток, предпринимаемых перед удвоением интервала отсрочки в случаях, когда не удается обнаружить контроллер домена. Каждый раз по истечении максимального интервала времени ожидания регистрируется соответствующее событие. Может принимать значения
    0 - между последовательными попытками устанавливается минимальный интервал; события не регистрируются.
    7 - [по умолчанию].
  • GetDcBackoffMinutes - Необязательный параметр типа DWORD. Исходное время ожидания (в минутах) перед поиском контроллера домена, если последняя попытка была неудачной. По умолчанию используется значение 15
  • LocalNTP - Параметр типа DWORD. Используется для запуска сервера SNTP.
    0 - не запускать сервер SNTP, если данный компьютер не является контроллером домена [по умолчанию].
    1 - всегда запускать сервер SNTP
  • NtpServer - Необязательный строковый параметр. Служит для настройки источника времени вручную. Содержит DNS-имя или IP-адрес NTP-сервера для синхронизации. Значение данного параметра можно изменить из командной строки с помощью команды net time. По умолчанию данному параметру не присваивается значение. Если необходимо указать несколько NTP-серверов, вводимые значения следует разделять пробелами.
  • Period - Параметр типа REG_DWORD или REG_SZ. Используется для управления частотой синхронизации времени. Если данный параметр является строковой величиной, ему может присваиваться одно из перечисленных ниже значений. Чтобы задать значение данного параметра в виде числа (например 65535), укажите при создании параметра тип REG_DWORD. Чтобы задать значение данного параметра в виде строки (например «Bidaily»), укажите при создании параметра тип REG_SZ.
    0 - один раз в день.
65535, «BiDaily» - один раз в 2 дня.
65534, «Tridaily» - один раз в 3 дня.
65533, «Weekly» - один раз в неделю (7 дней).
65532, «SpecialSkew» - каждые 45 минут, пока не будут выполнены 3 удачные синхронизации, затем каждые 8 часов (3 раза в день) [по умолчанию].
65531, «DailySpecialSkew» - каждые 45 минут до первой удачной синхронизации, затем один раз в день.
х - х раз в день.
  • ReliableTimeSource - Необязательный параметр типа DWORD. Указывает, может ли данный компьютер служить надежным источником времени. Может принимать значения
    0 - не отмечать данный компьютер как надежный источник времени [по умолчанию]
    1 - отметить данный компьютер как надежный источник времени (целесообразно использовать только на контроллере домена).

Интервал синхронизации системных часов

Сверка системных часов компьютера с сервером времени осуществляется через определенный интервал времени. Можно скорректировать величину интервала. Для этого в разделе HKLM\SYSTEM\CurrentControlSet\Services\W32Time\TimeProviders\NtpClient отредактируйте DWORD-параметр SpecialPollInterval. Значение данного параметра представляет собой величину интервала времени синхронизации системных часов. Оно выражается в секундах и по умолчанию составляет 604 800. Можно установить любой требуемый интервал (например, значение 43 200 будет равняться 12 ч.).

Существует такой же параметр SpecialPollInterval, который будет перекрывать значение описанного выше. Он находится в разделе HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\W32time\TimeProviders\NtpClient.

Политика: Конфигурация компьютера → Административные шаблоны → Система → Служба времени Windows → Поставщики времени → Настроить NTP-клиент Windows

Если вы не используете возможности синхронизации времени с интернет-серверами, то можете вообще удалить вкладку Время Интернета окна Дата и время, отвечающую за настройку данной возможности системы. Для этого нужно присвоить REG_DWORD-параметру Support Internet Time, расположенному в ветви реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\DateTime, значение, равное 0.


Защитник Windows

Microsoft SpyNet

Настройки присоединения к сообществу Microsoft SpyNet вы можете также указать при помощи системного реестра:

;Присоединиться к сообществу SpyNet
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender\SpyNet]
"SpyNetReporting"=dword:00000001
;Присоединиться в роли обычного участника
;"SpyNetReporting"=dword:00000001
;Присоединиться в роли опытного участника
;"SpyNetReporting"=dword:00000002
;Не присоединяться
"SpyNetReporting"=dword:00000000

По умолчанию программа Защитник Windows выполняет быструю проверку каждый день в восемь часов вечера. Вы можете изменить периодичность, время и еще множество настроек, перейдя в окно параметров программы.

Автоматическая проверка

На вкладке «Автоматическая проверка» вы можете задать тип и частоту выполнения проверки на компьютере.

Сняв флажок «Автоматически проверять компьютер», вы полностью отключаете защиту компьютера. В раскрывающихся списках «Частота», «Примерное время» и «Тип» вы можете изменять значения, которые указаны по умолчанию. Такого же результата вы можете добиться, изменив различные параметры в системном реестре:

;Автоматически проверять компьютер - частота
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender\Scan]
"ScheduleDay"=dword:00000000
;Еженедельно
;"ScheduleDay"=dword:00000000
;Понедельник
;"ScheduleDay"=dword:00000002
;Вторник
;"ScheduleDay"=dword:00000003
;Среда
;"ScheduleDay"=dword:00000004
;Четверг
;"ScheduleDay"=dword:00000005
;Пятница
;"ScheduleDay"=dword:00000006
;Суббота
;"ScheduleDay"=dword:00000007
;Воскресенье
;"ScheduleDay"=dword:00000001

;Примерное время (Пример - 09-00)
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender\Scan]
"ScheduleTime"=dword:0000021c

;Тип
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender\Scan]
"ScanParameters"=dword:00000001
;Быстрая проверка
;"ScanParameters"=dword:00000001
;Полная проверка
;"ScanParameters"=dword:00000002

Если установить флажок «Проверить на наличие установленных обновлений перед проверкой», то перед автоматической проверкой компьютера будет запускаться обновление. Также эту опцию можно установить с помощью реестра:

;Проверить на наличие установленных обновлений перед проверкой
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender\Scan]
"CheckForSignaturesBeforeRunningScan"=dword:00000001

Установив флажок на опции «Запускать проверку только в состоянии простоя», проверка будет выполняться только в том случае, если на момент автоматической проверки не будет выполняться никаких активных действий. Это также можно выполнить средствами системного реестра:

;Запускать проверку только в состоянии простоя
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender\Scan]
"ScanOnlyIfIdle"=dword:00000001

На вкладке действия по умолчанию, вы можете установить действия, которые будут выполняться при обнаружении шпионских или потенциально опасных программ для всех предусмотренных в Защитнике Windows уровней опасности. Для каждого из уровней доступны следующие действия: «Рекомендуемое действие на основе определений», «Удалить» или «Карантин»

Также доступна установка действий средствами реестра:

;Высокий уровень опасности
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender\Threats\ThreatSeverityDefaultAction]
"5"=dword:00000003
;Рекомендуемое действие на основе определений
;"5"=-
;Удалить
;"5"=dword:00000003
;Карантин
;"5"=dword:00000002

;Высокий уровень опасности
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender\Threats\ThreatSeverityDefaultAction]
"4"=dword:00000003
;Рекомендуемое действие на основе определений
;"4"=-
;Удалить
;"4"=dword:00000003
;Карантин
;"4"=dword:00000002

;Средний уровень опасности
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender\Threats\ThreatSeverityDefaultAction]
"2"=dword:00000003
;Рекомендуемое действие на основе определений
;"2"=-
;Удалить
;"2"=dword:00000003
;Карантин
;"2"=dword:00000002
;Разрешить
;"2"=dword:00000006

;Низкий уровень опасности
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender\Threats\ThreatSeverityDefaultAction]
"1"=dword:00000003
;Рекомендуемое действие на основе определений
;"1"=-
;Удалить
;"1"=dword:00000003
;Карантин
;"1"=dword:00000002
;Разрешить
;"1"=dword:00000006

Установив флажок «Применить рекомендуемые действия», программа Защитник Windows не будет вам выдавать запрос, а начнет сразу выполнять те действия, которые вы выставили в этом диалоге.

Также вы можете это сделать средствами реестра:

;Применить рекомендуемые действия
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender]
"DisableRoutinelyTakingAction"=dword:00000001

На вкладке «Защита в реальном времени», для того чтобы предотвратить запуск шпионских и потенциально опасных программ на компьютере, установите флажок «Использовать защиту в реальном времени». Средствами реестра это реализовывается следующим образом:

;Использовать защиту в реальном времени
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender\Real-Time Protection]
"DisableRealtimeMonitoring"=dword:00000000

Помимо этого вы можете установить флажки «Проверка загруженных файлов и вложений» и «Проверять выполняемые на компьютере программы» для выполнения соответствующих действий. Также это можно сделать при помощи системного реестра:

;Проверка загруженных файлов и вложений
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender\Real-Time Protection]
"DisableIOAVProtection"=dword:00000000

;Проверять выполняемые на компьютере программы
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender\Real-Time Protection]
"DisableOnAccessProtection"=dword:00000000

На вкладке «Исключенные файлы и папки» нажав на кнопку «Добавить» и выбрав из диалога «Обзор файлов и папок» определенные файлы или папки, вы можете исключить их из объектов для сканирования. Это также можно сделать при помощи системного реестра, где в названии параметра «ИМЯ_ПАПКИ» нужно ввести полный путь к папке или файлу, который будет исключен из сканирования.

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender\Exclusions\Paths]
"ИМЯ_ПАПКИ"=dword:00000000

Во вкладке «Исключенные типы файлов» вы можете добавлять расширения, которые не будут сканироваться. Добавляя только расширение файлов, в формате «*.jpg», операционная система автоматически определит тип файлов и добавит их в список. При помощи реестра исключать типы файлов можно следующим образом:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender\Exclusions\Extensions]
"JPG"=dword:00000000
"PNG"=dword:00000000
"PS1"=dword:00000000

На вкладке «Подробно» вы можете выбрать пять дополнительных вариантов для проверки вашего компьютера:

  • Проверять архивные файлы
  • Проверять электронную почту
  • Проверять съемные носители
  • Использовать эвристику
  • Создание точки восстановления

Все эти параметры можно настроить при помощи системного реестра следующим образом:

;Проверять архивные файлы
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender\Scan]
"DisableArchiveScanning"=dword:00000000

;Проверять сообщения электронной почты
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender\Scan]
"DisableEmailScanning"=dword:00000000

;Проверять съемные носители
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender\Scan]
"DisableRemovableDriveScanning"=dword:00000000

;Использовать эвристику
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender\Scan]
"DisableHeuristics"=dword:00000000

;Создать точку восстановления
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender\Scan]
"DisableRestorePoint"=dword:00000000

На последней вкладке параметров Защитника Windows «Администратор» вы можете полностью отключить программу, сняв флажок на опции «Использовать эту программу», а также в журнале административной учетной записи отображать все шпионские и потенциально опасные программы для всех пользователей текущего компьютера при помощи опции «Показать элементы всех пользователей компьютера». Эти действия вы можете выполнить при помощи реестра:

;Использовать эту программу
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender]
"DisableAntiSpyware"=dword:00000000

;Показать элементы всех пользователей компьютера
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender\UX Configuration]
"DisablePrivacyMode"=dword:00000001

Данные настройки доступны через интерфейс программы Защитник Windows. Подробнее об этой программе можно прочитать в справочнике Windows.Народные советы

В статье использовались материалы Использование Защитника Windows


Персонализация

Темы

Чтобы запретить пользователю менять темы Рабочего стола, используйте DWORD-параметр NoThemesTab со значением 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

После перезагрузки миниатюры тем будут обесцвечены и недоступны для изменения.

Фон рабочего стола

Вы можете изменять фон и положение изображений на рабочем столе. Откройте окно персонализации и перейдите по ссылке Фон рабочего стола. При помощи выпадающего списка Положение изображения вы можете выбрать любой из предложенных вариантов:

  • Заполнение
  • По размеру
  • Растянуть
  • Замостить
  • По центру

Для разработчиков: Данные настройки хранятся в разделе HKCU\Control Panel\Desktop в строковых параметрах WallpaperStyle и TileWallpaper:

  • Заполнение - WallpaperStyle = 10
  • По размеру - WallpaperStyle = 6
  • Растянуть - WallpaperStyle = 2
  • Замостить - WallpaperStyle = 0/TileWallpaper = 1
  • По центру - WallpaperStyle = 0/TileWallpaper = 0

Смена фона рабочего стола через заданный интервал

Для изменения частоты смены изображений откройте окно персонализации, перейдите по ссылке Фон рабочего стола и в выпадающем списке Сменять изображение каждые выберите нужный интервал.

Для разработчиков: Данная настройка доступна через DWORD-параметр Interval в разделе HKCU\Control Panel\Personalization\Desktop Slideshow. Для вычисления нужного времени можно воспользоваться калькулятором.

Смена обоев в случайном порядке

Чтобы настроить смену изображений в случайном порядке, откройте окно персонализации, перейдите по ссылке Фон рабочего стола и установите флажок В случайном порядке.

Для разработчиков: За данную настройку отвечает DWORD-параметр Shuffle со значением 1 в разделе HKCU\Control Panel\Personalization\Desktop Slideshow.

Запрет на смену фона рабочего стола

Можно запретить изменять фоновый рисунок. Для этого создайте DWORD-параметр NoChangingWallpaper со значением 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop. Ссылка Фон рабочего стола в окне Персонализация станет недоступной.

Внимание: Несмотря на подобный запрет, пользователь может изменить фон рабочего стола через Internet Explorer при помощи команды Сделать фоновым рисунком

Очистка истории выбора расположение фонов рабочего стола

Когда вы в окне Персонализация выбираете фон для Рабочего стола, то в списке Расположение изображения сохраняются названия папок, в которых вы искали подходящие картинки для своего Рабочего стола. Чтобы очистить данный список от ненужных записей и оставить только системные названия (Фоны рабочего стола Windows, Библиотека изображений, Самые популярные фотографии и Сплошные цвета), нужно в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\Images удалить все параметры ID под номерами от 0 до 9, которые содержат в зашифрованном виде пути нахождения изображений, выбранных пользователем.

Цвет окна

Чтобы изменить цвет окон в окне персонализации нужно перейти по ссылке Цвет окна и либо выбрать один из 16 предустановленных цветов, либо воспользоваться палитрой для определения своего цвета.

Для разработчиков: Данные настройки хранятся в разделе HKCU\Software\Microsoft\Windows\DWM

  • ColorizationColor
  • ColorizationColorBalance
  • ColorizationAfterglow
  • ColorizationAfterglowBalance
  • ColorizationBlurBalance

Прозрачность

При помощи флажка Включить прозрачность в этом же окне можно изменить внешний вид границ окна.

Для разработчиков: За данную настройку отвечает параметр ColorizationOpaqueBlend в разделе HKCU\Software\Microsoft\Windows\DWM.

Запрет на смену цвета окна

Можно запретить изменять страницу Цвет окна в окне Персонализация или диалогового окна «Цветовая схема» в панели управления экраном, если компонент персонализации недоступен. Чтобы ссылка Цвет окна стала недоступной, создайте в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System DWORD-параметр NoDispAppearancePage со значением 1.

Политика: Конфигурация пользователя → Административные шаблоны → Панель управления → Персонализация → Запретить изменение цвета и оформления окон

Запрет на настройку цвета границ окон, меню Пуск и панели задач

Существует еще один способ запрета на смену цвета окна. При этом ссылка Цвет окна будет активной, но следующее диалоговое окно будет содержать заблокированные элементы интерфейса. Вы не сможете выбрать цветную кнопку для изменения цвета границ окон. Также будет заблокирован ползунок Интенсивность цвета и флажок Показать настройку цветов. Для подобного запрета нужно создать параметр типа DWORD DisallowColorizationColorChanges со значением 1 в разделе HKCU\Software\Policies\Microsoft\Windows\DWM.

Политика: Конфигурация компьютера (Конфигурация пользователя) → Административные шаблоны → Компоненты Windows → Диспетчер окон рабочего стола → Цвет рамки окна → Не разрешать смену цветов

Звуки

В Windows 7 включено 14 новых звуковых схем, навеянных мотивами разных наций. Для выбора интересующей вас звуковой схемы перейти по ссылке Звук в окне Персонализация. В диалоговом окне можно выбрать сразу всю звуковую схему из выпадающего меню Звуковая схема а также указать отдельно звук для каждого программного события выделив событие в поле Программные события и выбрав подходящий звук через кнопку Обзор.

Для разработчиков: Данные настройки хранятся в разделе HKCU\AppEvents\Schemes\Apps\.Default

Запрет на изменение звуковых схем

Можно запретить пользователю изменять звуковые схемы, заблокировав ссылку Звуки. Создайте в разделе HKCU\Software\Policies\Microsoft\Windows\Personalization DWORD-параметр NoChangingSoundScheme со значением 1.

Политика: Конфигурация пользователя → Административные шаблоны → Панель управления → Персонализация → Запретить изменение звуков

Значки рабочего стола

Разрешить темам изменять значки на рабочем столе

В окне Параметры значков рабочего стола (Персонализация | Изменение значков рабочего стола) можно убрать флажок Разрешить темам изменять значки на рабочем столе, чтобы запретить новым темам менять стандартные значки на рабочем столе.

В реестре за этот запрет отвечает параметр ThemeChangesDesktopIcons в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Themes. Значение 0 убирает флажок, 1 - устанавливает.

Мышь

Разрешить темам изменять указатели мыши

В окне Свойства: Мышь (Персонализация | Изменение указателей мыши) можно убрать флажок Разрешить темам изменять указатели мыши, чтобы запретить новым темам менять указатели.

В реестре за этот запрет отвечает параметр ThemeChangesMousePointers в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Themes. Значение 0 убирает флажок, 1 - устанавливает.


Принтеры

Группировка принтеров

В Windows 7 при установке более 2 принтеров, использующих один и тот же драйвер принтера и установленых на тот же порт (например LPT 1), вы увидите, как в "Устройств и принтеров" группируются все принтеры. Такое поведение является особенностью данного продукта.

Чтобы обойти эту проблему, выполните следующие действия. Это создаст папку на рабочем столе с именем Принтеры, в которую будут включены все отдельно установленные принтеры:

Перейдите в раздел HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace и создайте новый подраздел {2227a280-3aea-1069-a2de-08002b30309d}. Измените значение по умолчанию на Принтеры. Обновите рабочий стол.

После обновления рабочего стола, появится новая папка с названием Принтеры, который будет отображать все отдельно установленные принтеры.

Источник: База Знаний

Запрет на установку новых принтеров в систему

Если вы хотите запретить установку новых принтеров (Пуск-Настройка-Принтеры-Установка принтера), то откройте раздел HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer и создайте DWORD-параметр NoAddPrinter со значением 1.

При попытке установить новый принтер будет выведено сооответствующее предупреждение.

Политика: Конфигурация пользователя → Административные шаблоны → Панель управления → Принтеры → Запретить добавление принтеров

Запрет на удаление установленных в системе принтеров

Чтобы запретить пользователю удалять установленные в системе принтеры, используйте ключ NoDeletePrinter в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer

Политика: Конфигурация пользователя → Административные шаблоны → Панель управления → Принтеры → Запретить удаление принтеров

Отключить печать по протоколу HTTP

Печать по протоколу HTTP позволяет клиенту печатать на принтерах в интрасети и в сети Интернет. Чтобы отключить печать по протоколу HTTP для этого клиента, нужно в разделе HKCU\SOFTWARE\Policies\Microsoft\Windows NT\Printers создать DWORD-параметр DisableHTTPPrinting

Этот параметр влияет только на клиент при печати через Интернет. Он не запрещает этому компьютеру выступать в качестве сервера печати через Интернет и делать подключенные к нему общие принтеры доступными через HTTP.
Политика: Конфигурация компьютера (Конфигурация пользователя) → Административные шаблоны → Система → Управление связью через Интернет → Параметры связи через Интернет → Отключить печать по протоколу HTTP

Отключение загрузки драйверов принтера по протоколу HTTP

Для установки печати по протоколу HTTP необходима загрузка специальных драйверов. Чтобы запретить клиенту выполнять загрузку драйверов принтера по протоколу HTTP, нужно в разделе HKCU\SOFTWARE\Policies\Microsoft\Windows NT\Printers создать DWORD-параметр DisableWebPnPDownload.

Примечание. Этот параметр не запрещает клиенту печатать на принтерах в интрасети или в сети Интернет по протоколу HTTP. Этот запрет не касается установленных локально драйверов.

Политика: Конфигурация компьютера (Конфигурация пользователя) → Административные шаблоны → Система → Управление связью через Интернет → Параметры связи через Интернет → Отключение загрузки драйверов принтера по протоколу HTTP


Программы и компоненты

Отключение компонента «Программы и компоненты»

Системные администраторы очень не любят, когда неопытные пользователи удаляют программы из раздела Панели управления Программы и компоненты. Существует возможность закрыть доступ к данному разделу при помощи настроек в реестре. Для этого в разделе реестра HKCU\Software\Microsoft\Windows\CurrentVersion\Policies необходимо создать новый подраздел Programs и создать в нем параметр типа DWORD NoProgramsCPL со значением 1. Теперь, когда пользователь откроет окно Программы и компоненты, то увидит надпись:
Системный администратор отключил компонент «Программы и компоненты»

То же самое происходит и при использовании в этом разделе параметра типа DWORD NoProgramsAndFeatures со значением 1.

Политика: Конфигурация пользователя → Административные шаблоны → Панель управления → Программы → Скрыть страницу «Программы и компоненты»

Скрытие апплета Установка и удаление программ

Чтобы пользователь не мог воспользоваться апплетом Панели управления Установка и удаление программ, создайте в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall
ключ NoAddRemovePrograms типа DWORD и установите его равным 1

Теперь, если пользователь выберет пункт Установка и удаление программ в Панели управления, то будет показано сообщение об ошибке

Изменение или удаление программ

Чтобы скрыть вкладку Изменение или удаление программ в апплете Установка и удаление программ, создайте в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall
ключ NoRemovePage типа DWORD и установите его равным 1

Установка программ

Чтобы скрыть вкладку Установка программ в апплете Установка и удаление программ, создайте в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall
ключ NoAddPage типа DWORD и установите его равным 1

Установка компонентов Windows

Чтобы скрыть вкладку Установка компонентов Windows, создайте в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall
ключ NoWindowsSetupPage типа DWORD и установите его равным 1

Выбор программ по умолчанию

Вкладка Выбор программ по умолчанию появилась в Windows XP SP1 и Windows 2000 SP3 и позволяет пользователям настраивать программы по умолчанию. Чтобы скрыть эту вкладку в Установка и удаление программ, откройте или создайте при необходимости раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall
и создайте параметр типа DWORD NoChooseProgramsPage со значением, равным 1

CD или дискета

Чтобы скрыть раздел Установка программы с CD-ROM или дискеты и кнопку CD или дискета на вкладке Установка программ, создайте в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall
ключ NoAddFromCDorFloppy типа DWORD и установите его равным 1

Windows Update

Чтобы скрыть раздел Установка программы от Майкрософт и кнопку Windows Update на вкладке Установка программ, создайте в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall
ключ NoAddFromInternet типа DWORD и установите его равным 1

Сведения о поддержке

Некоторые программы, представленные в списке Изменение или удаление программ могут содержать ссылку Чтобы получить сведения о поддержке, щелкните здесь. Чтобы скрыть данную ссылку, создайте в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall
ключ NoSupportInfo типа DWORD и установите его равным 1

Список установленных программ

Иногда в списке установленных программ Изменение или удаление программ может содержаться мусор (неправильно удаленные программы). Некоторых очень раздражают эти записи программ, которых давно уже нет на компьютере. Чтобы очистить этот список, найдите раздел

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall
, который содержит подразделы, отвечающие за каждый отдельный продукт. Просто удалите ненужные подразделы

Информация о продукте

Можно настроить внешний вид записи в разделе Установленные программы и диалогового окна Поддержка, которое появляется при щелчке на ссылке Чтобы получить сведения о поддержке, щелкните здесь.
Для включения нужного режима используйте строковые значения в разделе

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\<имя программы>
  • DisplayIcon - иконка, соответствующая приложению в диалоге "Установка и удаление программ"
  • DisplayName - Описание приложения
  • ModifyPath - Путь инсталлятора (утилиты) для изменения установочных параметров программы. Еcли этот ключ установлен, то Кнопка "Заменить/Удалить" распадается на две - "Заменить" (Выполняется ModifyPath) и "Удалить" (выполняется UninstallString)
  • UninstallString - путь деинсталлятора
Ключи для диалогового окна Поддержка

Если вы создадите параметр Publisher, то в описании удаляемой программы появляется ссылка Чтобы получить сведения о поддержке, щелкните здесь, которая открывает диалоговое окно Поддержка. Для настройки внешнего вида этого окна используйте следующие строковые значения

  • Publisher - Издатель продукта
  • Readme - Путь к файлу Readme для данного продукта
  • Comments - Коментарии к продукту
  • Contact - Контактное лицо (e-mail и т.п.)
  • DisplayVersion - Номер версии
  • ProductID - Код продукта
  • RegCompany - Зарегистрированная компания
  • RegOwner - Зарегистрированный владелец
  • URLInfoAbout - Домашняя страничка производителя (параметр Publisher становится ссылкой)
  • URLUpdateInfo - URL обновления продукта
  • HelpLink - URL сведений о поддержке


Свойства обозревателя

Вкладки окна Свойства обозревателя

При выборе пункта меню Свойства обозревателя (Сервис | Свойства обозревателя или Пуск | Настройка | Панель управления | Свойства обозревателя) появляется диалоговое окно, содержащее несколько вкладок. Следующие параметры позволяют настраивать эти вкладки. Все приведенные параметры (если особо не оговорено) имеют тип DWORD и находятся в разделе HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

Общие

Для скрытия вкладки Общие, присвойте параметру GeneralTab значение 1

Цвета

Чтобы заблокировать рамку Цвета (Общие-кнопка Цвета), присвойте параметру Colors значение 1

Ссылки

Чтобы заблокировать рамку Ссылки (Общие-кнопка Цвета), присвойте параметру Links значение 1

Шрифты

Чтобы заблокировать доступ к изменению параметров кнопки Шрифты, присвойте параметру Fonts значение 1

Языки

Чтобы заблокировать доступ к изменению параметров кнопки Языки, присвойте параметру Languages значение 1

Оформление

Чтобы заблокировать доступ к изменению параметров кнопки Оформление, присвойте параметру Accessibility значение 1

Домашняя страница

Для блокировки кнопок С текущей, С исходной, С пустой в рамке Домашняя страница присвойте параметру HomePage значение 1

Политика: Конфигурация пользователя → Административные шаблоны → Компоненты Windows → Internet Explorer → Отключить изменение параметров домашней страницы

Временнные файлы интернета

На вкладке Общие можно отключить все кнопки, относящиеся к рамке Временнные файлы интернета (Удалить Cookie"..., Удалить файлы..., Параметры...). Для этого присвойте параметру Settings значение 1

Блокировка кнопки Переместить

Чтобы блокировать кнопку Переместить (рамка Временные файлы интернета-кнопка Параметры), присвойте параметру Cache значение 1

Журнал

Чтобы блокировать рамку Журнал, присвойте параметру History значение 1

Политика: Конфигурация пользователя (Конфигурация пользователя) → Административные шаблоны → Компоненты Windows → Internet Explorer → Отключить настройку журнала

Настройка количества дней для хранения адресов

DWORD-параметр DaysToKeep раздела HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Url History определяет количество дней, которое Internet Explorer будет хранить введенные вами в адресной строке URL-адреса.

Безопасность

Для скрытия вкладки Безопасность, присвойте параметру SecurityTab значение 1

Запрет на добавление сайтов

Чтобы запретить добавлять сайты для Безопасности, присвойте параметру SecAddSites значение 1

Уровень безопасности для этой зоны

Чтобы заблокировать кнопки в фрейме Уровень безопасности для этой зоны, присвойте параметру SecChangeSettings значение 1

Конфиденциальность

Для скрытия вкладки Конфиденциальность, присвойте параметру PrivacyTab значение 1

Параметры

Чтобы заблокировать доступ к изменению настроек в рамке Параметры, присвойте параметру Privacy Settings значение 1

Содержание

Для скрытия вкладки Содержание, присвойте параметру ContentTab значение 1

Ограничение доступа

Чтобы заблокировать доступ к кнопкам Ограничения доступа, присвойте параметру Ratings значение 1

Сертификаты и Издатели

Чтобы блокировать кнопки Сертификаты и Издатели на вкладке Содержание, присвойте параметру Certificates значение 1

Сертификаты

Чтобы заблокировать только одну кнопку Сертификаты, то присвойте параметру CertifSite или CertifPers значение 1

Издатели

Чтобы заблокировать только одну кнопку Издатели, то присвойте параметру CertifPub значение 1

Запрет сохранения паролей для "Автозаполнения"

Если вы выберите на вкладке Содержание кнопку Автозаполнение, то увидите окно Настройка автозаполнения. Можно отключить возможность автозаполнения для пунктов Имен пользователей и паролей в формах и Запрос на сохранение пароля, блокируя автоматическое заполнение имен пользователей и паролей в формах web-страниц и предотвращая появление диалоговых окон с запросом о сохранении нового введенного пароля. Если эта настройка будет задействована, то названные выше пункты становятся затемненными, показывая тем самым, что заблокированы не только эти функции, но и сама возможность их включения. Для этого присваиваем строковому параметру FormSuggest Passwords значение "no". Установка новой политики для "запрета сохранения паролей для автозаполнения" не приводит к очистке уже занесенной информации в журнале, хранящем имена и соответствующие им пароли.

Запрос на сохранение пароля

Можно отключить только один пункт Запрос на сохранение пароля (смотри выше). Для этого в разделе:

HKCU\Software\Microsoft\Internet Explorer\Main
изменяем строковый параметр FormSuggest Passwords на "no"

Профиль

Для блокировки кнопки Профиль, , присвойте параметру Profiles значение 1

Подключения

Для скрытия вкладки Подключения, присвойте параметру ConnectionsTab значение 1

Чтобы заблокировть доступ к изменению параметров Подключения, кроме кнопки Установить, присвойте параметру Connection Settings значение 1

Кнопка Установить

Для блокировки кнопки Установить, которая запускает мастер подключения к Интернету присвойте параметру Connwiz Admin Lock значение 1

Автоматическая настройка

Для блокировки автоматической настройки (Свойства обозревателя-Подключения-Настройка локальной сети (LAN)) , присвойте параметру AutoConfig значение 1

Прокси-сервер

Для блокировки прокси-сервера (Свойства обозревателя | Подключения | Настройка локальной сети (LAN)), присвойте параметру Proxy значение 1. Также эта настройка доступна через Редактор локальной групповой политики (gpedit.msc): раздел Конфигурация пользователя | Административные шаблоны | Компоненты Windows | Internet Explorer - параметр Отключить изменения параметров прокси.

Ручное включение или отключение прокси-сервера

При решении некоторых задач необходимо включать или выключать прокси-сервер. Для этого нужно лезть в меню настроек Internet Explorer, что долго и неудобно. Сама настройка хранится в параметре ProxyEnabled раздела HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings. Значение 1 включает прокси-сервер, а значение 0 отключает.

В таких случаях проще создать сценарий командной строки для быстрого включения/отключения прокси-сервера.

Файл iepon.cmd (включение прокси-сервера):

reg add "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings" /v ProxyEnable /t REG_DWORD /d 1 /f

Файл iepoff.cmd (отключение прокси-сервера):

reg add "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings" /v ProxyEnable /t REG_DWORD /d 0 /f

Интересная особенность - Chrome также использует настройки интернета от IE, поэтому все сказанное актуально и для него. (Источник: Программирование — это просто!: Включение/выключение proxy в Internet Explorer)

Программы

Для скрытия вкладки Программы, присвойте параметру ProgramsTab значение 1

Электронная почта, Группы новостей и Связь по Интернету

Чтобы отключить Электронная почта, Группы новостей и Связь по Интернету на вкладке Программы, присвойте параметру Messaging значение 1

Календарь и адресная книга

Чтобы отключить Календарь и Адресная книга на вкладке Программы, присвойте параметру CalendarContact значение 1

Используемые программы для служб интернета

Вы можете добавить свои программы в список приложений, автоматически используемых Windows для различных служб Интернета. Вы видите на данной вкладке шесть различных служб: Редактор HTML, Электронная почта, Группы новостей, Связь по Интернету, Календарь, Адресная книга. Для добавления своих программ в эти службы откройте раздел

HKLM\Software\Clients
и в соответствующем разделе создайте свой подраздел. Предположим, вы хотите добавить программу почтовую программу WinMail. Открываем раздел Mail и создаем там новый подраздел WinMail. В этом подразделе значению по умолчанию присваиваем имя нашей программы WinMail. Теперь наша программа будет присутствовать в списке почтовых программ.

Сброс веб-параметров

Чтобы отключить кнопку Сброс веб-параметров на вкладке Программы, присвойте параметру ResetWebSettings значение 1

Проверять, является ли Internet Explorer используемым по умолчанию обозревателем

Чтобы заблокировать доступ к изменению параметров Проверять, является ли Internet Explorer используемым по умолчанию обозревателем, присвойте параметру Check_If_Default значение 1

Дополнительно

Для скрытия вкладки Дополнительно, присвойте параметру AdvancedTab значение 1

Запрет на изменения на вкладке Дополнительно

Можно не скрывать вкладку Дополнительно, а просто запретить делать изменения. Присвойте параметру Advanced значение 1, и вы не сможете ставить или убирать галочки, а также станет недоступной кнопка Восстановить значения по умолчанию


Свойства папки

Удаление апплета Свойства папки

Если вы хотите удалить пункт Свойства папки из меню Проводника, а также апплет из Панели управления, то откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр NoFolderOptions типа DWORD со значением 1.

Типы файлов

Чтобы заблокировать кнопки Создать, Удалить, Изменить на вкладке Типы файлов, тем самым лишить пользователя возможности менять типы файлов, нужно создать параметр NoFileAssociate типа DWORD со значением 1 в разделе
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Данная блокировка не мешает менять типы файлов непосредственно в реестре или другими программами


Панель задач и меню "Пуск"

Скрытие апплета Панель задач и меню "Пуск" из Панели управления

Если вы хотите скрыть пункт Панель задач и меню "Пуск" из Панели управления, то откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр типа DWORD NoSetTaskbar со значением 1. Также будет заблокирована возможность вызова данного компонента через пункт Свойства контекстного меню кнопки Пуск.

Политика: Конфигурация пользователя → Административные шаблоны → Меню Пуск и панель задач → Запретить изменение параметров панели задач и меню "Пуск"

Классический вид кнопки Пуск

Если вы хотите запретить возможность переключать внешний вид кнопки Пуск в стиль XP, то откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр NoSimpleStartMenu типа DWORD со значением, равным 1.

После перезагрузки на вкладке Меню "Пуск" (Панель управления-Панель задач и меню "Пуск") становится недоступным переключатель Меню "Пуск" (в стиле ХР) и работать теперь можно только с классическим видом меню Пуск

Запретить изменение параметров панели задач и меню "Пуск"

Можно запретить изменение параметров панели задач и меню "Пуск" окна Свойства панели задач и меню "Пуск". Для этого необходимо создать параметр типа DWORD TaskbarLockAll со значением 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer. Этот параметр запрещает открывать диалоговое окно свойств панели задач. Если пользователь щелкнет правой кнопкой мыши панель задач, а затем выберет пункт «Свойства», появится сообщение о том, что параметр запрещает выполнение этого действия.

Политика: Конфигурация пользователя → Административные шаблоны → Меню Пуск и панель задач → Блокировать все параметры панели задач

Удаляем элементы меню "Пуск"

Можно удалить различные пункты из Элементы меню "Пуск" (Панель управления-Панель задач и меню "Пуск"-вкладка Меню "Пуск"-кнопка Настроить-вкладка Дополнительно-Элементы меню "Пуск"). Подробнее смотрите в Настройка окна свойств меню кнопки Пуск

  • NoNetworkConnections - удаляет пункт Сетевое окружение

Область уведомлений

Скрытие области уведомлений

Порой в области уведомлений накапливается слишком много значков. Конечно, есть возможность выборочного скрытия отдельных значков. Но есть более радикальный способ - скрытие самой области уведомления. Для этого откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр NoTrayItemsDisplay типа DWORD со значением, равным 1. После перезагрузки окно Значки области уведомлений (Панель задач и меню "Пуск" | вкладка Панель задач | кнопка Настроить) будет недоступной с соответствующим сообщением.


Система

OEM: информация о производителе (Windows Vista)

Разработчики Windows предусмотрели возможность добавления информации для OEM-производителей компьютеров. Эта информация будет доступной в окне Панели управления Система.

Создаем новый раздел HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\OEMInformation, в котором прописываем строковые параметры.

  • HelpCustomized - в этом параметре указывается справочная система производителя
  • Logo - здесь прописывается путь к логотипу. Например, C:\Windows
  • Manufacturer - имя производителя
  • Model - номер модели
  • SupportHours - часы работы службы поддержки производителя
  • SupportPhone - номер телефона службы поддержки
  • SupportURL - ссылка на веб-сайт технической поддержки

Смотри также

OEM: логотип и информация о производителе


Центр обеспечения безопасности

Чтобы отключить Центр обеспечения безопасности, установите параметр типа DWORD Start в значение 4 в разделе

HKLM\SYSTEM\CurrentControlSet\Services\wscsvc

Можно отключить различные всплывающие сообщения Центра обеспечения безопасности. Для этого надо в разделе

HKLM\SOFTWARE\Microsoft\Security Center
установить в значение 1 следующие параметры
  • AntiVirusDisableNotify - при отключении антивируса
  • FirewallDisableNotify - при отключении брандмауэра
  • UpdatesDisableNotify - при отключении автоматического обновления

Также, в этом же разделе можно отключать слежение на наличием антивируса и файерволла

  • AntiVirusOverride
  • FirewallOverride


Экран

Запрет запуска апплета "Экран"

Чтобы запретить запуск апплета Экран в Панели управления, создайте ключ NoDispCPL типа DWORD и установите его равным 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

При попытке запуска апплета "Экрана" выдается сообщение, что системный администратор заблокировал "Экран". Для изменения настроек "Экрана" придется работать с реестром напрямую или через утилиты третьих производителей.

Рабочий стол

Скрытие вкладки Рабочий стол

Чтобы скрыть вкладку Рабочий стол в апплете Экран, создайте ключ NoDispBackgroundPage типа DWORD и установите его равным 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System
Эта вкладка убирается из приложения "Экран", и таким образом нельзя воспользоваться ею для изменения узоров или обоев для "Рабочего стола"

Запрет изменения обоев

Создайте строковый параметр Wallpaper и пропишите в нем полный путь к вашему графическому файлу в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System
В дополнение в этом же разделе создайте строковый параметр WallpaperStyle, в котором можете указать способ вывода картинки на Рабочий стол:
  • 0 - По центру (По умолчанию)
  • 1 - Замостить
  • 2 - Растянуть

После установки этих значений список Фоновый рисунок и кнопка Обзор будут заблокированы

Только растровые обои

А можно запретить использовать в качестве обоев картинки разных форматов, кроме растровых картинок (bmp). Чтобы включить данный запрет, используйте параметр типа DWORD NoHTMLWallPaper со значением 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop

Заставка

Скрытие вкладки Заставка

Чтобы скрыть вкладку Заставка в апплете Экран, создайте в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System
ключ NoDispScrSavPage типа DWORD и установите его равным 1. Эта вкладка убирается из приложения "Экран", и таким образом выбор экранной заставки, настройка ее параметров, энергосберегающих свойств монитора и компьютера будут недоступны

Блокировка вкладки Заставка

А можно не скрывать вкладку, а просто заблокировать ее, запрещая запуск экранных заставок и блокируя всю вкладку Заставка с настройками. Для данной блокировки присвойте параметру типа DWORD ScreenSaveActive значение 0 в разделе

HKCU\Software\Policies\Microsoft\Windows\Control Panel\Desktop

Защита паролем экранной заставки

Можно настроить политику поведения паролей для экранных заставок. Для этого существует ключ типа DWORD ScreenSaverIsSecure в разделе

HKCU\Software\Policies\Microsoft\Windows\Control Panel\Desktop
Существует три состояния:
  • Параметр ScreenSaverIsSecure отсутствует в реестре. Обычное поведение экранной заставки - пароли можно изменять, применять или отменять их использование через окно "защита паролем".
  • Параметр хранит значение "0". Использование паролей к заставкам недоступно.
  • Параметр хранит значение "1", пароли к экранным заставкам принудительно включены.

Описанная выше политика "Блокировка вкладки Заставка" имеет приоритет над этой политикой. Если политика "Блокировка вкладки Заставка" находится в активном состоянии, то система игнорирует состояние политики "Защита паролем экранной заставки".

Оформление

Окна и кнопки

Для блокировки элементов Окна и кнопки на вкладке Оформление создайте параметр типа DWORD NoVisualStyleChoice в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Политика: Конфигурация пользователя → Административные шаблоны → Панель управления → Персонализация → Запретить изменение стилей оформления окон и кнопок

Цветовая схема

Для блокировки элементов Цветовая схема на вкладке Оформление создайте параметр типа DWORD NoColorChoice в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Политика: Конфигурация пользователя → Административные шаблоны → Панель управления → Персонализация → Запретить изменение цветовой схемы

Размер шрифта

Для блокировки элементов Размер шрифта на вкладке Оформление создайте параметр типа DWORD NoSizeChoice в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System.

Скрытие вкладки Настройка

Чтобы скрыть вкладку Настройка в апплете Экран, создайте в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System ключ NoDispSettingsPage типа DWORD и установите его равным 1. Эта вкладка убирается из приложения "Экран", и таким образом невозможно использовать данную вкладку для изменения настроек дисплея, видеоадаптера, корректирующей гаммы.

Политика: Конфигурация пользователя → Административные шаблоны → Панель управления → Окно свойств экран → Скрыть вкладку «Настройка»

Применять следующий переходный эффект для меню и подсказок

Анимационные эффекты для окон, меню и списков созданы для разнообразия работы пользователя, но могут и раздражать или просто отвлекать от работы. К анимационным эффектам, к примеру, относятся затенение и развертывание меню с эффектами взрыва или соскальзывания. Пункт "Применять следующий переходный эффект для меню и подсказок", отвечающий за включенное или выключенное состояние эффектов анимации, находится на странице Эффекты вкладки Оформление.

Для блокировки данной опции используйте параметр NoChangeAnimation типа DWORD равным 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
. В этом случае данный пункт становится затемненным, показывая пользователю, что сама возможность включения эффектов анимации не доступна.

Блокировка пункта Скрывать указатели вызова с клавиатуры до нажатия <ALT>

Данная опция находится на вкладке Оформление при нажатии на кнопку Эффекты. Для блокировки опции "Скрывать указатели вызова с клавиатуры до нажатия <ALT>" используйте параметр NoChangeKeyboardNavigationIndicators типа DWORD равным 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
В этом случае данный пункт становится затемненным, показывая пользователю, что сама возможность включения эффектов не доступна.


Язык и региональные стандарты

Компонент Язык и региональные стандарты отвечает за настройку языка, валюты, мер измерений и т. п. Рассмотрим часть параметров, которые можно сделать при помощи настроек в реестре. Все описываемые параметры располагаются в разделе HKCU\Software\Policies\Microsoft\Control Panel\International и вступают в силу сразу, т. е. перезагрузки компьютера не требуется.

Скрытие вкладки Форматы

Можно скрыть вкладку Форматы, которая отвечает за отображение дат, чисел, денежных единиц. Для этого нужно в разделе HKCU\Software\Policies\Microsoft\Control Panel\International создать параметр типа DWORD HideLocaleSelectAndCustomize и присвоить ему значение 1.

Политика: Конфигурация пользователя → Административные шаблоны → Язык и региональные стандарты → Скрыть параметры выбора языковой группы

Блокировка кнопки Дополнительные параметры…

Можно не прятать вкладку Форматы, а заблокировать в ней кнопку Дополнительные параметры… Для этого достаточно параметру типа DWORD PreventUserOverrides присвоить значение 1 в разделе реестра HKCU\Software\Policies\Microsoft\ControlPanel\International.

Политика: Конфигурация пользователя → Административные шаблоны → Язык и региональные стандарты → Скрыть параметры выбора и настройки языкового параметра

Выпадающий список Формат

Продолжаем настраивать вкладку Форматы. На ней имеется выпадающий список Формат, который который тоже можно заблокировать, если присвоить параметру типа DWORD RestrictUserLocales значение 1 в разделе HKCU\Software\Policies\Microsoft\ControlPanel\International. После внесения изменений в реестр, пользователю будет доступена только один текущий формат.

Политика: Конфигурация пользователя → Административные шаблоны → Система → Служба языковых стандартов → Запретить выбор пользовательских языковых стандартов

Интересно отметить, что можно более гибко настроить данный выпадающий список и определить список перечень нужных записей. Если в данном разделе создать строковый параметр AllowableUserLocaleTagList и указать в нем список языков (перечисленных через точку с запятой, например ru-RU;en-US), то в выпадающем списке будут отображаться выбранные языки, даже если значение параметра RestrictUserLocales равно 1.

Политика: Конфигурация пользователя → Административные шаблоны → Система → Служба языковых стандартов → Ограничить пользовательские языковые стандарты

Вкладка Расположение

При помощи параметра типа DWORD HideCurrentLocation со значением 1 в разделе HKCU\Software\Policies\Microsoft\Control Panel\International можно скрыть вкладку Расположение.

Политика: Конфигурация пользователя → Административные шаблоны → Язык и региональные стандарты → Скрыть параметр географического положения

Выпадающий список Текущее расположение

На вкладке Расположение также имеется выпадающий список. Чтобы установить запрет для выпадающего списка Текущее расположение, нужно создать параметр типа DWORD PreventGeoIdChange присвоить значение 1 в разделе HKCU\Software\Policies\Microsoft\ControlPanel\International.

Политика: Конфигурация пользователя → Административные шаблоны → Система → Служба языковых стандартов → Запретить изменение географического положения

Языки и клавиатура

Саму вкладку Языки и клавиатура скрыть нельзя. Однако мы можем скрыть область Язык интерфейса, которая содержит кнопку Установить или удалить язык. Для этого нужно параметру типа DWORD HideLanguageSelection присвоить значение 1 в разделе HKCU\Software\Policies\Microsoft\Control Panel\International. После внесения изменений в реестр, описываемая область исчезнет.

Политика: Конфигурация пользователя → Административные шаблоны → Язык и региональные стандарты → Скрыть параметры выбора языкового стандарта

Выбор языка локализации

Кроме запрета доступа к данному полю, существует возможность определения языка локализации операционной системы, который для вашей учетной записи будет использоваться по умолчанию. Для этого достаточно ввести нужный вам язык (например, для русского нужно ввести ru-RU) в параметре строкового типа PreferredUILanguages в разделе HKCU\SOFTWARE\Policies\Microsoft\MUI\Settings.

Политика: Конфигурация пользователя → Административные шаблоны → Язык и региональные стандарты → Ограничить язык интерфейса Windows для указанного пользователя

Однако, если значение параметра MachineUILock равно 1 в разделе HKLM\SOFTWARE\Policies\Microsoft\MUI\Settings, то пользователям будет запрещено изменять язык интерфейса. В этом случае будет использоваться системный язык интерфейса.

Политика: Конфигурация пользователя → Административные шаблоны → Язык и региональные стандарты → Скрыть параметры управления в панели «Языки и региональные стандарты»

Вкладка Дополнительно

Для скрытия вкладки Дополнительно, нужно параметру типа DWORD HideAdminOptions присвоить значение 1 в разделе HKCU\Software\Policies\Microsoft\Control Panel\International.

Политика: Конфигурация пользователя → Административные шаблоны → Язык и региональные стандарты → Скрыть параметры управления в панели «Языки и региональные стандарты»


Блокнот

Вы можете получить доступ к дополнительным свойствам шрифта, используемого в Блокноте. Используются параметры типа DWORD в разделе HKCU\SOFTWARE\Microsoft\Notepad

Зачеркнутый стиль - параметр lfStrikeOut со значением 1

Подчеркнутый стиль - lfUnderline со значением 1


msconfig.exe

Настройка системы (msconfig.exe)

Восстановление окна для перезагрузки компьютера

Когда вы вносите изменения в утилите Настройка системы, то появляется окно, в котором говорится о необходимости перезагрузить компьютер.

Если вы отметите галочкой пункт Больше не показывать это предупреждение, то данное окно появляться не будет.

Для восстановления данного окна нужно в разделе HKCU\Software\Microsoft\Shared Tools\MsConfig удалить параметр NoRebootUI.

Удаление лишних записей

Порой окно программы Настройка системы (msconfig.exe) засоряется ненужными записями. Чтобы удалить записи, которые мозолят вам глаза, нужно прогуляться в раздел

HKLM\SOFTWARE\Microsoft\Shared Tools\MSConfig
и просмотреть все подразделы. Удалите ненужные параметры и окно программы будет выглядеть гораздо аккуратнее <


Параметры презентации

Включаем программу на настольном компьютере

По умолчанию, Параметры презентации (PresentationSettings.exe) нельзя запустить на настольном компьютере. C помощью реестра можно исправить данное положение вещей. Создайте в реестре раздел HKCU\Software\Microsoft\MobilePC\AdaptableSettings и далее создайте в нем параметр DWORD SkipBatteryCheck и присвойте ему значение 1.

Выключить настройки презентации Windows

Существует возможность выключить настройки презентации Windows, если в разделе HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\PresentationSettings присвоить параметру DWORD NoPresentationSettings со значением 1. Обратите внимание, что при включенном данном параметре программа PresentationSettings.exe не будет работать на настольном компьютере даже при использовании параметра SkipBatteryCheck, описанного выше.

Политика: Конфигурация компьютера (Конфигурация пользователя) → Административные шаблоны → Компоненты Windows → Настройки презентации → Выключить настройки презентации


Центр мобильности Windows

По умолчанию, Центр мобильности Windows (mblctr.exe) нельзя запустить на настольном компьютере. C помощью реестра можно исправить данное положение вещей. Создайте в реестре раздел HKCU\Software\Microsoft\MobilePC\MobilityCenter и далее создайте в нем параметр DWORD RunOnDesktop и присвойте ему значение 1.


Send Feedback

Удаление надписи ''Send Feedback'' с окон Windows 7 Beta

В верхней части всех открываемых окон Windows 7 Beta можно увидеть ссылку "Send Feedback", предназначенная для отправки своего мнения о тестируемой системе в Microsoft. Можно избавиться от этой надписи. В разделе HKCU\Control Panel\Desktop находим параметр FeedbackToolEnabled и меняем его значение на 0.

Если вам нужно отправить какие-либо сведения об обнаруженных ошибках Windows 7, то можете воспользоваться пунктом Feedback на Панели управления.


Активация Windows

Сброс активации

Если вам понадобилось по каким-то причинам сбросить текущую активацию Windows, то в разделе HKLM\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\WPAEvents меняем любую цифру в значении параметра OOBETimer. Это аннулирует текущую активизацию. Далее запускаем активизацию системы (или набираем в Пуск | Выполнить следующее:
C:\Windows\system32\oobe\msoobe.exe /a
В окне "активизировать по телефону" вводим в окошке для серийника новый серийный номер.

Нейтрализация отсрочки активации

В Windows 7 можно несколько раз откладывать активацию. Данную возможность можно нейтрализовать, если в разделе HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SoftwareProtectionPlatform DWORD-параметру SkipRearm присвоить значение 1.

Подробнее об отсрочке активации читайте в справочнике Windows.Народные советы


Вход в Windows

Сообщение при загрузке

Можно настроить систему таким образом, чтобы при загрузке системы на экране приветствия сначала выводилось ваше сообщение. Для этого откройте раздел HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System и найдите строковые параметры LegalNoticeCaption и LegalNoticeText. Первый параметр отвечает за заголовок сообщения, а второй за сам текст. Предположим, вы введете в первый параметр текст Внимание!, а во второй: На компьютере обнаружены вирусы! Форматировать диск? Теперь при каждом включении компьютера до появления стандартного экрана приветствия вы будете видеть заданное сообщение.

Просмотр сведений о предыдущих попытках входа в Windows

Существует возможность просмотра на экране приветствия информации о предыдущих удачных и неудачных попытках входа в систему, что позволяет определять, кто ранее работал за компьютером и, возможно, предупредить взлом системы. Для этого в разделе HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System создайте DWORD-параметр DisplayLastLogonInfo со значением, равным 1.

Автоматический вход в Windows

Существует возможность автоматического входа в Windows, минуя экран приветствия. Учтите, что данный способ не совсем безопасен, так как любой может войти в систему, если не требуется вводить пароль. Для автоматического входа в систему требуется изменить строковый параметр AutoAdminLogon на 1 в разделе HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon. Также необходимо установить строковые значения DefaultUserName и DefaultPassword в этом же разделе равными имени пользователя и пароля, которые используются для входа в Windows. Возможно, вам также придется установить строковое значение DefaultDomainName, если ваш компьютер используется как домен. Однако, вы должны понимать, что при автоматическом входе любой пользователь, получивший доступ к вашем компьютеру, может узнать ваш пароль, который хранится в реестре в открытом виде.

Лимит на число попыток автоматического входа в Windows

Данная настройка является логическим продолжением предыдущей настройки. Можно задать число попыток для автоматического входа в Windows. В этом случае в том же разделе надо создать параметр DWORD AutoLogonCount и присвоить ему некоторое значение. Например, если вы присвоите значение 5, то система пять раз автоматически войдет в Windows. Причем, при каждом входе данный параметр в реестре будет автоматически уменьшаться на единицу. Когда значение параметра достигнет 0, ключи AutoLogonCount и DefaultPassword будут удалены из реестра, а параметру AutoAdminLogo будет присвоено значение 0.

Экран приветствия

Замена экрана приветствия в Windows 7

В Windows 7 появилась возможность изменить изображение страницы приветствия (Logon screen) через реестр или при помощи групповой политики. Теперь не нужно копаться в ресурсах программы при помощи различных программ.

Сначала нам надо подготовить несколько картинок, которые будут являться фоном для страницы приветствия. Во-первых, нам понадобится картинка в формате JPG с разрешением равным разрешению экрана и размером не более 256 кбайт. Назовите этот файл backgroundDefault.jpg. Вы также можете подготовить файлы изображений для других разрешений экрана. В этом случае файлы должны содержать в названиях разрешения. Вот список поддерживаемых разрешений и соответствующие им имена файлов (кроме backgroundDefault.jpg):

background768x1280.jpg
background900x1440.jpg
background960x1280.jpg
background1024x1280.jpg
background1280x1024.jpg
background1024x768.jpg
background1280x960.jpg
background1600x1200.jpg
background1440x900.jpg
background1920x1200.jpg
background1280x768.jpg
background1360x768.jpg

Все подготовленные изображения необходимо разместить в папке %windir%\system32\oobe\info\backgrounds (в случае необходимости нужно создать недостающиеся папки).

В случае, если система не может найти файла с именем, соответствующим текущему разрешению будет применено изображение из BackgroundDefault.jpg. При необходимости оно будет растянуто или сжато так, чтобы полностью покрывать экран.

Обратите внимание, что, если вы смените тему оформления ОС, ваш экран приветствия может быть отключен, т.к тема включает в себя и настройки этого экрана.

Если вы хотите отредактировать оригинальный фон, применяемый в экране приветствия по умолчанию, то найдите файл C:\Windows\System32\oobe\background.bmp внесите нужные изменения.

Далее приступаем к редактированию реестра. Войдите в раздел реестра HKLM\Software\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\Background и создайте параметр DWORD OEMBackground со значением 1.

Также можно добиться этого эффекта при помощи редактора групповых политик gpedit.msc. Запустите редактор и последовательно разверните узлы Computer Configuration | Administrative Templates | System | Logon. В правой части окна откройте параметр Always use custom logon background. Установите значение параметра равным Enabled.

Пара замечаний о данной настройке: описанные способы действуют на сборку 7057 и выше. Кстати, нет никакой гарантии, что описанная настройка сохранится в окончательной версии Windows 7.

На моем Cайте для программистов, посвященном программированию на платформе .NET Framework, вы можете найти исходники на C# к програме Windows 7 LogonUI Changer, которая изменяет страницу приветствия. Утилита очень проста в использовании - изменяет нужный параметр реестре, изменяет разрешение выбранного изображения в соответствии с разрешением вашего экрана (можете выбрать другое изображение) и помещает файл с изображением в нужную папку.

Настройка кнопок на экране приветствия (Windows 7)

Изменив фон, как это описано выше, вы можете столкнуться с проблемой - низкий контраст текста и кнопочек при выборе светлого фона. Чтобы изменить кнопки, необходимо в разделе HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI добавить DWORD-параметр ButtonSet. Значения параметра варьируются от 0 до 2. Ниже приведено их описание:

0 - тени текста светлее, темные (более непрозрачные) кнопки (по умолчанию)
1 - тени текста темнее, более светлые (прозрачные) кнопки (для светлых фонов)
2 - нет теней текста, непрозрачные кнопки (для темных фоновых рисунков)

Скрытие кнопки завершения работы

На экране приветствия в нижнем правом углу вы можете видеть красную кнопку завершения работы. Вы можете скрыть ее, если присвоите параметру типа DWORD shutdownwithoutlogon значение 0. Данный параметр находится в разделе HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System.

Замена экрана в Windows XP/Vista

Существует возможность замены экрана приветствия без модификации самого файла logonui.exe, в котором содержится внешний вид экрана. Для этого скачайте из интернета или создайте самостоятельно такой экран. Затем в разделе

HKLM/SOFTWARE/Microsoft/Windows NT/CurrentVersion/WinLogon
создайте строковый параметр UIHost, в котором и пропишите полный путь к вашему новому файлу

Учетные записи

Скрываем/показываем имя пользователя в Welcome Screen

В окне Приветствие можно показывать или скрывать имена пользователей. Например, если кто-то не хочет афишировать своего присутствия на компьютере, или машина стоит в офисе и на ней зарегистрированы пользователи, которые логинятся по сети, то можно скрыть нежелательные имена из экрана приветствия. Для этого в разделе реестра HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\SpecialAccounts\UserList\ надо создать DWORD-параметр с именем, совпадающим с именем пользователя, и значением 0. Чтобы вернуть пользователя назад надо либо удалить параметр, либо присвоить ему значение 1. Чтобы залогиниться под скрытым пользователем, придется дважды нажать Ctrl+Alt+Del, откроется классический диалог логона, где можно по старинке указать имя пользователя и пароль. Рассмотрим частные случаи.

Учетная запись Administrator

Если вы хотите, чтобы помимо учетной записи пользователя на экране приветствия предлагалось еще войти в систему под именем Администратора, то добавьте в указанный выше раздел параметр DWORD Administrator со значением 1.

Скрытые учетные записи

Существует обратная ситуация, когда система устанавливает скрытые учетные записи. Например, при установке пакета .NET Framework 1.1 система регистрирует новую скрытую учетную запись ASPNET. В этом случае, у вас будет появляться окно приветствия Windows, которого до этого его не было. Чтобы избавиться от этого эффекта, создайте параметр типа DWORD ASPNET со значением 0 в разделе HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\Special Accounts\UserList

ClearType

Совет для пользователей ноутбуков или жидкокристаллических мониторов. Для дисплеев такого типа Microsoft разработала технологию ClearType, значительно улучшающую восприятие текста. Но эта опция в настройках экрана включается отдельно для каждого пользователя и не работает до тех пор, пока профиль пользователя не загружен (экран приветствия, например). Чтобы включить этот режим и для экрана приветствия, нужно открыть раздел:

HKU\.DEFAULT\Control Panel\Desktop
и установить значения 2 для параметров FontSmoothing и FontSmoothingType и значение 1 для параметра FontSmoothingOrientation


Изображение по умолчанию для учетной записи пользователя ко всем пользователем

DWORD-параметр UseDefaultTile со значением 1 в разделе HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer позволяет администратору установить стандартное изображение по умолчанию для учетных записей всех пользователей системы. Одним из применений данного параметра политики является использование эмблемы компании в качестве изображения по умолчанию для учетной записи пользователей.

Изображение по умолчанию для учетной записи пользователя находится в %PROGRAMDATA%\Microsoft\User Account Pictures\user.bmp. Изображение по умолчанию для учетной записи «Гость» находится в %PROGRAMDATA%\Microsoft\User Account Pictures\guest.bmp. Если изображения по умолчанию недоступны, отображается пустая рамка.

Если включить этот параметр, изображение по умолчанию для входа в систему будет отображаться у всех пользователей системы без возможности изменения.

Если параметр равен 0 или не задан, пользователи смогут менять свои изображения.

Эту настройку можно осуществить при помощи Редактора локальной групповой политики (gpedit.msc) - Конфигурация компьютера | Административные шаблоны | Панель управления | Учетные записи пользователей: Применить изображения по умолчанию для учетной записи пользователя ко всем пользователям.


Регистрационные данные

Если вы нажмете на пункт меню О программе в Проводнике или в других программах, поставляемых с Windows, то увидите, кто обладает правом использования этой копии. Также эти данные можно увидеть в апплете Система Панели управления. Возможно, вам компьютер достался от вашего босса Пупкина, и вы страстно хотели бы изменить регистрационные данные. Для этого нужно изменить строковые параметры RegisteredOwner (Ваше имя) и RegisteredOrganization (название организации) в разделе

HKLM\SOFTWARE\Microsoft\WindowsNT\CurrentVersion


Путь установки Windows

Иногда приходится переустанавливать Windows с разных мест - с жесткого диска, с компакт-диска, с записывающего CD-RW. Но Windows запоминает путь инсталяционных файлов, что порой создает проблему. Чтобы "обмануть" Windows, используйте в разделе

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup
строковый параметр SourcePath, указав в нем ваш путь


Пакеты обновлений (Service Pack)

Исключение пакетов обновлений из службы Windows Update

Если вы хотите заблокировать установку сервис-паков Windows 7 Service Pack 1 и Windows Server 2008 R2 Service Pack 1 через службу Windows Update, то добавьте в раздел HKLM\Software\Policies\Microsoft\Windows\WindowsUpdate DWORD-параметр DoNotAllowSP со значением, равным единице.

Данная блокировка будет работать 12 месяцев для того, чтобы системные администраторы могли подготовить компьютеры для этой задачи. Данная блокировка предназначена только для механизма Windows Update, но не блокирует установку сервис-паков через компакт-диски или файлы на жестком диске и т.п.

Также сисадмины могут скачать специальную утилиту от Microsoft - Windows Service Pack Blocker Tool Kit, которая делает ту же работу. В состав утилиты входят три компонента:

  • исполняемый файл, который вносит описанные выше изменения в реестр
  • сценарий (файл SPreg.cmd), который вносит те же изменения в реестр, но позволяет задать имя удаленной машины
  • административный шаблон (файл NoSPUpdate.adm), позволяющий импортировать настройки групповых политик

Аналогично, этот параметр раньше использовался для блокировки сервис-паков для Windows XP (SP3) и Vista (SP1).


Синий Экран Смерти - Blue Screen of Death (BSOD)

Синий Экран Смерти

Если вы хотите полюбоваться на культовый Синий Экран Смерти - Blue Screen of Death (BSOD) в любое время, то откройте раздел

HKLM\SYSTEM\CurrentControlSet\Servises\i8042prt\Parameters
и присвойте параметру типа DWORD CrashOnCtrlScroll значение 1

Удерживая правую клавишу Ctrl, нажмите два раза на клавишу Scroll Lock и вы увидите этот синий экран


Восстановление системы

Восстановление системы используется для отмены конфигурации Windows. Программа позволяет вернуть настройки компьютера в более раннее состояние (контрольная точка).

Все описываемые настройки являются параметрами DWORD и происходят в разделе

HKLM\Software\Microsoft\Windows NT\CurrentVersion\SystemRestore
  • CompressionBurst - задает время сжатия в секундах при простое системы. Восстановление системы сохраняет данные в течение данного времени и прекращает свою работу до следующего периода простоя системы
  • DiskPersent - указывает, какой объем дискового пространства будет использовать программа. Для дисков с объемом более 4 Гигабайт по умолчанию используется 12 процентов
  • DSMax - указывает, какой объем дискового пространства будет использовать программа. Для дисков с объемом менее 4 Гигабайт по умолчанию используется 400 мегабайт
  • DSMin - указывает минимальное количество свободного дискового пространства, которое потребуется программе восстановления системы для создания точек восстановления
  • RestoreStatus - статус последней операции восстановления системы (0 - ошибка, 1 - успешное восстановление, 2 - прерванная операция)
  • RPGlobalInterval - число секунд, в течении которого программа ожидает перед созданием новой контрольной точки. По умолчанию - 24 часа (86400)
  • RPLifeInterval - число секунд, в течении которого программа хранит точки восстановления перед их удалением. По умолчанию 90 дней (7776000)
  • RPSessionInterval - число секунд, в течении которого ожидает перед созданием новой контрольной точки при включенном компьютере. По умолчанию установлено 0 (выключено), вы можете установить свое значение (например, интервал в один час), чтобы программа создавала контрольные точки через заданный интервал
  • ThawInterval - число секунд, в течении которого программа ожидает перед возобновлением своей работы, если появился свободный объем дискового пространства.

Отключение Восстановления системы

Чтобы отключить Восстановление системы, нужно создать параметр DWORD DisableConfig со значением 1 в разделе

HKLM\SOFTWARE\Policies\Microsoft\Windows NT


Панель переключателя задач

Отключение панели переключателя задач

Чтобы отключить панель переключателя задач (который выводится по Alt+Tab), надо в разделе

HKCU\Control Panel\Desktop
присвоить строковому параметру CoolSwitch значение 0 (чтобы включить - значение 1).

Изменение числа строк и колонок

Чтобы изменить число строк и колонок, показываемое на панели переключателя задач (который выводится по Alt+Tab), надо в разделе

HKCU\Control Panel\Desktop
отредактировать значения строковых параметров CoolSwitchRows и CoolSwitchColumns соответственно.


Поиск

Очистка истории раннее вводимых слов (Windows 7)

Когда вы открываете окно поиска в Windows 7, то список предыдущих запросов отображаются в строке поиска. Также, старые запросы появляются при включенном автозаполнении. Вы можете удалить записи по отдельности или все сразу.

Вы можете удалить ненужный запрос из списка MRU, выделив нужный элемент при помощи мыши или клавиш со стрелками и нажав клавишу DELETE.

Чтобы сразу очистить весь список, то воспользуйтесь реестром: В разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer удалите подраздел WordWheelQuery


Боковая панель Windows

Если у вас возникли проблемы с отключением боковой панели Windows, то можете отключить ее через реестре. Найдите раздел HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Windows\Sidebar и удалите параметр TurnOffSidebar. Особенно эта проблема проявляется на ноутбуках с предустановленной боковой панелью от Google.


Windows Aero

Хочешь первым узнавать о выходе новой версии справочника? Следуй за мной в Twitter - @tehnolog

Отключение режима Flip3D

В Windows появился новый режим переключения между окнами в режиме Flip3D, вызываемый при помощи клавиш Win+Tab. Данный режим является альтернативным вариантом для просмотра окон, который можно было вызвать через комбинацию клавиш Alt+Tab. При помощи параметра типа DWORD DisallowFlip3d со значением 1 в разделе HKCU\SOFTWARE\Policies\Microsoft\Windows\DWM вы можете отключить новый режим Flip3D.

Политика: Конфигурация компьютера (Конфигурация пользователя) → Административные шаблоны → Компоненты Windows → Диспетчер окон рабочего стола → Не разрешать вызов Flip3D

Отключение анимации окон

Чтобы отключить красивую анимацию при сворачивании или разворачивании окон используйте параметр типа DWORD DisallowAnimations со значением 1 в разделе HKCU\SOFTWARE\Policies\Microsoft\Windows\DWM.

Политика: Конфигурация компьютера (Конфигурация пользователя) → Административные шаблоны → Компоненты Windows → Диспетчер окон рабочего стола → Не разрешать анимацию окон

Отключение композиции рабочего стола

Начиная с Windows Vista, компоновщик рабочего стола использует различные эффекты для отображения различных графических эффектов и облегчает реализацию таких свойств, как Flip, Flip3D, Taskbar Thumbnails (эскизы панели задач). Чтобы отключить визуальные эффекты компоновщика рабочего стола используйте параметр типа DWORD DisallowComposition со значением 1 в разделе HKCU\SOFTWARE\Policies\Microsoft\Windows\DWM.

Политика: Конфигурация компьютера (Конфигурация пользователя) → Административные шаблоны → Компоненты Windows → Диспетчер окон рабочего стола → Не разрешать композицию рабочего стола

Замедленная анимация окна

Сами разработчики из Microsoft не признаются, зачем они придумали параметр для интересного эффекта анимации окна при его сворачивании или восстановлении. Суть эффекта заключается в следующем. Нажмите и удерживайте клавишу Shift и попробуйте свернуть или развернуть любое окно. Вы увидите, как окно очень медленно будет сворачиваться и растворяться (или проявляться при восстановлении). Зрелище очень красивое и на него стоит посмотреть. Добиться подобного эффекта можно, если создать параметр типа DWORD AnimationsShiftKey со значением 1 в разделе HKCU\Software\Microsoft\Windows\DWM

Aero Shake

В Windows 7 появилась новая технология Aero Shake, когда при помощи мыши можно потрясти окно для быстрого сворачивания или восстановления окон. Чтобы отключить Aero Shake, нужно в разделе HKCU\Software\Policies\Microsoft\Windows\Explorer присвоить параметру типа DWORD NoWindowMinimizingShortcuts значение 1.

Также этом можно сделать через редактор групповых политик gpedit.msc: Конфигурация пользователя | Административные шаблоны | Рабочий стол. Для политики Отключить сворачивание окна Aero Shake жестом мышью установите значение Включена.

Смотри также

Управление Windows Aero из контекстного меню Проводника

Aero Peek

Aero Peek - это возможность быстро скрыть или временно сделать прозрачными окна на Рабочем столе. Вы можете изменить время срабатывания режима Aero Peek - быстрее или медленнее. В разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced создайте новый DWORD-параметр DesktopLivePreviewHoverTime и задайте ему нужно значение в миллисекундах. По умолчанию, оно равно 1 секунде (1000 мс). Попробуйте значения 500 (полсекунды) или 2000 (2 секунды).

Чтобы вернуть значения по умолчанию, можете просто удалить этот параметр.

Отключение Aero Peek

Если вы хотите заблокировать Aero Peek, то воспользуйтесь параметром типа DWORD DisablePreviewDesktop со значением 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced.

Можно обойтись без вмешательства в реестр: Наведите курсор мышки в правый нижний угол, нажмите на правую кнопку мыши и уберите флажок с команды Показывать рабочий стол при наведении. Также можно вызвать контекстное меню Панели задач и выбрать в меню Свойства | закладка Панель задач, и убрать флажок Использовать Aero Peek для предварительного просмотра рабочего стола.

Отключение функции Aero Snap

Отключить функцию Aero Snap можно при помощи параметра типа DWORD WindowArrangementActive со значением 0 в разделе HKCU\Control Panel\Desktop.

Также этого результата можно добиться через графический интерфейс: в Панели управления выберите Центр специальных возможностей и перейдите по любой из следующих ссылок: «Облегчение работы с мышью», «Облегчение работы с клавиатурой» или «Облегчение сосредоточения». Для отключения Aero Snap установите флажок в разделе Упрощенное управление окнами на опции Отключение автоматического упорядочения окон при их перемещении к границе экрана.


Всплывающие подсказки

Описания папок и файлов на Рабочем столе и в Проводнике

Если подвести указатель какому-нибудь элементу рабочего стола или оболочки, то открывается небольшое окно, содержащее текст описания этого элемента. Чтобы запретить появление этих окон, нужно присвоить параметру типа DWORD ShowInfoTip значение 0 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Всплывающие подсказки на панели задач

Windows XP показывает всплывающие подсказки для начинающих пользователей. Чтобы отключить подсказки, нужно присвоить параметру типа DWORD EnableBalloonTips значение 0 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Панель задач под всплывающими подсказками

Источник: http://www.n-admin.com/n1-3336.html
Хотел посмотреть полностью название песенки, которую проигрывает Winamp, подъехал курсором к кнопке винампа (Winamp показывает на всплывающей подсказке полное название песенки), но панель задач закрыл подсказку и прочитать то, что в этой подсказке написано невозможно. Вообще такая штука бывает не во всех Windows XP, но частенько случается...

Следующий batch файл (FixTTbTB.bat) разработан для исправления данной ситуации.
Формат запуска:
FixTTbTB.bat F - исправляет данную ситуацию
FixTTbTB.bat U - возвращает все в исходное состояние
Ну и сам batch файл (FixTTbTB.bat):

@echo off
setlocal
if {%1}=={} goto err
set key="HKCU\Control Panel\Desktop"
set switch=%1
set switch=%switch:"=%
if /i "%switch%" EQU "F" goto fix
if /i "%switch%" EQU "U" goto undo
:err
@echo Syntax: FixTTbTB F^|U
:end
endlocal
goto :EOF
:fix
REG ADD %key% /V UserPreferencesMask /T REG_BINARY /F /D 90320780
goto end
:undo
REG ADD %key% /V UserPreferencesMask /T REG_BINARY /F /D 9E3E0780
goto end


Отключение подсказок для кнопок Свернуть, Развернуть и Закрыть

В Windows 2000/XP контекстная подсказка отображается при размещении курсора мыши поверх кнопок Свернуть, Развернуть и Закрыть. Чтобы отключить эти подсказки, откройте раздел

HKCU\Control Panel\Desktop
и замените первую цифру параметра UserPreferencesMask следующим образом:
  • 8 меняется на 0
  • 9 меняется на 1
  • a меняется на 2
  • b меняется на 3
  • c меняется на 4
  • d меняется на 5
  • e меняется на 6

Например, исходная строка: 9e 3e 07 80, тогда должно стать - 1e 3e 07 80


Пароль после спящего режима

Пароль после ждущего режима

Можно настроить систему таким образом, чтобы при включении компьютера после Ждущего режима появлялось диалоговое окно с приглашением ввести пароль. Для этого в разделе

HKCU\Software\Policies\Microsoft\Windows\System\Power
создаем параметр типа DWORD PromptPasswordOnResume со значением 1.


Заставки

Заставка Ленты

Чтобы задать толщину лент в заставке Ленты (Ribbons), в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Screensavers\Ribbons создайте параметр DWORD RibbonWidth и укажите число, определяющее толщину лент: чем меньше число, тем тоньше будут ленты.

Заставка Мыльные пузыри

Для скринсейвера Мыльные пузыри, например, можно сделать пузыри металлическими на вид или прозрачными, сконфигурировать, будут ли пузыри с тенью и будут ли они показываться на фоне рабочего стола или на фоне сплошного черного цвета.

Вид пузырей - откройте раздел HKCU\Software\Microsoft\Windows\CurrentVersion\Screensavers\Bubbles и создайте параметр DWORD MaterialGlass. Для стеклянных пузыерей используйте значение 1, и 0 для получения металлических пузырей.

Отображение теней - в том же разделе создайте параметр DWORD ShowShadows со значением 1 для отображения теней под пузырями или 0 для их отсутствия.

Отображение на Рабочем столе - опять в том же разделе создайте новый параметр DWORD ShowBubbles со значением 1 для отображения пузырей на рабочем столе или 0 для их отображения на сплошном черном фоне.

Смотри также управление заставками в апплете Экран Панели управления


Автозагрузка

Что скрывается в автозагрузке?

Существует несколько способов прописать программу в автозагрузку. Самый простой - скопировать программу или ярлык в папку Автозагрузка, а также настроить задания планировщика и скрипты групповой политики, выполняющиеся при входе пользователя в систему. Но существует другой способ - через реестр. Этим способом часто пользуются вредоносные программы (вирусы, трояны, шпионы).

Для автоматического запуска программ и скриптов в Windows, как правило, используются разделы реестра Run в двух местах:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run

Сперва откройте раздел HKLM\Software\Microsoft\Windows\CurrentVersion.

Найдите там подразделы Run, RunOnce В этих разделах есть строковые ключи (некоторые разделы пустые), отвечающие за запуск программ. Название ключа может быть произвольным, а в качестве значения у них указывается запускаемая программа, если надо - то с параметрами. Обратите внимание на разделы, в названии которых присутствует "Once". Это разделы, в которых прописываются программы, запуск которых надо произвести всего один раз. Например, при установке новых программ некоторые из них прописывают туда ключи, указывающие на какие-нибудь настроечные модули, которые запускаются сразу после перезагрузки компьютера. Такие ключи после своего запуска автоматически удаляются.

Внимательно проверьте, что за программы у вас запускаются. Подумайте, все ли они нужны вам при загрузке и лишнее просто удалите. Это позволит значительно ускорить загрузку Windows.

В разделе HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion есть только два подраздела, отвечающие за автозагрузку: Run и Runonce. Изначально они пустые, так что все записи сделаны другими программами.

Запрет на автозагрузку

Существуют способы наложения запрета на автозагрузку программ через записи в реестре, указанные выше. Используются параметры типа DWORD. Все параметры должны храниться в разделе HKLMSoftware\Microsoft\Windows\CurrentVersion\Policies\Explorer

Для запрета запуска программ, прописанных в подразделе Run раздела LOCAL MACHINE используется параметр DisableLocalMachineRun со значением 1. В этом случае система игнорирует содержимое списка Run, находящегося в LOCAL MACHINE.

Аналогично действует запрет списка Run Once для LOCAL MACHINE. За состояние этой политики отвечает параметр DisableLocalMachineRunOnce. Система игнорирует содержимое RunOnce в LOCAL MACHINE.

Для запрета списка Run раздела CURRENT USER используется параметр DisableCurrentUserRun.

Для запрета списка Run Once раздела CURRENT USER используется параметр DisableCurrentUserRunOnce

Форсирование нормального приоритета потока для программ в автозагрузке

Материал с сайта Ускорение загрузки Windows одним твиком реестра | Вадим Стеркин

Поток (thread) является частью процесса и может выполняться с разным приоритетом. Потокам с высоким приоритетом требуется больше ресурсов, чем их коллегам с обычным или низким приоритетом.

В Windows Vista для размещенных в автозагрузке программ зафиксировали приоритет потока (thread priority) на обычном уровне (Normal) и заблокировали любые попытки повысить его. Эти ограничения действовали на протяжении некоторого периода времени после запуска системы.

Логика создателей Windows Vista была такова, что если этого не сделать, некоторые разработчики будут стремиться повысить приоритет своих программ, чтобы растолкать локтями тех, кто этого не сделал. Поэтому все программы в автозагрузке поставили в равные условия.

Понижение приоритета CPU и I/O для программ в автозагрузке

Все программы в автозагрузке Windows Vista поместили в «коробку» (“box”, в терминологии Performance Team, отвечающей за производительность системы). На практике это означало, что по умолчанию на протяжении 60 секунд после запуска системы для всех приложений в автозагрузке задавался приоритет:

  • CPU ниже обычного (below normal), чтобы уменьшить нагрузку на процессор
  • I/O очень низкий (very low), чтобы снизить интенсивность обращений к диску

Таким образом, каждая программа в автозагрузке меньше нагружала систему во время ее запуска. А по истечении заданного периода времени приоритет программы восстанавливался на уровень, определенный ее создателями.

Microsoft закопала топор войны за автозагрузку с выходом Windows 7. Трудно сказать, что послужило основной причиной. Возможно, было много нареканий от корпоративных клиентов, недовольных медленным выполнением скриптов групповой политики.

С другой стороны, за три года, прошедших с выпуска Windows Vista, улучшились аппаратные конфигурации компьютеров на рынке. Появились новые, более мощные процессоры, а твердотельные накопители стали проникать в массы. Это снизило полезный эффект от помещения в коробку автоматически запускаемых программ. Так или иначе, в Windows 7 и Windows 8 приоритет CPU и I/O для программ в автозагрузке не понижается, а возможность увеличить приоритет потока не блокируется. Однако топор войны не утоплен, а именно закопан!

В каких случаях изменение в реестре ускорит загрузку системы

Наибольшее ускорение загрузки Windows будет наблюдаться в системах, где:

  • много программ в автозагрузке
  • слабый процессор
  • медленный жесткий диск (например, 5400 rpm)

Таким образом, ускорение будет заметно на глаз на нетбуке или слабом ноутбуке с двумя-тремя десятками программ в автозагрузке. Если же у вас четырехъядерный процессор, SSD диск и минимум программ в автозапуске, вы вряд ли заметите ускорение загрузки.

Параметр реестра, изменяющий приоритет CPU и I/O для программ в автозагрузке

Описанные выше возможности остались в Windows 7 и Windows 8. Их просто отключили, изменив низкоприоритетный период с 60 секунд до 0. Вы можете установить любой интервал по своему усмотрению!

  1. Перейдите в раздел реестра HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced\DelayedApps
  2. Станьте владельцем этого раздела (по умолчанию им владеет системная учетная запись TrustedInstaller).
  3. Задайте желаемое значение для параметра Delay_Sec в секундах (в десятичном формате). Например, установите 120 секунд.
  4. Верните исходного владельца раздела реестра, как описано в шаге 2.

Вот и все! Теперь на протяжении заданного интервала времени программы из автозагрузки будут иметь низкий приоритет CPU и I/O.

Как проверить приоритет запущенных программ

С помощью утилиты Process Explorer вы можете быстро посмотреть, с каким приоритетом запущены процессы.


Общее диалоговое окно открытия и сохранения файла

Диалоговое окно открытия и сохранения файла

Windows 7 имеет новое диалоговое окно "Открыть/Сохранить файл".

Списки последних открытых и сохранённых файлов в стандартных окнах открытия и сохранения файлов

Каждый раз, когда мы пользуемся стандартными диалоговыми окнами, то Windows сохраняет список последних открытых и сохранённых файлов в реестре. Порой эти записи слишком разрастаются. Кроме того, возможно вам не хотелось бы оставлять следы своей деятельности на компьютере. Этот список можно безболезненно удалить (или часть записей). Данный список хранится по адресу HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ComDlg32

Раздел HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\ComDlg32\LastVisitedPidlMRU содержит параметры от a до z, а также параметр MRUList (определяет очередность вызова файлов). Они определяют список использованных путей.

Раздел HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\ComDlg32\OpenSavePidlMRU хранит список MRU для диалога Открытие/Сохранение файла. Каждый подраздел определяет список недавно выбранных файлов конкретного расширения.

В левой части диалогового окна расположены пять системных папок, которые можно поменять местами или изменить на те, которыми вы часто пользуетесь. Создайте в ветви HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\comdlg32 раздел PlacesBar. В нем хранятся имена папок. Как я уже говорил, их пять. И у каждой свой параметр. У первой Place0, у второй Place1, а у пятой Place4. Системные папки имеют значение типа DWORD:

Название папки | Значение
Рабочий стол | 00000000
Мои документы | 00000005
Мои рисунки | 00000027
Мои видеозаписи | 0000000e
Мой компьютер | 00000011
Избранное | 00000006
Мое сетевое окружение | 00000012
Шрифты | 00000014
History | 00000022

Папки могут быть и обычные, где строковое значение параметра Place указывает путь к папке. Например:
Place1="C:\Windows\Systems"

Если вы не используете все пять параметров, а только часть из них, например Place0 и Place1, то в левой части диалогового окна будут отображаться столько же папок.

Старый вид диалогового окна

Чтобы вернуться к старому виду диалогового окна Windows 95/98, создайте DWORD-параметр NoPlacesBar со значением 1 в HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\comdlg32

Убираем кнопку Назад

Чтобы убрать кнопку Назад из Общего диалогового окна, создайте параметр NoBackButton типа DWORD со значением 1 в HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\comdlg32

Убираем список файлов

Чтобы убрать выпадающее комбинированное окно со списком файлов (Имя файла), создайте параметр NoFileMru типа DWORD со значением 1 в HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\comdlg32

Смотри также

Диалоговое окно открытия и сохранения файла для Office


Запись компакт-дисков

Оболочка Windows позволяет прожигать компакт-диски, если установлен пишущий CD-ROM. Чтобы запретить пользователю пользоваться пишущим приводом, в разделе HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer создайте параметр DWORD NoCDBurning и присвойте ему значение 1.

Политика: Конфигурация Конфигурация пользователя → Административные шаблоны → Компоненты Windows → Проводник Windows → Удалить возможности записи компакт-дисков


Контекстное меню дисков, папок и файлов

Контекстное меню папок и файлов, дисков

Как сделать доступными команды контекстого меню "Открыть/Печать/Редактировать" для более 15 файлов

В Windows 7 команды "Открыть/Печать/Редактировать" не отображаются в контекстном меню, если оно вызывается сразу для 15 и более файлов. Такое поведение реализовано по умолчанию, так как использование этих команд сразу для большого количества файлов редко используется пользователями. Чтобы снять данное ограничение, откройте раздел HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer и для параметра MultipleInvokePromptMinimum установите значение 16 (режим безлимитный). Также вы можете использовать значения от 1 до 15, чтобы установить собственные значения для скрытия указанных элементов меню. Например, при значении 3, уже к четырём одновременно выделенным файлам команды меню применяться не будут. Но не используйте значение ключа равным нулю - вы отключите команды вообще, в том числе и команду "Открыть".

Источник: Context menus are shortened when more than 15 files are selected

Настройка контекстного меню рабочего стола Windows 7

Можно добавлять свои пункты в контекстное меню рабочего стола и получать быстрый доступ к настройкам системы и приложениям. Рассмотрим несколько вариантов.

Доступ к настройкам системы

Для добавления пунктов контекстного меню рабочего стола в разделе HKCR\Directory\Background\shell создайте новый раздел, название которого будет соответствовать названию пункта меню, например Свойства системы

Примечание. Здесь можно использовать два варианта: первый – это когда имя подраздела соответствует названию пункта контекстного меню. Второй – значение параметра “По умолчанию” в созданном подразделе должно соответствовать названию пункта контекстного меню.

В новом подразделе создайте подраздел с именем command и в его параметре по умолчанию пропишите команду, запускающую необходимую оснастку, например, для запуска свойств системы используйте control sysdm.cpl. В контекстном меню рабочего стола появится пункт Свойства системы.

Также можно назначить значок для нового пункта контекстного меню. В созданном выше разделе создайте строковый параметр Icon и пропишите в нем путь к значку, например, shell32.dll,15

Еще один параметр, который можно использовать для изменения вида нового пункта меню – это Position. Параметр, который создается в том же разделе, что и параметр Icon, позволит определить положение этого пункта меню. По умолчанию новый пункт меню расположен посередине, но его можно переместить в нижнюю часть контекстного меню или вверх. Значения параметра доступны только bottom и top - соответственно внизу и вверху меню; есть еще значение middle, но оно бесполезно так как отвечает расположению по умолчанию, то есть так же как и без параметра Position вовсе.

Лишние команды в меню

При установке многих программ контекстное меню файлов и папок постепенно заполняется лишними пунктами.

Чтобы оставить в меню только то, что действительно нужно, найдите ветвь HKCR\*\shellex\ContextMenuHandlers - в ней в качестве подразделов выступают команды, отображаемые в меню любого файла. Просто удалите ненужные команды.

Команды, привязанные к конкретному типу файлов можно найти уже в ветвях, соответствующих такому типу. Например, для файла AVI это будет раздел HKCR\avifile\shell

Соответственно, чтобы добавить новый пункт в контекстное меню, нужно прописать строку типа

HKEY_CLASSES_ROOT\*\shell
@="Путь_к_программе %1"

Например, чтобы прописать пункт "Открыть с помощью..." в контекстном меню, найдем ключ HKCR\*\shell\openas\command Измените значение "По умолчанию" на "C:\WINDOWS\rundll32.exe shell32.dll,OpenAs_RunDLL %1" (путь к файлу подредактируйте при необходимости).

За меню папок отвечают разделы: HKCR\Directory\shell и HKCR\Folder\shell

За меню дисков отвечают HKCR\Drive\shell

Например, для быстрой очистки диска создайте в указанном месте новый раздел типа Очистка диска, в котором создать раздел command, в параметре "По умолчанию", которого прописать:
C:\WINDOWS\cleanmgr.exe /d %1
Теперь нажав правой кнопкой мыши на каком-либо диске можно выбрать команду Очистка диска.

Есть также раздел, в котором задается контекстные меню для принтеров: HKCR\Printers\shellex\ContextMenuHandlers

Команда Закрепить в меню Пуск для папки

В контекстном меню программы или ярлыка в операционной системы Windows XP и Vista есть команда Закрепить в меню Пуск. Можно добавить такую же команду и для папки - в разделе HKCR\Folder\shellex\ContextMenuHandlers создайте раздел с любым названием и введите для параметра по умолчанию значение {a2a9545d-a0c2-42b4-9708-a0b2badd77c8}. Теперь, если нажать на клавишу Shift и вызвать контекстное меню папки, то увидите в нем команду Закрепить в меню Пуск.

Редактирование меню Открыть с помощью (XP и Vista)

Если в контекстном меню Открыть с помощью... Проводника имеются лишние ярлыки неиспользуемых приложений, то можно отредактировать этот список. Сначала нужно определиться с расширением файлов, контекстное меню которых требуется изменить. Далее найдите ветку HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts, выберите в ней нужное расширение и внесите соответствующие изменения в содержимое подраздела OpenWithList.

Управление Windows Aero из контекстного меню Проводника

Можно добавить в контекстное меню Проводника команды быстрого отключения и включения интерфейса Aero. Для этого откройте ветку HKCR\Directory\Background\shell и создайте новый подраздел Включить Aero. Внутри созданного раздела Включить Aero создайте новый подраздел command и задайте строковому параметру значение Rundll32 dwmApi #102.

Повторяем шаги для второй команды. Снова в разделе shell (смотри выше) создаем новый подраздел Отключить Aero, затем подраздел command и в строковом параметре прописать команду Rundll32 dwmApi #104.

Вкладка Безопасность

Если у вас пропала вкладка Безопасность в свойствах папок, файлов и дисков, проверьте параметр типа DWORD NoSecurityTab в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer. Чтобы данная вкладка была видна, нужно установить значение 0, в противном случае установите значение 1.


Исполняемые файлы и ярлыки

Если вдруг вы не можете запустить исполняемые файлы или ярлыки (например, в результате ваших экспериментов с реестром), то решить эту проблему сможет мой справочник :-)

Откройте раздел

HKCR\exefile\shell\open\command
и присвойте параметру по умолчанию значение "%1" %*


Ярлыки

Удаление стрелочки с ярлычка

При создании ярлыка для папки, файла, диска и т.д., то в нижнем левом углу значка для этого элемента будет изображена стрелочка. Чтобы удалить эти стрелочки с ярлычка, нужно удалить параметр IsShortcut из раздела HKCR\lnkfile


Удаление "ладошки" из расшаренных ресурсов

Для удаления "ладошки" из расшаренных ресурсов нужно удалить строковое значение По умолчанию из раздела

HKCR\Network\SharingHandler

Чтобы вернуться к прежнему состоянию, используйте строку ntshrui.dll


Перемещение HOST, LMHOST и других файлов из Windows\System32\drivers\etc в другое место

Если вы хотите указанные файлы в другое место (например, по соображениям безопасности) из папки Windows\System32\drivers\etc, то:

  1. Скопируйте файлы в новое место
  2. Зайдите в раздел
    HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
  3. Измените значение параметра DataBasePath на новый путь к папке
  4. Перезагрузитесь и удалите файлы из %SystemRoot%\System32\drivers\etc


Увеличение скорости всплывания меню

Иногда при выборе меню появляется подменю. Существует возможность менять скорость появления этих подменю (в т.ч. меню кнопки Пуск), облегчая работу на компьютере. Для этого используйте строковый параметр MenuShowDelay в разделе HKCU\Control Panel\Desktop.

По умолчанию он равен "400". Значение "0" соответствует наиболее быстрому реагированию на движение мыши. Данный параметр можно менять от "0" до "32767". Рекомендуется от 100 до 200.


Отключения автозапуска компакт-дисков

Автозапуск CD-ROM

Отключение стандартного автозапуска компакт-дисков

Чтобы отключить автозапуск компакт-диска, устанавливаем значение параметра типа DWORD AutoRun, равным 0 в разделе

HKLM\SYSTEM\CurrentControlSet\Services\CDRom

Отключение нового метода автозапуска компакт-дисков

В Windows XP существует новый метод автозапуска стандартных компакт-дисков (имеются в виду только те компакты, на которых не предусмотрен специальный вызов автозапуска через autorun.inf). Можно отключить данный метод или настроить его под себя. Итак, открываем следующий раздел:

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\AutoplayHandlers\CancelAutoplay\Files

В этом разделе находятся текстовые параметры, содержащие имена файлов, отыскав которые на вашем компакте встроенный AutoRun запускаться не станет и позволит запустить компакт через autorun.inf. Добавьте строковый параметр следующего содержания: *.* и наслаждайтесь полным спокойствием вашего CD-ROM


Запрещение/Разрешения на запуск программ

Запрещение запуска программ

Windows позволяет ограничить доступ к программам, кроме разрешенных в специальном списке.

Для ограничения запускаемых программ надо открыть раздел HKCU\SOFTWARE\Microsoft\Windows\CurrentVerson\Policies\Explorer и создать там ключ RestrictRun типа DWORD со значением 0х00000001. Затем тут же надо создать подраздел с аналогичным именем RestrictRun и в нем перечислить список РАЗРЕШЕННЫХ к запуску программ для текущего пользователя. Записи в этом подразделе пронумеровываются, начиная с 1, и содержат строки с путями (необязательно) и именами приложений. Файлы должны быть с расширением. Например, Word.exe, Excel.exe ...

Не забудьте указать файл Regedit.exe, иначе Вы сами не сможете больше запустить редактор реестра! Для сброса ограничения на запуск программ надо установить значение ключа RestrictRun в 0.

Разрешения на запуск приложение, кроме указанных в списке

Можно решить обратную задачу и указать список запрещенных к запуску приложений. Надо открыть раздел HKCU\SOFTWARE\Microsoft\Windows\CurrentVerson\Policies\Explorer и создать там ключ DisallowRun типа DWORD со значением 1. Затем надо создать подраздел с этим же именем DisallowRun и в нем указать список запрещенных программ в виде строковых параметров. Записи в этом подразделе пронумеровываются, начиная с 1, и содержат строки с путями (необязательно) и именами приложений. Файлы должны быть с расширением. Например, Word.exe, Excel.exe. Например:

"1" - "calc.exe"
"2" - "thebat.exe"
"3" - "hl.exe"

Эта настройка действует на программы, который запускает процесс от Windows Explorer, но не защищает от запуска этих программ при помощи Диспетчера задач (Task Manager), который запускается системным процессом или другими процессами. Также эти программы можно запустить через командную строку Cmd.exe.

Запрет на запуск редактора реестра

Вы можете запретить запуск редактор реестра. Для этого в разделе HKCU\SOFTWARE\Microsoft\ Windows\CurrentVerson\Policies\System нужно добавить ключ типа DWORD DisableRegistryTools со значением 1. Запуск редактора реестра будет запрещен, однако останется возможность вносить изменения с помощью программного обеспечения сторонних разработчиков и с помощью REG-файла.

Запрет на запуск программы Диспетчер задач Windows

Чтобы запретить пользователю возможность запуска Диспетчера задач Windows, установите в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System значение параметра типа DWORD DisableTaskMgrравным 1.

Запрет на запуск программы Windows Media Center

Запуск программы Windows Media Center можно запретить при помощи параметра DWORD MediaCenter со значением 1 в разделе HKCU/Software\Policies\Microsoft\WindowsMediaCenter.

Политика: Конфигурация компьютера (Конфигурация пользователя) → Административные шаблоны → Компоненты Windows → Windows Media Center → Не запускать Windows Media Center

Запрет на запуск программы Ножницы (Windows Vista)

Запуск программы Ножницы можно запретить при помощи параметра DWORD DisableSnippingTool со значением 1 в разделе HKCU/Software/Policies/Microsoft/TabletPC.

Запрет на запуск программы Записки (Windows Vista)

Запуск программы можно запретить при помощи параметра DWORD DisableStickyNotes со значением 1 в разделе HKCU/Software/Policies/Microsoft/TablePC.

Запрет на запуск программы Журнал Windows (Windows Vista)

Запуск программы можно запретить при помощи параметра DWORD DisableJournal со значением 1 в разделе HKCU/Software/Policies/Microsoft/TablePC.

Запрет на запуск программы Календарь Windows (Windows Vista)

Запуск программы можно запретить при помощи параметра DWORD TurnOffWinCal со значением 1 в разделе HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Windows. Это можно сделать также при помощи групповой политики Выключить календарь Windows в разделе Конфигурация компьютера | Административные шаблоны | Компоненты Windows | Календарь Windows оснастки Редактор объектов групповой политики (gpedit.msc).

Запрет на запуск программу Помощник по цифровой корзине

Запретить запуск программы можно при помощи параметра DWORD DoNotRunDigitalLocker со значением 1 в разделе HKLM\Software\Policies\Microsoft\Windows\Digital Locker

Запрет на запуск Центра мобильности Windows

Чтобы запретить запуск Центра мобильности Windows, можно скрыть отображение данного окна в Панели управления при помощи параметра DWORD NoMobilityCenter со значением 1 в разделе HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\MobilityCenter.

Политика: Конфигурация компьютера (Конфигурация пользователя) → Административные шаблоны → Компоненты Windows → Центр мобильности Windows → Отключить центр мобильности Windows


Средство удаления вредоносных программ

Как проверить, что на клиентском компьютере запускалось средство удаления вредоносных программ?

Чтобы определить, запускалось ли это средство, проверьте значение параметра Version в разделе HKLM\SOFTWARE\Microsoft\RemovalTools\MRT. Необходимо сравнить данное значение с таблицей на сайте Microsoft.

Что предпринять, чтобы данное средство не отправляло отчеты в корпорацию Майкрософт?

Чтобы отключить отправление отчетов в корпорацию Майкрософт, пользователю с правами администратора необходимо добавить параметр DWORD DontReportInfectionInformationсо значением 1 в разделе HKLM\SOFTWARE\Policies\Microsoft\MRT.

Данная функция отключается автоматически, если в реестре существует следующий параметр: HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\WUServer. Наличие этого параметра говорит о том, что компьютер подключен к серверу SUS.

Смотри также

Средство удаления вредоносных программ mrt.exe

Средство удаления вредоносных программ для Microsoft Windows удаляет наиболее распространенные виды вредоносных программ с компьютеров под управлением Windows Vista, Windows Server 2003, Windows XP и Windows 2000


Пароли и безопасность

Рассматриваемые настройки хранятся в ветви

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Network
Все ключи имеют тип DWORD, если это не обговорено отдельно; значение ключа равное 1 включает данную опцию, 0 выключает, если это не обговорено отдельно

Отмена кэширования пароля

Данная настройка помогает избавиться от проблемы "утаскивания" и дальнейшего взлома ваших сетевых и интернет паролей. Эти пароли хранятся в файле с расширением PWL. Отключение кэша запрещает запись паролей в этот файл. Следовательно, его "выкрадывание" и дальнейший взлом не приносят никаких результатов. Единственное неудобство - это надобность вводить каждый раз при коннекте в окно DialUp - Password пароль вручную. Но это всё же лучше, чем "подарить" пароль и логин хакеру. Итак, используем параметр типа DisablePwdCaching со значением 1

Находим в каталоге Windows файл (или файлы) с расширением PWL. Удаляем их. Перезагружаемся. Файл паролей хоть и создаётся опять, но он пустой :-)

Звездочки в паролях

Параметр типа HideSharePwds со значением 1 определяет, показывать ли пароли к расшаренным ресурсам (имеющим общий доступ) открытым текстом или заменять их звездочками.

Запрет перечисления рабочей группы

Для того чтобы запретить перечисление содержимого рабочей группы, надо установить значение ключа NoWorkgroupContents равным 1.

Даже при запрете пользователи могут подключаться к компьютерам в своей рабочей группе или домене. Для этого необходимо набрать полное сетевое имя разделенного ресурса в формате UNC, в диалоговых окнах команд "Выполнить" или "Подключить сетевой диск".

Смотри также
Пароли
Отмена кэширования пароля в IE


CMD

Командная строка

Быстрая вставка

За режим быстрой вставки отвечает параметр QuickEdit со значением 1 в разделе HKCU\Console. Этого результата проще добиться через настройки командной строки. Запустите командную строку и щелкните в левом верхнем углу окна (или Alt+Пробел). Выберите в меню команду Умолчания и отметьте галочкой пункт Быстрая вставка.

Изменение вида приглашения

Вы можете изменить вид приглашения для командной строки. Как правило используется формат типа C:\> (текущий диск и угловая скобка). Откройте раздел HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment и создайте параметр PROMPT типа REG_EXPAND_SZ, которому нужно присвоить одно из следующих значений:

  • $B - | (вертикальная черта)
  • $D - текущая дата
  • $G - > (знак больше)
  • $L - < (знак меньше)
  • $N - текущий диск
  • $P - текущий диск и путь
  • $Q - = (знак равно)
  • $T - текущее время
  • $V - версия Windows
  • $$ - $ (знак доллара)

Запрет на расширенный режим командного процессора CMD.EXE

Существует возможность запрета на расширенный режим командного процессора (cmd.exe). Например, в расширенном режиме существуют такие команды как del, erase, chdir, goto. Для запрета найдите или создайте параметр типа DWORD EnableExtensions в разделе

HKCU\Software\Microsoft\Command Processor
и присвойте ему значение 0. Для включения этого режима используйте значение 1

Отложенное расширение переменных среды

Отложенное расширение переменных среды по умолчанию не включено. Для включения используйте параметр типа DWORD DelayedExpansion, равный 1 в разделе

HKCU\Software\Microsoft\Command Processor

Запрет на режим командной строки и обработки bat-файлов

Существует возможность запрета на режим командной строки (cmd.exe) и обработки bat-файлов. Для этого найдите или создайте параметр типа DWORD DisableCMD в разделе

HKCU\Software\Policies\Microsoft\Windows\System

Данный параметр может принимать следующие значения
0 (или отсутствие записи в реестре | Система может использовать режим командной строки и обрабатывать bat-файлы
1 | Система не может использовать режим командной строки, но может обрабатывать bat-файлы
2 | Система не может использовать режим командной строки и обрабатывать bat-файлы

Автонабор команд

Для включения возможности автонабора команд по нажатию клавиши Tab, в разделе

HKCU\Software\Microsoft\Command Processor
установите значение параметра типа DWORD CompletionChar равным 9, что соответствует идентификатору клавиши Tab. Для клавиши Backspace используйте 8, для клавиш Ctrl-D - 4, для Ctrl-F - 6

Откуда запускать командную строку

По умолчанию консоль cmd.exe стартует в папке профиля пользователя, но этот порядок вполне можно изменить. Для этого надо в разделе

HKCU\Software\Microsoft\Command Processor
создать строковый параметр AutoRun с указанием в его значении команды перехода к необходимой директории - например, - CD /D C:\ - именно в ней и будет стартовать консоль. Кстати говоря, в значении этого параметра можно указать и специально заготовленный bat-файл с разными командами, с параметрами переменных окружения и т. п. Получится что-то вроде autoexec.bat для консоли, да и редактировать такой файл удобнее, чем параметры в реестре.

Добавление новых шрифтов

Если щелкнуть правой кнопкой на заголовке окна программы CMD.EXE и выбрать пункт меню Свойства, а затем выбрать вкладку Шрифт, то увидите один или два шрифта на выбор. Можно добавить свои моноширные шрифты. Для этого зайдите в раздел

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Console\TrueTypeFont
Там уже присутствует строковый параметр 0 со значением Lucida Console. Создайте новые строковые параметры 00 со значением Courier New и параметр 000 со значением Lucida Sans Typewriter (Это стандартные шрифты, присутствующие в Windows). Можете поискать другие моноширные шрифты на сайте http://www.lowing.org/fonts/.


Консоль управления Windows (MMC)

Запрет на запуск консоли управления в авторском режиме

Чтобы запретить пользователю возможность запуска Консоль управления Windows (MMC) в авторском режиме, установите значение параметра типа DWORD RestrictAuthorMode равным 1 в разделе

HKCU\Software\Policies\Microsoft\MMC
В этом случае будет выводиться сообщение о невозможности открыть консоль управления в авторском режиме

Запрет на запуск любой оснастки консоли управления

Чтобы запретить пользователю возможность запуска любой оснастки, установите значение параметра типа DWORD RestrictToPermittedSnapins равным 1 в разделе

HKCU\Software\Policies\Microsoft\MMC
В этом случае будет выводиться сообщение о невозможности открыть оснастку


Раскладка клавиатуры

Раскладка для окна Приветствие

Если при установки системы вы в качестве основного языка установили русский язык, а пароль обычно используете на английском языке, то при выводе окна Приветствие вам каждый раз придется переключаться с русского языка на английский, чтобы ввести пароль. Чтобы по умолчанию система выводила английскую раскладку в этом окне надо открыть раздел

HKU\.DEFAULT\Keyboard Layout\Preload
И там надо на первую позицию поместить желаемую раскладку - 00000409 (английская раскладка) или 00000419 (русская), т.е. просто поменяйте их местами.

Свой текст для названия раскладки

Рядом с часиками находится значок раскладки, позволяющий переключать языки при набивке текста (В России обычно используют два языка - Русский и английский). Чтобы изменить всплывающий текст при подведении мыши, идем в раздел

HKLM\System\CurrentControlSet\Сontrol\Nls\Locale.
Там нужно изменить значение соответствующего параметра. Параметр русского языка — 00000419, английского — 00000409 и т.п. Например, вместо слова Русский пишем Великий и могучий


Изменение порога выдачи предупреждения о недостатке свободного места на диске

Если на вашем диске остается свободным менее 10% (по умолчанию) места, то система информирует об этом появлением иконки в области уведомления (рядом с часиками). На дисках маленькой емкости этот порог вполне оправдан, но для дисков большой емкости это не совсем удобно. Можно изменить порог в процентном соотношении. Находим параметр типа DWORD DiskSpaceThreshold, в котором указываете значение от 0 до 99 (т.е процент от объема диска) в разделе

HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters

Недостаточно места на диске

Если Windows постоянно выводит сообщения о том, что на диске мало места (см. выше), то создайте параметр типа DWORD NoLowDiskSpaceChecks со значением, равным 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer


Режим LBA48

Для работы с дисками более 137 Гб в Windows необходимо включить поддержку 48-разрядного режима – LBA48. Для этого необходимо в разделе

HKLM\SYSTEM\CurrentControlSet\Services\Atapi\Parameters
создать параметр DWORD EnableBigLba и присвоить ему значение «1».


Defragment

Дефрагментация

Параметры, необходимые для работы дефрагментации диска, хранятся в разделе HKLM\SOFTWARE\Microsoft\Dfrg. Рассмотрим часть из них.

LogFilePath: параметр строкового типа позволяет задать путь к лог-файлу, в который программа dfrgui.exe будет записывать сведения о процессе своей работы. Например, туда заносятся сведения анализа диска. Следует только учитывать, что размер данного файла будет очень большой.

CreateLogFile: DWORD-параметр определяет, будет ли создаваться лог-файл работы программы дефрагментации диска.

DoNoOptimizeForVolsnap: DWORD-параметр определяет, будет ли выполняться оптимизация доступа к снимкам системы во время дефрагментации раздела диска.

FreeSpaceErrorLevel: По умолчанию дефрагментация диска не начнется, если на диске, содержимое которого дефрагментируется, нет, как минимум, 15% свободного места. Это место необходимо программе дефрагментации для хранения временных файлов, необходимых в процессе дефрагментации. Однако вы можете изменить процент свободного места, необходимый программе дефрагментации, изменив значение данного параметра.

Как уменьшить фрагментируемость больших файлов на диске?

Для того чтобы операционная система при записи файла на диск сначала нашла для него наиболее подходящее по размеру место и поместила его туда, как можно меньше дробя на части, необходимо добавить в раздел

HKLM\System\CurrentControlSet\Control\FileSystem
параметр ContigFileAllocSize со значением типа dword равный 00000200, который и определяет максимальный размер нефрагментируемого блока данных на диске. При желании размер такого блока можно еще увеличить. Данная настройка может быть очень полезной при работе с мультимедиа (уменьшается нагрузка на диск и процессор при записи и воспроизведении видео или звуковых файлов).

Boot defrag (Windows XP)

Суть boot defrag заключается в дефрагментации тех файлов, что нужны для старта операционной системы. Выключение этой функции позволит на некоторое время уменьшить время загрузки, но со временем она будет становиться все медленнее. Если хотите отключить данную функцию, то идем в раздел

HKLM\SOFTWARE\Microsoft\Dfrg\BootOptimizeFunction
и меняем там значение параметра Enable на N. Для включения используйте Y


Проверка диска

Изменение времени ожидания

При загрузке Windows после неправильного выключения запускается проверка дисков. При этом пишется что-то вроде "Через 10 секунд начну проверять...". Чтобы уменьшить время ожидания надо в разделе

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager
создать или отредактировать параметр AutoChkTimeOut типа DWORD и присвоить ему значение в секундах. По умолчанию установлена пауза в 10 секунд. Если вы присвоите ему значение больше чем 259200 секунд (около 3 дней), то будет использоваться значение по умолчанию


Поиск драйверов устройств в Центре обновления Windows

Чтобы запретить производить поиск драйверов устройств в Центре обновления Windows при их отсутствии на локальном диске, установите значение параметра типа DWORD DontSearchWindowsUpdate в разделе

HKLM\SOFTWARE\Policies\Microsoft\Windows\DriverSearching
равным 1

Чтобы не выводить администратору системы запрос на подтверждение поиска драйвера устройства в Центре обновления Windows при их отсутствии на локальном диске, установите значение параметра типа DWORD DontPromptForWindowsUpdate в разделе

HKLM\SOFTWARE\Policies\Microsoft\Windows\DriverSearching
равным 1


USB

Существует способ запретить использование USB-накопителей в Windows XP. Откройте раздел

HKLM\SYSTEM\CurrentControlSet\Services\UsbStor
и установите значение параметра Start равным 4. USB-диски после этого работать перестанут


Клавиши

Отключение клавиши Windows

На некоторых современных клавиатурах присутствует клавиша Windows (как правило, логотип-флажок Майкрософт). Некоторым пользователям она мешает при быстрой печати или играх. Чтобы отключить ее, нужно создать новый двоичный параметр Scancode Map со значением 00 00 00 00 00 00 00 00 03 00 00 00 00 00 5B E0 00 00 5C E0 00 00 00 00 в разделе HKLM\SYSTEM\CurrentControlSet\Control\Keyboard Layout

Запрещение горячих клавиш с клавишей Windows

Можно отключить использование комбинацию "горячих" клавиш с клавишей Windows. Для этого создаем DWORD-параметр NoWinKeys со значением 1 в разделе HKCU\Software\Microsoft\Windows\Current Version\Policies\Explorer

Однако после установки этого запрета, одиночное нажатие клавиши Windows, которое вызывает меню "Пуск", будет работать.

Политика: Конфигурация пользователя → Административные шаблоны → Компоненты Windows → Проводник Windows → Отключить сочетания клавиш Windows+X

Клавиши быстрого доступа

Многие клавиатуры, кроме стандартных клавиш, имеют дополнительные, например, клавиши для запуска Калькулятора, Проигрывателя Windows Media, почтовой программы и т. д. Можно самостоятельно настроить данные клавиши под себя, ускорив работу с приложениями.

Для этого перейдем в раздел HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\AppKey. Раздел содержит подразделы, каждый из которых идентифицирует назначение одной клавиши. По умолчанию на большинстве клавиатур используются следующие подразделы.

  • 1 — задает команду клавиши Back (по умолчанию эта клавиша соответствует кнопке Назад в окне браузера).
  • 2 — задает команду клавиши Forward (по умолчанию она соответствует кнопке Вперед в окне браузера).
  • 3 — задает команду клавиши Refresh (по умолчанию эта клавиша соответствует кнопке Обновить в окне браузера).
  • 4 — задает команду клавиши Stop (по умолчанию она соответствует кнопке Стоп в окне браузера). К сожалению, назначение этой клавиши не всегда можно изменить.
  • 5 — задает команду клавиши Search (по умолчанию эта клавиша соответствует комбинации клавиш Windows+F).
  • 6 — задает команду клавиши Favorites (по умолчанию она соответствует кнопке Избранное в окне браузера).
  • 7 — задает команду клавиши Home (по умолчанию эта клавиша соответствует кнопке Домой в окне браузера).
  • 8 — задает команду клавиши Mute (по умолчанию она отключает звук в проигрывателе). К сожалению, назначение этой клавиши не всегда можно изменить.
  • 15 — задает команду клавиши E-mail (по умолчанию эта клавиша вызывает почтовую программу).
  • 16 — задает команду клавиши Media (по умолчанию она аналогична вызову программы, ассоциированной с расширением CDA — обычно Проигрыватель Windows Media).
  • 17 — задает команду клавиши My Computer (по умолчанию эта клавиша аналогична вызову окна Компьютер).
  • 18 — задает команду клавиши Calculator (по умолчанию она аналогична вызову программы calc.exe).

Чтобы изменить назначение клавиши, нужно создать в подразделе, соответствующем нужной клавише, строковый параметр ShellExecute и присвоить ему команду, которая будет выполняться при нажатии клавиши. Например, чтобы вместо калькулятора вызывать папку с программами (допустим, папку Download, расположенную в корневом разделе диска D:), нужно изменить в подразделе 18 значение строкового параметра ShellExecute на explorer /root, D:\Download.

Также, вместо параметра ShellExecute используется строковый параметр Assosiation, который ассоциирует клавишу с протоколом, например, mailto, .cda, http

Некоторые клавиши после изменения назначения принимают двойную функциональность. Например, после изменения назначения клавиши Favorites была замечена следующая особенность. Если при нажатии клавиши Favorites фокус установлен на папке, то будет вызвано окно Избранное, а если фокус установлен на Рабочем столе или окне какой-нибудь программы, то будет выполняться команда, присвоенная вами этой клавише.

Num Lock, Caps Lock, Scroll Lock

Некоторые сетуют, что при входе пользователя в систему переключатель клавиатуры Num Lock всегда выключен. Можно ли сделать, чтобы он всегда был включен? Да, можно.

Для этого найдите ветвь HKCU\Сontrol Panel\Keyboard и установите строковое значение InitialKeyboardIndicators равным нужному значению из списка

  • 0 - все переключатели выключены
  • 1 - Caps Lock включен
  • 2 - Num Lock включен
  • 3 - Caps Lock и Num Lock включены
  • 4 - Scroll Lock включен
  • 5 - Caps Lock и Scroll Lock включены
  • 6 - Num Lock и Scroll Lock включены
  • 7 - Caps Lock, Num Lock и Scroll Lock включены

Можно управлять состоянием клавиш-индикаторов до входа в систему в экране приветствия. Этот способ может пригодиться тем, кто использует для входа в систему в качестве пароля цифры. В этом случае вам надо установить параметр InitialKeyboardIndicators в разделе HKU\.DEFAULT\Control Panel\Keyboard.


Мышь

Основные настройки работы мыши хранятся в разделе HKEY_CURRENT_USER\Control Panel\Mouse. Все параметры имеют тип DWORD.

DoubleClickHeight
определяет высоту прямоугольника, в пределах которого два щелчка кнопкой мыши будут считаться двойным щелчком. По умолчанию значение данного параметра равно четырем пикселам.
DoubleClickWidth
задает ширину прямоугольника, в пределах которого два щелчка кнопкой мыши будут считаться двойным щелчком. По умолчанию значение данного параметра равно четырем пикселам.
MouseHoverHeight
определяет чувствительность наведения указателя мыши по вертикали. По умолчанию значение данного параметра равно четырем пикселам.
MouseHoverTime
задает время наведения указателя мыши. По умолчанию значение данного параметра равно 400.
MouseHoverWidth
определяет чувствительность наведения указателя мыши по горизонтали. По умолчанию значение данного параметра равно четырем пикселам.
MouseThreshold1
указывает предельную скорость перемещения указателя мыши, при достижении которой скорость перемещения указателя будет удваиваться.
MouseThreshold2
задает предельную скорость перемещения указателя мыши, при достижении которой скорость перемещения указателя станет в четыре раза больше.

Настройки колесика мыши

Настройки работы колесика мыши можно изменить в разделе HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Control Panel\Desktop. Данные настройки желательно менять в окне Свойства: Мышь.

WheelScrollChars
параметр строкового типа определяет количество столбцов, на которые будет выполняться горизонтальная прокрутка при повороте колеса прокрутки мыши. При значении данного параметра, равном -1, прокрутка будет выполняться на один экран.
WheelScrollLines
параметр строкового типа определяет количество строк, на которые будет выполняться вертикальная прокрутка при повороте колеса прокрутки мыши. При значении данного параметра, равном -1, прокрутка будет выполняться на один экран.


Выбор программы

Когда вы щелкаете на файле с незарегистрированным в системе расширением, то появляется окно "Выбор программы", в котором вам предлагается выбрать из предложенного списка программу, способную обработать неизвестный тип файла. Но в данном окне всегда установлен флажок "Всегда использовать эту программу...", что порой приводит к нежелательным проблемам. Как правило, данный флажок лучше не использовать, чтобы не повредить реестр. Существует способ, чтобы этот флажок отсутствовал по умолчанию. Для этого нужно немного подправить запись в реестре. Откройте раздел HKCR\Unknown\shell\openas\command и в установленном по умолчанию параметре запишите C:\WINDOWS\rundll32.exe shell32.dll,OpenAs_RunDLL %1 %2

Не искать в интернете

Если системе не знаком тип файла, который вы пытаетесь открыть, то сначала выводится диалоговое окно для поиска программы в интернете.

Если вы выберите этот вариант, то запускается веб-служба shell.windows.com/fileassoc/0409/xml/redir.asp?Ext=rar (пример для случая с RAR-файлом). Можно пропустить этот шаг и сразу искать нужную программу на своем компьютере. Для этого создайте параметр DWORD NoInternetOpenWith со значением 1 в разделе HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer

Не включать в список выбора программ

Список программ, которые выводятся в диалоговом окне выбора программы, формируется при помощи списка подразделов раздела HKEY_CLASSES_ROOT\Applications. В данном разделе вы можете видеть, что имена подразделов соответствуют именам программ, установленных на вашем компьютере. Если вы хотите, чтобы какая-то из этих программ никогда не выводилась в диалоговом окне выбора программы, то в подразделе этой программы создайте строковый параметр NoOpenWith без всякого значения.


Создание псевдонима для программы

Существует скрытая возможность создания псевдонима для запускаемой программы. Например, вы выбрали команду Пуск-Выполнить и напечатали WINRAR, а запускается блокнот NOTEPAD

Для этого найдите ветвь:

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths
- в ней в качестве подразделов выступают имена программ.

Войдите в один из разделов, например WINRAR.EXE из измените строковое значение по умолчанию на путь к другой программер, например C:\WINDOWS\NOTEPAD.EXE.

Теперь закройте реестр. Выберите Пуск-Выполнить и напечатайте winrar и у вас запустится блокнот


Обработка reg-файлов

Импорт значений из reg-файла без вывода диалогового окна

Когда вы в Проводнике щелкаете на reg-файл, то происходит импорт значений в реестр при помощи редактора реестра Regedit, при этом выводится запрос к пользователю на подтверждение этой операции, а после ее завершения - еще и сообщение, что данные были успешно внесены. Но данный редактор имеет ключ, позволяющий не выводить диалоговые окна. Если вы часто пользуетесь reg-файлами, то используя этот ключ, вы можете съэкономить себе время, не нажимая две кнопки. Для этого откройте раздел

HKCR\regfile\shell\open\command
и измените строковое значение по умолчанию на regedit.exe /s "%1"

Обработка reg-файлов как текстового документа

Если предыдущий совет кому-то покажется небезопасным (без вашего ведома будут меняться настройки!), то воспользуйтесь прямо противоположным способом. Пусть вместо импорта reg-файл будет открываться в Блокноте. Для этого используйте запись:
NOTEPAD.EXE "%1" (В случае необходимости измените путь к вашем текстовому редактору).


Значки для DLL

Оболочка Windows использует для файлов DLL определенный стандартный значок. Но порой эти dll-файлы сами содержат значки. Можно настроить систему таким образом, чтобы она выводила значок из этих файлов (Если файл значков не содержит, то будет выведен стандартный значок для неизвестного типа файлов). Идем в раздел
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\dllfile\DefaultIcon и меняем установленное строковое значение по умолчанию (например, "C:\WINDOWS\SYSTEM\shell32.dll,-154") на "%1"


Ускорение файловой системы

Можно ускорить действие файловой системы, (если позволяет оперативная память) увеличив параметр типа DWORD IoPageLockLimit от заданных по умолчанию 512 КБ до 4 МБ и более в разделе

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

Этот параметр представляет максимальное число байт, которые могут быть блокированы для операций I/O. Когда значение параметра равно 0, то система использует встроенный алгоритм определения необходимой памяти и использует объем 512 КБ. Установка максимального значения должна основываться на объеме памяти в Вашей системе.
Таблица рекомендуемых значений
RAM (MB) | IoPageLockLimit
32 | 4096000
64 | 8192000
128 | 16384000
256+ | 65536000


Отключение дебаггера

При возникновении каких-либо неполадок в работе приложений пользователю показывается окно с сообщением об ошибке и предложением закрыть приложение, при этом DrWatson (дебаггер по умолчанию) автоматически записывает информацию о сбое в log-файл. Для отключения этой службы вставляем в ключ реестра

HKLM\SOFTWARE\Microsoft\Windows NT\Current Version\AeDebug
строковый параметр Auto со значением 0. После этого DrWatson больше не будет загружаться автоматически, а будет выводиться окно с сообщением об ошибке. По умолчанию установлено 1 (автоматическая загрузка дебаггера)


Зависшие программы

Время, по истечении которого программу считать зависшей

Иногда программа зависает, т.е. не реагирует на обращение к ней. Приходится принудительно закрывать его (например, через Диспетчер задач (Ctr-Shift-Esc)):
Ключ HungAppTimeout в разделе

HKCU\Control Panel\Desktop
определяет время, по прошествии которого не отвечающее приложение считается зависшим (по умолчанию 5000 миллисекунд). Измените данный строковый параметр на необходимое значение.

Время ожидания перед завершением зависшего приложения

Ключ WaitToKillAppTimeout в разделе

HKCU\Control Panel\Desktop
задает время ожидания перед завершением зависшего приложения (по умолчанию 20000 миллисекунд). Измените данный строковый параметр на необходимое значение, например 2000.

Автоматическое завершение зависших программ

Вы можете разрешить системе автоматически завершать зависшие процессы. Для этого используйте строковый параметр AutoEndTasks в разделе

HKCU\Control Panel\Desktop
Значение "1" разрешает системе автоматически завершать процессы
Значение "2" - процессы не завершаются автоматически. Система ожидает, когда процесс завершится, и если время завершения процесса превышает значение HungAppTimeout (см. выше), то появлятеся диалоговое окно Завершение работы, указывающее, что приложение зависло

Примечания

При установке слишком малых значений в указанных ключах могут возникнуть проблемы с автозавершением запущенных задач, так как приложение может длительное время не отвечать на запросы в случае достаточно большой загруженности процессора или работой с другими программами.


Длинные и короткие имена файлов

Запрещение длинных имен файлов

Вы можете запретить длинные имена файлов в Windows, заставив тем самым генерировать имена в формате 8.3 (DOS-овский формат). Для этого в разделе

HKLM\System\CurrentControlSet\control\FileSystem
надо изменить параметр Win31FileSystem, присвоив ему значение 01 (по умолчанию стоит 00)

Сделанные изменения вступят в силу после перезагрузки


Формат MS-DOS для файлов и папок

По умолчанию Windows создает в разделе NTFS специальную таблицу, содержащую все имена файлов и папок в формате MS-DOS по формуле 8.3 (8 символов имени файла и 3 символа для его расширения). Данная возможность в настоящее время не совсем актуальна и ее можно отключить для повышения производительности системы.

Для этого установите параметр типа DWORD NtfsDisable8dot3NameCreation в разделе HKLM\System\CurrentControlSet\Policies равным 1.

Политика: Конфигурация компьютера → Административные шаблоны → Система → Файловая система → NTFS → Параметры создания коротких имен


Обновление метки последнего доступа к папке

По умолчанию Windows в системе NTFS обновляют метку последнего доступа к папке при их открытии. Данная возможность может тормозить вашу систему при слишком большом количестве папок. Если вас не интересует данная метка, то можете отключить данную возможность.

Для этого установите параметр типа DWORD NtfsDisableLastAccessUpdate равным 1в разделе

HKLM\SYSTEM\CurrentControlSet\Control\FileSystem


Быстрое завершение работы Windows

Windows NT версии 3.1и 3.5 позволяла закрыть все процессы за 20 секунд. В Windows XP существует возможность определять величину интервала, в течение которого система должна завершить свою работу. Для этого необходимо исправить ключ системного реестра – строковый параметр WaitToKillServiceTimeout, где установлена временная задержка закрытия всех запущенных сервисов в миллисекундах.

Этот ключ расположен в разделе

HKLM/SYSTEM/CurrentControlSet/Control

По умолчанию значение параметра равно 20000, что эквивалентно 20 секундам.

Для уменьшения времени завершения, нужно уменьшить это значение, например до 1000, что эквивалентно 1 секунде. Однако, помните, что слишком значительное уменьшение значения этого ключа не позволит системе корректно завершить запущенные сервисы, что может сказаться на стабильности загрузки. Во время завершения работы, система уведомляет все сервисы и дает каждому сервису время на корректное закрытие. По истечении этого времени система уничтожает сервис. При этом некоторые параметры настройки сервиса могут быть не сохранены. Поэтому, если при уменьшении значения система становится нестабильной, рекомендуется попробовать увеличить это значение до тех пор, пока система не будет полностью стабильной.


Windows Installer

Контроль над Windows Installer

Майкрософт разработала новый формат для установки программ - Windows Installer (msi-файлы). Существует возможность контроля над этим форматом. Создайте новый параметр DisableMSI типа DWORD в разделе

HKLM\Software\Policies\Microsoft\Windows\Installer
и присвойте ему следующие значения
  • 0 - по умолчанию
  • 1 - только адмистраторы системы могут запустить Windows Installer
  • 2 - запрет на запуск Windows Installer

Запрет на запуск msi-файлов со сменных носителей

Можно запретить запуск msi-файлов со сменных носителей (CD-ROM, флоппи-диск, DVD и т.д.) при помощи параметра типа DWORD DisableMedia в разделе

HKCU\Software\Policies\Microsoft\Windows\Installer


Windows Script Host

Windows Script Host (WSH)

Существуют несколько параметров, позволяющих настроить Windows Script Host. Данные параметры находятся в разделе

HKLM\Software\Microsoft\Windows Script Host\Settings

Строковый параметр Enabled равный "0" отключает работу скриптов WSH (значение "1" включает обратно)

Строковый параметр DisplayLogo равный "0" отключает показ версии WSH и копирайт компании Майкрософт при работе скрипта в окне сеанса MS-DOS


Запрет сохранения паролей в Dial-Up-соединениях

По умолчанию, в Dial-Up-соединениях введенный пароль сохраняется после успешного соединения, если задействована опция "Сохранять имя пользователя и пароль", расположенная на диалоговом окне для Dial-Up. Это достаточно удобно для многих пользователей, но если вы занимаетесь проблемой безопасности системы, то можете запретить сохранение этих паролей. В разделе

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\Parameters
создайте параметр типа DWORD DisableSavePassword со значением 1, который запрещает сохранение паролей в Dial-Up-соединениях. В этом случае опция "Сохранять имя пользователя и пароль" становится недоступной, а сохраненные пароли пропадают.


Remote Desktop Connection

Удаление имен машин

Если вы активно пользуетесь функцией Remote Desktop Connection, то в диалоговом окне Remote Desktop Connection | Computer сохраняются имена всех машин, к которым вы когда-либо подключались. Можно очистить данный список. Откройте раздел

HKCU\Software\Microsoft\Terminal Server Client\Default
В данном разделе вы увидите несколько параметров с именами типа MRU0, MRU1 и так далее. Удалите ненужные имена, и в окне Remote Desktop Connection вы их больше не увидите


Сохраняем Интернет соединение при переключении между пользователями

По умолчанию при переключении между пользователями Windows сбрасывает dial-up и некоторые виды xDSL соединений. Можно изменить это поведение следующим образом. Создайте в разделе

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon
строковый параметр KeepRASConnections и присвойте ему значение 1. Если вы хотите, чтобы соединения сбрасывались, то используйте значение 0 или удалите этот параметр.


Включение ограничения на количество полуоткрытых соединений

Microsoft официально подтвердила в своей статье в базе знаний, что лимит на количество одновременных полуоткрытых подключений в Windows Server 2008 SP2 и Windows Vista SP2 снят (How to enable the half-open TCP connections limit in Windows Vista with Service Pack 2 and in Windows Server 2008 with Service Pack 2), но его можно включить.

По умолчанию, ограничение на количество полуоткрытых соединений отключено в Vista SP2. Можно включить данное ограничение снова (лимит равен 10 соединениям).

В разделе HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters присвойте параметру EnableConnectionRateLimiting значение 1, чтобы включить ограничение.

Примечание: В Windows Server 2008 и Windows Vista SP1 имеется ограничение на 10 полуоткрытых соединений, которое нельзя снять. Ограничение было создано для борьбы с вирусами, пытаясь замедлить их распростарнение. Но, вирусы научились снимать это ограничение, поэтому огранечние перестало быть эффективным.


Регулятор громкости

Если вы хотите, чтобы регулятор громкости запускался в компактном виде по умолчанию, то в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Applets\Volume Control\Options
присвойте параметру типа DWORD Style значение 00000020. Для обычного состояния используется значение 00000200.


Настройка архивации данных

По умолчанию инструмент архивации данных Windows уведомляет пользователей о необходимости своей настройки. Уведомления могут появиться в Центре поддержки, если инструмент архивации данных Windows не был настроен в течение семи дней, или когда пользователь подключает внешний жесткий диск.

Если включать инструмент архивации данных Windows не планируется, и вместо него пользователям будет предложено решение для архивации стороннего разработчика, уведомления инструмента архивации данных Windows следует отключить.

Это можно сделать при помощи реестра. Создайте вручную раздел HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsBackup и создайте в нем параметр DWORD DisableMonitoring со значением 1. Если значение параметра равно 0 или если этот раздел отсутствует, инструмент архивации данных Windows будет выводить для пользователя уведомления о необходимости своей настройки.

Также этой настройке посвящена статья в Technet - Настройка архивации данных


Диалоговое окно при подключении фотоаппарата

Диалоговое окно при подключении фотоаппарата (Windows XP)

При подключении к компьютеру цифрового фотоаппарата появляется диалоговое окно с программами, которыми можно открыть и редактировать изображения. Если программ соответствующего типа устанавливалось много, то список может быть очень большим. Чтобы убрать из списка лишние программы (мусор), то зайдите в раздел

HKLM\SYSTEM\CurrentControlSet\Control\StillImage\Events\STIProxyEvent
и почистите ненужные программы. После этого необходимо перезагрузиться.


Программа справки Windows (WinHlp32.exe)

Программа справки Windows (WinHlp32.exe) - это программа справки, которая была включена в операционную систему Microsoft Windows начиная с версии Microsoft Windows 3.1. WinHlp32.exe требуется для пользователей, желающих просматривать 32-битные файлы справки с расширением HLP. Технология WinHlp32.exe официально считается устаревшей, начиная с выпуска Windows Vista. Пользователям, которым необходимо просматривать 32-битные файлы с расширением HLP в операционной системе Windows Vista или будущих версиях операционных систем Windows, нужно загрузить программу WinHlp32.exe с веб-узла центра загрузки корпорации Майкрософт и установить на свои компьютеры.

Разрешение макросов

Чтобы включить макросы в файлах HLP, установите значение параметра типа DWORD AllowProgrammaticMacros в разделе HKLM\Software\Microsoft\WinHelp равным 1. Если значение параметра будет равно 0 или значение параметра не установлено, то макросы будут отключены.

Получение доступа к файлам HLP, хранящимся в интрасети

Чтобы разблокировать доступ к файлам HLP, хранящимся на узлах интрасети, необходимо в разделе HKLM\SOFTWARE\Microsoft\WinHelp установить значение параметра типа DWORD AllowIntranetAccess равным 1. Если значение AllowIntranetAccess установлено в 0 или не установлено, то файлы HLP, хранящиеся на узлах интрасети, недоступны.

Более подробное описание вы можете прочитать в статье Базы Знаний 917607.


Избранное в реестре

В реестре есть команда меню Избранное, где хранятся пути к наиболее посещаемым разделам реестра. Если вы активно пользуетесь Избранным и там скопилось слишком много записей, то имеет смысл делать бэкап, чтобы не потерять данные.

Все элементы Избранного хранятся в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Applets\Regedit\Favorites. Откройте редактор реестра, перейдите в указанный раздел. Щелкните правой кнопкой мыши на разделе Favorites и выберите команду Экспортировать для сохранения записей в reg-файл.

Чтобы восстановить сохраненные данные или перенести их на другй компьютер, скопируйте reg-файл на другой компьютер, щелкните правой кнопкой мыши на файле и выберите команду Слияние.


Internet Explorer

Internet Explorer: Общее

Как настроить несколько рядов избранных сайтов в IE9

При создании новой вкладки (about:Tabs) в IE9 отображается два ряда сайтов. Вы можете изменить данное поведение, если в разделе HKCU\Software\Microsoft\Internet Explorer\TabbedBrowsing\NewTabPage укажете новое значение для параметра DWORD NumRows, которое отвечает за количество рядов. Чтобы изменения вступили в силу, необходимо перезапустить браузер.

Во весь экран

Чтобы включить режим Во весь экран, нужно нажать клавишу F11. Если вы хотите, чтобы IE9 запускался в таком режиме по умолчанию, то в разделе HKCU\Software\Microsoft\Internet Explorer\Main присвойте параметру Fullscreen значение Yes. Для переключения в обычный режим вы можете по прежнему использовать клавишу F11.

Internet Explorer (без настроек)

Если вы запускаете Internet Explorer 8 в режиме Без настроек (Пуск→Все программы→Стандартные→Служебные→Internet Explorer (без настроек), то браузер открывает специальную страницу about:NoAdd-ons, на которой выводится информация, что все надстройки отключены. При помощи реестра можно изменить данную страницу. В разделе HKLM\SOFTWARE\Microsoft\Internet Explorer\Main найдите параметр Extensions Off Page, который содержит значение about:NoAdd-ons. Вы можете задать свою домашнюю страницу, например, http://user.alexanderklimov.ru или пустую страницу - about:blank.

Масштабирование страниц

Начиная с IE7, в браузере есть возможность масштабирования страниц при помощи Ctrl+колесико мыши (или Ctrl + и Ctrl -) или при помощи лупы в строке состояния. Можно отключить масштабирование страниц, если в разделе HKCU\Software\Microsoft\Internet Explorer\Zoom создать DWORD-параметр ZoomDisabled со значением 1.

Политика: Конфигурация компьютера (Конфигурация пользователя) → Административные шаблоны → Компоненты Windows → Internet Explorer → Отключить функцию масштабирования страниц

Блокировка окна выбора браузеров

В европейских версиях Windows появилось окно выбора браузера, где в случайном порядке выводятся ссылки на несколько популярных браузеров. В корпоративной среде такой окно является лишним, и администраторы могут отключать данное окно выбора, если в разделе HKLM\Software\BrowserChoice параметру DWORD Enable присвоят значение 0 (по умолчанию стоит 1 - показывать окно выбора).

Версия Internet Explorer

Начиная с Internet Explorer 4.0, номер версии браузера можно найти в разделе HKLM\Software\Microsoft\Internet Explorer в строковом параметре Version

Общие настройки IE7/IE8

Параметры браузера IE7 находятся в ветках HKCU\Software\Microsoft\Internet Explorer\TabbedBrowsing. Все параметры имеют тип DWORD

  • Enabled - Позволяет режим закладок (многооконный режим): 0 = Выключен/1 = Включен
  • WarnOnClose - Оповещает пользователя при попытке закрытия браузера, что все вкладки также будут закрыты: 0 = Не оповещать/1 = Оповещать
  • OpenInForeground - Определяет, всегда ли осуществлять переход на закладку при ее создании, или нет: 0 = Отключено/1 = Включено
  • QuickTabsThreshold - Определяет, будет ли доступна функция просмотра эскизов страниц (Ctrl + Q): 0 = Отключено/2 = Включено
  • OpenAllHomePages - Если у вас есть несколько стартовых страниц, каждая из которых открывается в новой закладке при запуске браузера, определяет, позволить ли загрузку остальных станиц или только первую: 0 = Открывается только первая страница/1 = Открываются все страницы
  • OpenAdjacent - Определяет, будет ли создаваться новая страница следом за текущей закладкой: 0 = Отключено/1 = Включено
  • UseHomePageForNewTab - Позволяет администратору установить страницу по умолчанию для вновь создаваемых закладок: 0 = Пустая страница/1 = Домашняя страница
  • PopupsUseNewWindow - Определяет, что IE должен делать при встрече всплывающих окон: 0 = Позволить IE решать/1 = Открыть в новом окне браузера/2 = Открыть на новой закладке
  • ShortcutBehavior - Определяет, как IE должен осуществлять открытие URL адресов из других приложений: 0 = В новом окне/1 = На новой закладке в текущем окне браузера/2 = Текущая закладка/окно

Меню

Начиная с IE7, в браузере по умолчанию не выводится строка меню. Если вы хотите, чтобы строка меню была в браузере постоянно на самом верху, то в разделе

HKCU\Software\Microsoft\Internet Explorer\Toolbar\WebBrowser
создайте параметр типа DWORD ITBar7Position со значением 1. Перезапустите браузер, чтобы изменения вступили в силу.

В IE8 строка меню, если ее включить в настройках панели инструментов, располагается между полем для ввода адресов и линейкой табов. Кому-то подобная схема расположения элементов может показаться неудобной и захочется передвинуть строку меню на привычную позицию, то есть поместить ее аккурат под заголовком окна браузера. Стандартными средствами переместить строку меню не удастся. Для этого воспользуйтесь параметром, о котором говорилось выше.

Политика: Конфигурация компьютера (Конфигурация пользователя) → Административные шаблоны → Компоненты Windows → Internet Explorer → Перемещение строки меню выше панели навигации

Исключение IE8 из службы Windows Update

Если необходимо заблокировать автоматическое развертывание программы через службу Windows Update, то в разделе HKLM\SOFTWARE\Microsoft\Internet Explorer\Setup\8.0 создайте параметр DoNotAllowIE80

Настройка служб поиска в IE8

В IE8 появилась обновленная панель мгновенного поиска, возможности которой можно расширять путем подключения к браузеру дополнительных сетевых сервисов. В окне менеджера надстроек программы можно изменять порядок отображения служб поиска и отключать их, но нельзя изменять закрепленные за ними URL-адреса. Для корректировки адресов нужно в разделе HKCU\Software\Microsoft\Internet Explorer\SearchScopes изменить соответствующие параметры. Таким образом, к примеру, можно научить надстройку Wikipedia осуществлять поиск по русскоязычному разделу "Википедии" (по умолчанию она ищет энциклопедические материалы на английском языке).

Программа просмотра HTML-кода (IE8)

Чтобы сменить программу просмотра HTML-кода в IE8, нужно в разделе HKLM\SOFTWARE\Microsoft\Internet Explorer создать подраздел View Source Editor, в котором создать еще один подраздел Editor Name и в параметре по умолчанию прописать строчку Notepad.exe.

Если вы хотите использовать другой редактор, то пропишите полный путь к исполняемому файлу вашего редактора.

Этого же результата можно добиться, не прибегая к помощи реестра. Смотри совет Программа просмотра HTML-кода (IE8) в справочнике Народные советы.Windows

Здесь приводятся настройки, которые доступны из меню Сервис-Свойства обозревателя-Дополнительно. Обычным пользователям рекомендуется менять значения именно через это окно. Данные примеры предназначены только для программистов. Все параметры вносятся в раздел

HKCU\Software\Microsoft\Internet Explorer\Main
Включить автоматическую подгонку размеров изображения | AutoImageResize ("yes"/"no")
Автоматически проверять обновления Internet Explorer | NoUpdateCheck (dword)
Включить личное меню избранного | FavIntelliMenus ("yes"/"no")
Воспроизводить звуки на веб-страницах | Play_Background_Sounds ("yes"/"no")
Использовать одно и то же окно для загрузки ярлыков | AllowWindowReuse (dword)

Настройки мастера подключения к Интернету

HKCU\Software\Microsoft\Internet Connection Wizard

Программа для просмотра HTML-кода

В разделе HKCU\Software\Microsoft\Internet Explorer\Default HTML Editor хранится информация о программе для просмотра и редактирования HTML-кода

Страницы для about

В IE существуют несколько страниц, которые можно открыть через команду about

  • about:blank - отображает пустую страницу
  • about:SecurityRisk
  • about:NoAdd-ons
  • about:Tabs

Вы сами можете создать такой адрес, либо изменить страницу, на которую ссылается стандартный адрес

Все адреса, которые начинаются со слова about:, хранятся в параметрах строкового типа раздела HKLM\SOFTWARE\Microsoft\Internet Explorer\AboutURLs. Значения этих параметров определяют страницы, который эти адреса отображают. Названия же параметров соответствуют строке, которую нужно добавить к строке about: для формирования окончательного адреса. Встроенные команды как правило зашиты в ресурсы библиотек.


Окно приветствия и первоначальных настроек IE

Окно приветствия и первоначальных настроек IE9/IE8

Internet Explorer 9

Не показывать страницу знакомства с браузером

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
"IE9TourNoShow"=dword:00000001

Internet Explorer 8

При первом запуске Internet Explorer 8 пользователь видит окно приветствия и настроек поиска и акселераторов. После настройки открывается новая вкладка, в которой загружается специальная страница с сайта Microsoft. Существует несколько способов отключить эти операции.

Способ первый (для каждого пользователя)

Данный способ действует на отдельного пользователя, поэтому в случае необходимости нужно проделать описываемые операции с каждым пользователем.

В разделе HKCU\Software\Microsoft\Internet Explorer\Main необходимо создать несколько ключей:

  • IE8RunOnceLastShown со значением 1 (DWORD)
  • IE8RunOncePerInstallCompleted со значением 1 (DWORD)
  • IE8RunOnceCompletionTime (empty) (BINARY)
  • IE8TourShown со значением 1 (DWORD)
  • IE8TourShownTime (empty) (BINARY)
  • IE8RunOnceLastShown_TIMESTAMP (empty) (BINARY)

Способ второй

В разделе HKCU\Software\Policies\Microsoft\Internet Explorer\Main создать параметр типа DWORD DisableFirstRunCustomize. Он может принимать следующие значения: 1 (будет загружена домашняя страница), 2 (будет загружена страница приветствия).

Политика: Конфигурация компьютера (Конфигурация пользователя) → Административные шаблоны → Компоненты Windows → Internet Explorer → Запретить выполнение параметров "Настроить первый запуск"


Меню в Internet Explorer

Меню

Показать меню в Internet Explorer

По умолчанию, в Internet Explorer 8/9 строка меню не выводится, чтобы увеличить полезное пространство на экране. Если вы предпочитаете, чтоб меню всегда выводилось на экран, то добавьте в разделе HKCU\Software\Policies\Microsoft\Internet Explorer\Main параметр DWORD AlwaysShowMenus

Политика: Конфигурация компьютера (Конфигурация пользователя) → Административные шаблоны → Компоненты Windows → Internet Explorer → Включить панель меню по умолчанию

Удаление пункта меню Файл из Internet Explorer

Для удаления пункта меню Файл из Internet Explorer используйте параметр DWORD NoFileMenu со значением 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Также будет удален этот пункт из окна Проводника, Мои документы и других мест, использующих оболочку Windows

Запрет на создание нового окна

При выборе Файл-Новое окно (или Ctrl-N) создается новое окно. Для запрета такой возможности используйте параметр типа DWORD NoFileNew со значением равным 1 в разделе HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions

Запрет на расширенное меню для пункта Создать

При выборе Файл-Создать-Окно появляется расширенное меню, включающее в себя команды Сообщение, Объявление, Контакт, Вызов через Интернет.

Чтобы убрать это расширенное меню, используйте параметр типа DWORD NoExpandedNewMenu со значением равным 1 в разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Открыть (Internet Explorer 4 и выше)

Если вы хотите, чтобы пользователь не мог открыть страничку (через Файл-Открыть, Ctrl-O, или Ctrl-L), то создайте следующий параметр типа DWORD NoFileOpen со значением, равным 1 в разделе HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions

Править в ... (Устарело)

Internet Explorer делает попытку определить программу, используемую вами для создания и редактирования html-документа. В пункте меню Файл у вас может присутствовать строка Править в Блокнот (или другой текстовый редактор). Чтобы убрать данную команду, присвойте строковому параметру CheckDocumentForProgID значение no в разделе

HKCU\Software\Microsoft\Internet Explorer\Main

Сохранить как

Для удаления пункта Сохранить как ... из меню Файл используйте параметр типа DWORD NoBrowserSaveAs со значением, равным 1 в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions

Печать и Предварительный просмотр

Чтобы удалить пункты Печать и Предварительный просмотр, то присвойте параметру типа DWORD NoPrinting значение, равное 1 в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions

Импорт и экспорт

Если вы хотите запретить пользователю воспользоваться пунктом Импорт и экспорт, то создайте параметр типа DWORD DisableImportExportFavorites со значением, равным 1 в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer
В этом случае, при попытке нажать на кнопку Готово, будет выводиться соответствующее предупреждение.

Закрыть (Internet Explorer 4 и выше)

Если вы хотите, чтобы пользователь не мог закрыть страничку (через Файл-Закрыть, Alt-F4, системное меню или нажимая крестик в верхнем углу), то создайте параметр типа DWORD NoBrowserClose со значением, равным 1 в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions


Вид

Меню Вид

Просмотр HTML-кода

Для блокировки пункта меню Просмотр HTML-кода используйте параметр типа DWORD NoViewSource со значением равным 1 в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions

Выбор текстового редактора для просмотра HTML-кода

По умолчанию для просмотра HTML-кода используется стандартный Блокнот. Вы можете использовать ваш любимый текстовый редактор, используя в разделе

HKLM\SOFTWARE\Microsoft\Internet Explorer\View Source Editor\Editor Name
строковый параметр (По умолчанию), в который нужно прописать полный путь к exe-файлу текстового редактора

Во весь экран

При выборе Вид-Во весь экран (или F11) Internet Explorer переходит в так называемый режим киоска. Для запрета такой возможности используйте параметр типа DWORD NoTheaterMode со значением равным 1 в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions


Избранное

Удаление пункта меню в IE

Чтобы удалить пункт меню Избранное в Internet Explorer, создайте параметр типа DWORD NoFavorites со значением 1 в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions
Кнопка Избранное также будет недоступна на панели инструментов

Открывать в новом окне

Вы можете сделать так, чтобы ссылка в Избранном открывалась в новом окне. Для этого в разделе

HKCR\InternetShortcut\shell
создайте новый раздел Открыть в новом окне, в котором создайте подраздел command. В созданном подразделе измените значение по умолчанию на rundll32.exe shdocvw.dll,OpenURL %1. Теперь в контекстном меню ссылки в Избранном появится новая команда, позволяющая открывать ссылку в новом окне.


Сервис

Повторное открытие последнего сеанса просмотра (Internet Explorer 8)

Если вы хотите заблокировать команду меню Повторное открытие последнего сеанса просмотра, то в разделе HKCU\Software\Policies\Microsoft\Internet Explorer\Recovery (раздел Recovery по умолчанию не существует) создайте параметр DWORD NoReopenLastSession со значением 1.

Политика: Конфигурация компьютера (Конфигурация пользователя) → Административные шаблоны → Компоненты Windows → Internet Explorer → Отключить параметр Повторное открытие последнего сеанса просмотра

Свойства обозревателя

Чтобы запретить доступ к свойствам Internet Explorer (Сервис-Свойства обозревателя), используйте параметр типа DWORD NoBrowserOptions со значением 1 в разделе HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions (Для отмены запрета используйте значение 0)

Настройки параметров свойств обозревателя смотрите в разделе Свойства обозревателя категории Панель управления.


Справка

Все настройки делаются в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer
при помощи DWORD-параметров

Блокировка пункта Справка

Для блокировки пункта Справка создайте параметр NoHelpMenu со значением, равным 1

Для пользователей Netscape

Для скрытия подпункта Для пользователей Netscape в меню Справка создайте параметр NoHelpItemNetscapeHelp со значением, равным 1

Отзывы и предложения

Для скрытия подпункта Отзывы и предложения в меню Справка создайте параметр NoHelpItemSendFeedback со значением, равным 1

Полезный совет

Для скрытия подпункта Полезный совет в меню Справка создайте параметр NoHelpItemTipOfTheDay со значением, равным 1


Контекстное меню в Internet Explorer

Лишние команды в контекстном меню

Если контекстное меню вашего браузера, выпадающего, если нажать правую кнопку мыши на ссылке, содержит слишком много лишних команд, то найдите раздел

HKCU\SOFTWARE\Microsoft\Internet Explorer\MenuExt.
Данный раздел содержит подразделы, которые вы можете удалять, изменять, редактировать

Запрет на контекстное меню

Чтобы запретить вызов контекстного меню правой кнопкой мыши, используйте параметр типа DWORD NoBrowserContextMenu со значением 1 в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions

Открыть в новом окне

Для блокировки возможности открытия страницы в новом окне, когда вы нажимаете правой кнопкой на ссылке и выбираете пункт Открыть в новом окне используйте параметр типа DWORD NoOpeninNewWnd со значением 1 в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions


Панель информации

При открытии веб-документов на локальном компьютере Internet Explorer выводит специальное окно Панель информации, уточняющее, как мы хотим пользоваться информационной панелью, отвечающей, например, за блокировку всплывающих окон. Если вы поставите галочку в соответствующем флажке, то это окно появляться не будет. Но если вы хотите вернуть эту панель, или, наоборот, чтобы это окно не появлялсь при создании собственного инсталяционного диска, то делаем следующее.

В разделе

HKCU\Software\Microsoft\Internet Explorer\InformationBar
меняем параметр типа DWORD FirstTime. Значение 0 отключает диалог, 1 - включает.


Настройки блокировщика всплывающих окон

Для переноса настроек блокировщика всплывающих окон IE с одного компа на другой достаточно экспортировать ветвь реестра

HKCU\Software\Microsoft\Internet Explorer\New Windows
Именно здесь хранятся настройки для борьбы с рекламой.

Многие сайты взяли привычку при своей загрузке отображать сразу несколько всплывающих окна (в основном в рекламных целях). Начиная с Windows XP SP2, Internet Explorer стал поддерживать возможность блокирования всплывающих окон.

Включить или отключить механизм блокирования всплывающих окон можно при помощи флажка ВКЛЮЧИТЬ БЛОКИРОВАНИЕ ВСПЛЫВАЮЩИХ ОКОН. Данный флажок расположен на вкладке КОНФИДЕНЦИАЛЬНОСТЬ диалога СВОЙСТВА: ИНТЕРНЕТ. После установки данного флажка параметру PopupMgr присваивается значение 1.

Основным способом настройки всплывающих окон является диалог ПАРАМЕТРЫ БЛОКИРОВАНИЯ ВСПЛЫВАЮЩИХ ОКОН, который вызывается после нажатия на кнопку ПАРАМЕТРЫ, расположенную на вкладке КОНФИДЕНЦИАЛЬНОСТЬ диалога СВОЙСТВА: ИНТЕРНЕТ.

Сведения о работе механизма блокирования всплывающих окон хранятся в разделе HKCU\Software\Microsoft\Internet Explorer\New Windows (все параметры с типом REG_DWORD) .

  • AllowHTTPS - Если значение данного параметра равно 1, тогда отображение всплывающих окон, при работе с защищенными сайтами по протоколу SSL, будет разрешено.
  • BlockUserInit - Значение данного параметра определяет уровень блокирования всплывающих окон. Если значение параметра равно 1, тогда установлен высокий уровень блокирования. Данный параметр отвечает за возможность отключения блокировки всплывающих окон при помощи клавиши CTRL.
  • BlockControls - Если значение параметра равно 1, тогда установлен высокий уровень блокирования. При этом все всплывающие окна будут заблокированы.
  • PlaySound - Установка флажка ПОДАВАТЬ ЗВУКОВОЙ СИГНАЛ, ЕСЛИ ВСПЛЫВАЮЩЕЕ ОКНО ЗАБЛОКИРОВАНО присваивает данному параметру значение 1. Значение 0 отключает звук.
  • PopupMgr - Включает или отключает работу механизма блокирования всплывающих окон.
  • UseHooks - Значение данного параметра при наивысшем уровне блокировки равно 0.
  • UseSecBand - Установка флажка ОТОБРАЖАТЬ СООБЩЕНИЕ, ЕСЛИ ВСПЛЫВАЮЩЕЕ ОКНО ЗАБЛОКИРОВАНО присваивает данному параметру значение 1.
  • UseTimerMethod - При значении 1 включает режим, при котором специальный таймер выявляет всплывающие окна, инициализированные пользователем, и разрешает их.
  • UserInitTimeout - если связанный параметр UseTimerMethod равен 1, то здесь можно указать число миллисекунд между действием пользователя и появлением всплывающего окна.

Также с помощью данного диалога можно указать сайты-исключения, всплывающие окна на которых блокироваться не будут. Все эти сайты заносятся в параметры REG_BINARY типа подраздела Allow данной ветви реестра. Названия этих параметров определяют сайт-исключение, а значения параметров равны нулю.

Также настройки блокирования всплывающих окон хранятся в параметрах REG_DWORD раздела HKLM\SOFTWARE\Policies\Microsoft\Internet Explorer\New Windows.

ListBox_Support_Allow - Если значение данного параметра равно 1, тогда сайтам, названия которых определены в параметрах строкового типа дочернего подраздела Allow данной ветви реестра будет разрешено отображать всплывающие окна.

Сообщение при первом запуске

При первых запусках Internet Explorer непременно появляется запрос: "Did you notice the Information Bar?", уточняющий, как мы хотим пользоваться информационной панелью, отвечающей, например, за блокировку всплывающих окон. Можно отключить это сообщение (для любителей создавать собственный дистрибутив). Для этого нужно изменить параметр DWORD FirstTime в разделе HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\InformationBar. Значение 0 отключает диалог, 1 - включает.


Поиск

Строка поиска

Чтобы скрыть строку поиска из IE7/IE8, в разделе HKCU\Software\Policies\Microsoft\Internet Explorer\InfoDelivery\Restrictions создайте параметр DWORD NoSearchBox со значением 1. Перезапустите браузер, чтобы изменения вступили в силу.


Запрет на загрузку файлов

Чтобы запретить пользователю загружать файлы из интернета, создайте параметр типа DWORD NoSelectDownloadDir со значением 1 в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions
При попытке нажать кнопку Сохранить в диалоговом окне загрузки файлов будет выводиться соответствующее предупреждение.

Блокировка загрузки файлов в IE (Другой способ)

Можно заблокировать в браузере опцию загрузки файлов следующим способом. В разделе HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\3 измените значение DWORD-параметра 1803 с 0 на 3.

После произведенных изменений Internet Explorer будет препятствовать любые попытки пользователя скачать какой-нибудь файл из интернета.


Сохранение странички

Сохранение странички (Internet Explorer 5 и выше)

По умолчанию Internet Explorer позволяет сохранять страничку полностью - с картинками, скриптами, файлами. Чтобы запретить такую возможность, создайте следующий параметр типа DWORD NoBrowserSaveWebComplete со значением, равным 1 в разделе:

HKCU\Software\Policies\Microsoft\Internet Explorer\Infodelivery\Restrictions
Теперь можно будет сохранять страницу только как Веб-страница, только HTML или Текстовый файл


Доступ к сайтам

Чтобы убрать ограничение на доступ к сайтам в IE достаточно удалить все параметры из раздела

HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Ratings


Безопасность

Отключение предупреждения (Windows XP SP2)

После установки SP2 Internet Exprlorer стал выводит предупреждающие сообщения, при просмотре html-страниц на локальном компьютере, содержащих скрипты и элементы ActiveX. Но если вы сами занимаетесь созданием подобных страниц, то подобное поведение может вам мешать. Чтобы отключить подобный режим, добавьте в раздел

HKLM\SOFTWARE\Microsoft\Internet Explorer\main\FeatureControl\Feature_LocalMachine_Lockdown
параметр типа DWORD IExplorer со значением 0


Ошибки при загрузке страницы

По умолчанию IE при возникновении ошибок 4** показывает страницы с подробным описанием соответствующей ошибки и дальнейшими рекомендациями. Чтобы запретить показ таких страничек, нужно изменить значение строкового параметра Friendly http errors со значением no в разделе

HKCU\Software\Microsoft\Internet Explorer\Main

В этом случае будут выводится пустые странички


Internet Explorer не может отобразить эту веб-страницу

При просмотре веб-сайта с помощью Internet Explorer 8 появляется сообщение об ошибке следующего вида:
Internet Explorer не может отобразить эту веб-страницу.

Одной из причин может быть использование сайтом двух протоколов IPv4 и IPv6.

Можно решить эту проблему путем правки реестра, увеличив число соединений с сервером.

Изменения вносятся в следующих разделах

Для x86-компьютеров:

HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings

Для x64-компьютеров (32-битный IE)

HKCU\Software\Wow6432Node\Microsoft\Windows\CurrentVersion\Internet Settings

Для x64-компьютеров (64-битный IE)

HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings

Необходимо создать в указанных разделах параметр DWORD ConnectRetries и присвоить ему значение 10.

После внесения изменений необходимо перезагрузить Internet Explorer

Источник: An error occurs when using Windows Internet Explorer 8 or Windows Internet Explorer 7 to view a Web site: “Internet Explorer cannot display the webpage”. (анг.)

Также рекомендуется почитать статью, где описываются другие способы решения проблемы - Сообщение об ошибке в браузере Internet Explorer: "Internet Explorer не может отобразить эту веб-страницу"


Работа с серверами

Время ожидания ответа сервера (Internet Explorer 4.0 SP1 и выше)

При работе в интернете иногда приходится обращаться к весьма удаленным или очень медленным сайтам, в связи с чем у Internet Explorer не всегда хватает терпения дождаться ответа от сервера, и он выдает такие сообщения: "Microsoft Internet Explorer error 10060 connection timed out", "Internet Explorer cannot open the internet site. The operation timed out", "The page cannot be displayed. Cannot find server or DNS Error". В этой ситуации можно попробовать увеличить время ожидания ответа сервера, которое по умолчанию составляет пять минут, установив, например, для восьми минут в разделе:

HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
параметр типа DWORD ReceiveTimeout, равным 00075300 (480000). Для того, чтобы установить другое время, надо количество секунд умножить на 1000, то есть для нашего примера с 8 минутами мы получаем: 60 х 8 х 1000 = 480 000.

Время сохранения соединения

После установки соединения можно настроить время сохранения соединения с сервером. Для этого в разделе:

HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
установить параметр типа DWORD KeepAliveTimeout с новым значением в миллисекундах (по умолчанию 0x0001D4C0 (120000))

Увеличение числа сеансов загрузки

По умолчанию в IE количество одновременных сеансов загрузки файлов с одного сервера ограничено двумя или четырьмя сеансами (в зависимости от конфигурации сервера). Чтобы увеличить количество одновременных подключений к серверам, необходимо внести изменения в два параметра типа DWORD MaxConnectionsPerServer и MaxConnectionsPer1_0Server в разделе HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings Например, чтобы установить 6 одновременных подключений, присвойте этим параметрам значение 6 (десятичное значение).


Замена заголовка и фона в Internet Explorer

Замена заголовка в Internet Explorer

Найдите или создайте строковый параметр Window Title в разделе HKCU\Software\Microsoft\Internet Explorer\Main\ Создайте в ней новую строку или измените существующую запись на вашу. Удалив раздел, вы восстановите строку заголовка по умолчанию

Замена фона в панели инструментов в Internet Explorer

Существует возможность установки своего фона для панели инструментов в Internet Explorer. Для этого в разделе

HKCU\SOFTWARE\Microsoft\Internet Explorer\Toolbar
создайте строковый параметр BackBitmap, значением которого будет полное имя BMP-файла с нужной картинкой - она и замостится мозаикой на панелях окон. Кстати, заодно замостится и панель инструментов Проводника.

Для замены фона только в Проводнике, не затрагивая Internet Explorer смотрите Замена фона в панели инструментов в Проводнике


Установка стартовой странички

Найдите или создайте следующий строковый параметр Start Page в разделе

HKCU\Software\Microsoft\Internet Explorer\Main\
Создайте новую строку или измените существующую запись на вашу.

Теперь, при запуске браузера будет загружаться указанная страница


F3

Клавиша F3 (Поиск)

Можно заблокировать клавишу F3 в Internet Explorer, которая запускает поиск в интернете. Создайте параметр типа DWORD NoFindFiles со значением 1 в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions


Кнопки на панели инструментов в Internet Explorer

Если панель инструментов вашего браузера содержит слишком много лишних кнопок, то найдите раздел: HKEY_LOCAL_MACHINE\ Software\ Microsoft\Internet Explorer\ Extensions. Данный раздел содержит подразделы, которые вы можете удалять, изменять, редактировать

Лишние кнопки могут быть невидимы, но присутствовать на панели инструментов. Чтобы просмотреть все существующие кнопки, нажмите правой кнопкой на панели инструментов и выберите команду Настройка


Кнопки Вперед и Назад

Чтобы заблокировать кнопки Вперед и Назад в Internet Explorer, создайте параметр типа DWORD NoNavButtons со значением 1 в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions


Строчки для комбобокса Адрес

При нажатии на треугольник в комбобоксе Адрес вываливается список вводимых вами адресов.

Вы можете отредактировать этот список (добавить, удалить, изменить). Войдите в раздел:

HKCU\Software\Microsoft\Internet Explorer\TypedURLs
Там присутствует список ваших адресов, начиная со строкового параметра url1. Добавляйте или удаляйте строки, но следите, чтобы параметры были упорядоченными. Иначе, если у вас будет url1, url2, url5, url6, то будут выводиться только первые два адреса

Примечание: Данный список будет появляться, если в комбобоксе находится веб-адрес. Если же там путь к файлу на локальном компьютере, то появится список, аналогичный списку Проводника


Панель инструментов изображений

Отключение Панели инструментов изображений

В Internet Explorer при наведении указателя мыши на рисунок, который требуется сохранить, в уголке рисунка появляется панель инструментов изображений.

Эта панель позволяет быстро осуществить разные операции: сохранить, печатать, послать по почте, открыть папку Мои рисунки

Для отключения данной панели инструментов изображений создайте ключ типа DWORD MyPics_Hoverbar в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer\PhotoSupport
со значением 1

Существует еще альтернативный вариант. Создайте строковый параметр Enable_MyPics_Hoverbar в разделе

HKCU\Software\Microsoft\Internet Explorer\main
и присвойте ему значение yes (включить) или no (выключить)

Размер картинки

Панель инструментов изображений появляется не для всех рисунков. Для использования панели инструментов размер рисунка должен быть не менее 130 x 130 пикселей. Если вы хотите изменить данное значение, то создайте параметр DWORD Image_Filter в разделе

HKCU\Software\Microsoft\Internet Explorer\main
и присвойте ему нужное значение

Смещение Панели относительно изображения

По умолчанию Панель инструментов изображений появляется смещенной на 10 пикселей от верхнего и левого сторон изображения. Для изменения этой настройки создайте параметр DWORD Offset в разделе

HKCU\Software\Microsoft\Internet Explorer\main
и присвойте ему нужное значение


Отмена кэширования пароля в IE

Отмена кэширования пароля (Internet Explorer 4 и выше)

По некоторым сведениям, эта настройка имеет ограниченное применение. Приведенная информация относится к Internet Explorer версии 4.01 с установленным 2-м пакетом обновлений, к 5 и 5.01 версиям Internet Explorer, работающему под Windows 95, 98, NT 4.0 и Internet Explorer 5.01 для Windows 98 Second Edition. Например, при проведении испытаний под Windows ME, Internet Explorer 5.5 проигнорировал эту настройку.

Чтобы отключить кэширование паролей, используйте параметр типа DWORD DisablePasswordCaching со значением 1 в разделе
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings. По умолчанию в Internet Explorer задействовано кэширование паролей.

Microsoft посвятила этой проблеме статью Q229940 в MSDN под названием "How to Disable Internet Explorer Password Caching".

Смотри также
Отмена кэширования пароля


Команда "Q" в адресной строке для получения статьи из Базы Знаний

Команда "Q" в адресной строке для получения статьи из Базы Знаний от Майкрософт

Данная настройка будет полезна разработчикам. Порой в различных публикациях встречаются ссылки на определенный идентификатор статьи Базы Знаний (Knowledge Base). Можно быстро получить доступ к этой статьи, напечатав Q nnnnnn, где nnnnnn - номер статьи.
Для этого откройте или создайте раздел
[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchUrl\Q и измените строковое значение по умолчанию на @="http://support.microsoft.com/default.aspx?scid=kb;en-us;%s"

Теперь вы можете запустить Internet Explorer, напечатать Q nnnnnn или Q Qnnnnnn и браузер сразу покажет нужную статью


Размеры окна

Если вас не устраивают размеры или позиция открываемого окна браузера, то удалите следующие параметры:

  • WINDOW_PLACEMENT в HKCU\Software\Microsoft\Internet Explorer\Main
  • OldWorkAreas и OldWorkAreaRects в HKCU\Software\Microsoft\Internet Explorer\Desktop


Почта Windows

Отключение стартовой заставки

При загрузке почтового клиента Почта Windows сначала показывается заставка программы. Чтобы отключить стартовую заставку, нужно в разделе HKCU\Software\Microsoft\Windows Mail добавить новый DWORD-параметр NoSplash, равный единице.


Windows Media Player

Изменение фонового изображения Библиотеки в Windows Media Player 12 (Windows 7)

В разделе HKCU\Software\Microsoft\MediaPlayer\Preferences установите для параметра LibraryBackgroundImage значения от 0 (изображение отсутствует) до 6 (значение по умолчанию).

Изменение заголовка в Windows Media Player

Для изменения заголовка в Windows Media Player откройте или создайте раздел

HKCU\Software\Policies\Microsoft\WindowsMediaPlayer
со строковым параметром TitleBar, содержащим ваш текст.

Сеть (Windows Media 8.0 и выше)

Чтобы скрыть вкладку Сеть (Сервис | Параметры), нужно установить значение типа DWORD параметра HideNetworkTab равным 1 в разделе

HKCU\Software\Policies\Microsoft\WindowsMediaPlayer

Автоматическое обновление (Windows Media 7.0 и выше)

Проигрыватель Windows Media периодически устанавливает связь через интернет для проверки существования новой версии программы (Сервис-Параметры-вкладка Проигрыватель-рамка Автоматическое обновление). Можно отключить данную возможность в Проигрыватель Windows Media, установив значение типа DWORD параметра DisableAutoUpdate равным 1 в разделе

HKLM\SOFTWARE\Policies\Microsoft\WindowsMediaPlayer
После установки данного значения рамка Автоматическое обновление будет заблокирована.

Очистка списка файлов

Иногда возникает необходимость корректировки либо полной очистки списка последних воспроизведенных проигрывателем файлов. Список файлов находится в разделе

HKCU\Software\Microsoft\MediaPlayer\Player\RecentFileList
который содержит строковые параметры File0, File1 и т.д, в которых прописаны пути к недавно воспроизведенным файлам. Удалите лишние записи или скорректируйте их.


Игры

Паук

Если вы хотите поправить статистику неудачных игр, то необходимо поправить следующие параметры в разделе

HKCU/Software/Microsoft/Spider
  • Losses_Difficult – количество проигранных игр в режиме – «Сложный»
  • Losses_Easy – количество проигранных игр в режиме – «Простой»
  • Losses_Medium – количество проигранных игр в режиме – «Средний»
  • Wins_Difficult– количество выигранных игр в режиме – «Сложный»
  • Wins_Easy – количество выигранных игр в режиме – «Простой»
  • Wins_Medium – количество выигранных игр в режиме – «Средний»
  • HighScore_Difficult – количество максимально набранных очков в режиме – «Сложный»
  • HighScore _Easy – количество максимально набранных очков в режиме – «Простой»
  • HighScore _Medium – количество максимально набранных очков в режиме – «Средний»
  • StreakWins_Difficult – количество подряд выигранных игр в режиме – «Сложный»
  • StreakWins_Easy – количество подряд выигранных игр в режиме – «Простой»
  • StreakWins_Medium – количество подряд выигранных игр в режиме – «Средний»

Измените, любое из этих значений десятичного параметра, на требуемое число. Например, думаю, что 10000 выигранных игр потрясут кого угодно.

Сапер

Если вы хотите поправить статистику неудачных игр, необходимо изменить следующие параметры в разделе

HKCU/Software/Microsoft/winmine
  • Time1 – время, за которое Вы выиграли данную игру в режиме «Новичок»
  • Time2 – время, за которое Вы выиграли данную игру в режиме «Специалист»
  • Time3 – время, за которое Вы выиграли данную игру в режиме «Профессионал»

Например, 3 секунды очень хороший результат, чтобы похвастаться перед своими друзьями.

Червы

Хотите стать шулером в карточной игре "Червы"?

Откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Applets\Hearts
и создайте строковый параметр ZB со значением 42, тогда после нажатия клавиш CTRL+SHIFT+ALT+F12 вы откроете карты противников!


Как в Office 2010 вернуть меню от Office 2007

В разделе HKCU\Software\Microsoft\Office\14.0\Common\Toolbars создаем параметр DWORD UseOutspace со значением 1, чтобы включить меню, как в Office 2007. Значение 0 или отсутствие параметра отключает это меню.


Excel

Увеличение количества отмен

В Microsoft Excel число отмен последнего действия ограничено по умолчанию до 16 раз. Чтобы увеличить число отмен, нужно присвоить параметру типа DWORD UndoHistory значение от 1 до 100 в разделе

HKCU\SOFTWARE\Microsoft\Office\11.0\Excel\Options

Здесь приведен пример для Excel 2003, для других версий ищите соответсвующие номера (9.0 - Excel 2000, 10.0 - Excel 2002)


Сворачивание Outlook в область уведомлений

Чтобы сворачивать Outlook не на панель задач, а в область уведомлений, нужно создать новый параметр типа DWORD MinToTray со значением 1 (0 - сворачивать на панель задач) в разделе

HKCU\Software\Microsoft\Office\10.0\Outlook\Preferences


Диалоговое окно открытия и сохранения файла для Office

Office 2000/XP имеет новое диалоговое окно "Открыть/Сохранить файл", аналогичное в Windows Me/2000/XP, которое можно изменить по Вашему желанию.

В левой части диалогового окна расположены пять папок. Но многих пользователей не устраивает этот список. Вы можете скрыть, поменять местами или изменить на те, которыми вы часто пользуетесь. Открываем раздел

HKCU\Software\Microsoft\Office\9.0\Common\OpenFind\Places\StandardPlaces
(для Office 2000, для Office XP используется раздел 10.0) Вложенные разделы и определяют стандартные ссылки (Журнал, Мои документы и пр.) диалогового окна открытия документов. Чтобы скрыть отображение ненужных элементов списка, создайте в соответствующем подразделе DWORD-параметр Show со значением "0" (не показывать).

Спрятав таким образом значки ненужных папок, можно приступать к созданию собственного списка папок. Для этого перейдите в раздел

HKCU\Software\Microsoft\Office\9.0\Common\OpenFind\Places\UserDefinedPlaces.
Создайте в нем новый раздел (его имя не имеет особого значения, но влияет на сортировку папок). В этом разделе создайте два строковых параметра - Nаmе и Path и присвойте им соответственно название и полный путь к папке. Если общее число отображаемых папок равно пяти, то проблем не будет. Если же нет, список может оказаться слишком мал или слишком велик для отображения с установленным по умолчанию размером значка. Чтобы избежать этого, создайте в разделе
HKCU\Software\Microsoft\Office\9.0\Common\OpenFind\Places
DWORD-параметр ItemSize и присвойте ему значение "0" для уменьшения высоты значков папок.

Смотри также
Диалоговое окно открытия и сохранения файла


Outlook

Перенос учетных записей

Чтобы перенести учетные записи электронной почты на другой компьютер, необходимо на вашем текущем компьютере скопировать данные из раздела HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\Outlook\9375CFF0413111d3B88A00104B2A6676.

Удобнее это сделать через команду:

reg export "HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\Outlook\9375CFF0413111d3B88A00104B2A6676" c:\test.reg

Вместо c:\test.reg можете указать собственный путь к файлу. После этого сведения об учетных записях будут скопированы в указанный вами файл.

Открытие заблокированных вложенных файлов в Outlook

В последних версиях приложения Outlook заблокирована возможность работы с прикрепленными файлами, пришедшими по электронной почте. Вот список расширений, которые Outlook считает потенциально опасными: .ade, .adp, .app, .asp, .bas, .bat, .cer, .chm, .cmd, .com, .cpl, .crt, .csh, .exe, .fxp, .hlp, .hta, .inf, .ins, .isp, .its, .js, .jse, .ksh, .lnk, .mad, .maf, .mag, .mam, .maq, .mar, .mas, .mat, .mau, .mav, .maw, .mda, .mdb, .mde, .mdt, .mdw, .mdz, .msc, .msi, .msp, .mst, .ops, .pcd, .pif, .prf, .prg, .pst, .reg, .scf, .scr, .sct, .shb, .shs, .tmp, .url, .vb, .vbe, .vbs, .vsmacros, .vss, .vst, .vsw, .ws, .wsc, .wsf, .wsh.

Существует возможность изменения списка этих расширений. В разделе

HKCU\Software\Microsoft\Office\11.0\Outlook\Security
создаем строковый параметр Level1Remove и прописываем расширения файлов, для которых необходимо отменить блокировку в следующем формате: .exe; .com; .reg и так далее.

Пример приведен для Outlook 2003. Для Outlook 2002 используйте 10.0, для Outlook 2000 используйте 9.0


Ошибки в Office

Ошибки в Office (Office XP)

При возникновении сбоя в Office XP утилита DW.exe пытается отправить отчет о нем в Microsoft. Если вы не хотите заниматься ловлей багов, то можете отключить эту функцию. Существует несколько различных параметров, находящихся в разделе

HKCU\Software\Policies\Microsoft\Office\10.0\Common
  • Параметр типа DWORD DWNeverUpload со значением 1 отключает отправку данных и не выводит соответствущее сообщение
  • Параметр типа DWORD DWNoExternalURL со значением 1 отключает соединение с сервером Майкрософт и не выводит соответствущее сообщение
  • Параметр типа DWORD DWNoFileCollection со значением 1 не высылает файлы, запрашиваемые сервером обработки ошибок
  • Параметр типа DWORD DWNoSecondLevelCollection со значением 1 не высылает файлы особого рода (записи в реестре, версия файлов, используемые программы), запрашиваемые сервером обработки ошибок

Отсутствие этих параметров (по умолчанию) или установка в 0 включает эти настройки обратно


Zune

Microsoft выпустила Zune HD и Zune 4.0, но некоторые ее возможности недоступны пользователям за пределами США и Канады. Вы можете включить эти возможности самостоятельно. В разделе HKCU\Software\Microsoft\Zune создайте подраздел FeaturesOverride и в нем можете создать отдельные параметры DWORD со значением 1 для каждой нужно параметра, который вы хотели бы включить. Список прилагается.

  • Quickplay
  • Marketplace
  • Picks
  • Videos
  • MusicVideos
  • Podcasts
  • Channels
  • Games
  • SubscriptionFreeTracks
  • SignInAvailable
  • FirstLaunchIntroVideo
  • MBRRental
  • MBRPurchase
  • MBRPreview


Visual Studio

Как убрать ЗАГЛАВНЫЕ БУКВЫ из меню Visual Studio 2012 RC

В Visual Studio 2012 RC главное меню содержит элементы, набранные ЗАГЛАВНЫМИ БУКВАМИ. Не всем это пришлось по душе. Можно вернуть меню в старое состояние. В разделе HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\11.0\General\ присвойте параметру DWORD SuppressUppercaseConversion значение 1.

Скачать новую версию Visual Studio 2012 RC можно по специальному короткому адресу vs11.ru/.


ICQ

Параметры находятся в разделе

HKCU\Software\Mirabilis\ICQ
и в его подразделах.
  • Auto Update - Включение автообновления - Yes No
  • DataBase - Путь до базы данных ICQ - C:\Program Files\ICQ\DB
  • Default Http User Agent - По умолчанию значение отсутствует
  • Default Server Host - URL сервера - ICQ login.icq.com
  • Default Server Port - Порт для соединения - Число (по умолчанию 0x1446)
  • Default Tunnel Server Host - URL сервера ICQ по PTPTP
  • Default Tunnel Server Port - Порт для соединения по PTPTP - Число
  • Email Message - Строка, добавляемая к письму
  • ICQPath - Путь установки ICQ - C:\Program Files\ICQ

Как запустить несколько асек

Можно запустить несколько копий ICQ. Для этого надо внести изменения в разделе

HKLM\Software\Mirabilis\ICQ\DefaultPrefs
  • Auto Update = No
  • OwnersNoLimit = Yes
  • MultiInstance = Yes


Google Chrome

Ошибка при поиске приложения установщика

Если при установке Google Chrome у вас появляется сообщение Ошибка при поиске приложения установщика, то, вероятно, что во время поиска приложения установщика на вашем компьютере произошла ошибка. Чтобы устранить эту проблему, выполните следующие действия.

В разделе HKEY_CURRENT_USER\SOFTWARE\Google\Update\Clients\ удалите раздел {430FD4D0-B729-4F61-AA34-91526481799D}. Попробуйте снова установить программу.


NERO

Во время записи DVD с помощью программы Nero Burning ROM по тем звукам, которые издает привод, можно понять, что скорость записи непостоянна, иногда она снижается. Но если верить показаниям самой программы, скорость никогда не отклоняется от того значения, что я выставляю перед началом записи. Можно ли сделать так, чтобы Nero показывал точную скорость записи? Чтобы Nero показывал точную скорость записи, вам нужно лишь добавить параметр типа DWORD ShowSingleRecorderSpeed в разделе

HKCU\Software\Ahead\Nero - Burning Rom\Recorder

Источник - журнал Upgrade


The Bat!

Восстановление параметров почтовых аккаунтов The Bat!

Можно восстановить параметры почтовых аккаунтов The Bat! после переустановки операционной системы Windows? Если после переустановки Windows сохранилась прежняя структура папок с электронными письмами, можно снова создать всю структуру на новом месте. После повторной установки The Bat! скопируйте все содержимое папки MAIL клиента The Bat! из сохраненной копии в папку MAIL в новом месте. После этого из старой копии сохраните название аккаунтов в папку MAIL (это названия папок). В редакторе реестра откройте раздел

HKCU\Software\RIT\The Bat!\Users Depot
Для каждого аккаунта следует завести два строковых параметра — Dir #N и User#N, где #N — порядковый номер аккаунта; параметр Count (тип DWORD) — это счетчик аккаунтов, который указывает их количество в шестнадцатеричной системе счисления. Например, если у вас было четыре аккаунта, то User#1будет равен имени первого аккаунта, User#2 — второго и т. д.


Skype

Разработчики Skype опубликовали документ, содержащий настройки в реестре, которые можно использовать для работы. Все настройки можно использовать либо в разделе HKLM, либо в HKCU. В данной статье используется только второй вариант. Документ доступен по адресу Guide for Network Administrator.

Список параметров

HKEY_CURRENT_USER\Software\Policies\Skype\Phone, DisableApi, REG_DWORD = {0,1}

HKEY_CURRENT_USER\Software\Policies\Skype\Phone, DisableFileTransfer, REG_DWORD = {0,1}

HKEY_CURRENT_USER\Software\Policies\Skype\Phone, MemoryOnly, REG_DWORD = {0,1}

HKEY_CURRENT_USER\Software\Policies\Skype\Phone, DisableContactImport, REG_DWORD = {0,1}

HKEY_CURRENT_USER\Software\Policies\Skype\Phone, DisableVersionCheck, REG_DWORD = {0,1}

HKEY_CURRENT_USER\Software\Policies\Skype\Phone, DisablePersonalise, REG_DWORD = {0,1}

HKEY_CURRENT_USER\Software\Policies\Skype\Phone, DisableLanguageEdit, REG_DWORD = {0,1}

HKEY_CURRENT_USER\Software\Policies\Skype\Phone, ListenPort, REG_DWORD = {0,1}

HKEY_CURRENT_USER\Software\Policies\Skype\Phone, ListenHTTPPorts, REG_DWORD = {0,1}

HKEY_CURRENT_USER\Software\Policies\Skype\Phone, DisableTCPListen, REG_DWORD = {0,1}

HKEY_CURRENT_USER\Software\Policies\Skype\Phone, DisableUDP, REG_DWORD = {0,1}

HKEY_CURRENT_USER\Software\Policies\Skype\Phone, DisableSupernode, REG_DWORD = {0,1}

HKEY_CURRENT_USER\Software\Policies\Skype\Phone, ProxySetting, REG_SZ = {string}

HKEY_CURRENT_USER\Software\Policies\Skype\Phone, ProxyAddress, REG_SZ = {string}

HKEY_CURRENT_USER\Software\Policies\Skype\Phone, ProxyUsername, REG_SZ = {string}

HKEY_CURRENT_USER\Software\Policies\Skype\Phone, ProxyPassword, REG_SZ = {string}

HKEY_CURRENT_USER\Software\Policies\Skype\Phone, WebStatus, REG_DWORD = {0,1}

Пример

Как известно, Skype использует p2p сеть для обмена данными. Если у Вас достаточно мощный компьютер, то Skype может решить сделать Вас Супернодом и, как следствие, скайп-трафик других участников сети будет идти через Вас.Начиная с версии 3.0 программы, появилась возможность отключить такую «фичу», что бы чужой трафик скайпа не шёл через Вас.Для этого необходимо создать ветку HKCU\SOFTWARE\Policies\Skype\Phone и в ней создать DWORD-параметр DisableSupernode со значением 1.


WinRAR

При работе в многопользовательской среде может потребоваться запретить доступ к меню и настройкам WinRAR, оставив в распоряжении пользователя лишь основной набор функций, доступных с панели инструментов. В этом случае вам нужно создать в системном реестре разделы HKEY_LOCAL_MACHINE\Software\WinRAR\Policy или HKEY_CURRENT_USER\Software\WinRAR\Policy.

Параметры в HKEY_LOCAL_MACHINE имеют более высокий приоритет, чем ключ в HKEY_CURRENT_USER. Разделы могут содержать следующие ключи типа DWORD:

  • Menu - Если установлено в 0, отключает главное меню WinRAR.
  • Settings - Если установлено в 0, отключает диалог "Параметры", команды импорта/экспорта параметров и контекстное меню панели инструментов
  • Password - Если установлено в 0, запрещает изменение пароля архивирования (например, во избежание шифрования важных данных).


Windows Phone 7

Отображаем вывод консоли в эмуляторе Windows Phone 7

Хочется выводить какую-либо информацию в консоль в процессе дебага WP приложения. Надо сделать следующее - исправить определенный ключ в реестре.

Для Win32:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\XDE]
"EnableConsole"=dword:00000001

Для Win64:

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\XDE]
"EnableConsole"=dword:00000001

После этого можно смело использовать Console.WriteLine.

Используем WP7 как USB-хранилище

Откройте раздел HKLM\SYSTEM\CurrentControlSet\Enum\USB. Далее производим поиск (Ctrl+F) слова ZuneDriver.

Теперь, когда вы нашли ZuneDriver (ZuneDriver лежит где-то в папке с похожим именем: VID_045E&PID_04EC&MI_00 Все подпапки в ней – это возможные устройства.), обратите внимание, что она находится в разделе Device Parameters.

Измените значение ShowInShell с 0 на 1 (это позволит обозревателю Windows отображать устройство при подключении)

Измените значение PortableDeviceNameSpaceExcludeFromShell с 0 на 1

Измените значение EnableLegacySupport с 0 на 1 (это позволит Windows опредедять устройство)

Поменяйте те же свойства в других подпапках для других девайсов. Теперь просто подключаем свой Windows Phone 7. Стартует Zune Desktop. Закрываем его и идем в Проводник. Теперь можно без проблем работать с файлами на Windows Phone 7


Windows Phone 7

Для работы с реестром на телефоне необходимо разблокировать телефон при помощи программы ChevronWP7.

Выключение звука затвора камеры

Существует множество причин, почему вы не хотите слышать звук затвора камеры и при каждом снимке. Приведенная правка реестра избавит вас от надоевшего звука затвора. Уровень звука будет соответствовать уровню в самой системе, и если он у вас выключен, то и больше камера не издаст посторонних шумов.

Необходимо в разделе HKEY_LOCAL_MACHINE\Audio\StreamClass\Output\10 присвоить параметру BypassDeviceGain значение 0.

Этот хак реестра взят из большого списка, выложенного на XDA-Developers, там же можно посмотреть, как выполнить правку реестра на различных WP7 девайсах.

Источник: Полезные хаки: выключение звука затвора камеры - Программы - Windows Phone 7

Быстрое возвращение в приложение

Если в разделе HKLM\Software\Microsoft\TaskHost параметру DehydrateOnPause присвоить значение 0, то у вас появится возможность моментально возобновлять работу приложений при возвращении к ним из экрана блокировки. Также данный прием может быть использован для переключения между приложениями в реальном времени.

Можно заходить в различные игры или приложения, нажимать Back и возвращаться ровно в то место, где вы в них остановились, без каких-либо задержек. Можно запустить довольно большое число приложений, никаких ошибок в памяти или её утечка не возникает. Правда, иногда нажатие кнопки Back не вызывает никакого действия - видимо, приложение выгрузилось из памяти для её оптимизации.

К примеру, можно пройтись по восьми приложениям и вернуться туда, где вы в них остановились. Если вы печатали твит, то на страницу этого твита и вернётесь, даже набранный текст останется нетронутым.

При использовании этого хака начинает усиленно расходоваться заряд батареи. Вероятно, это происходит из-за повышенного потребления оперативной памяти в момент сохранения состояния приложения.

Источник: Разблокирован хак, позволяющий возвращаться к приложению моментально - ОС - Windows Phone 7

Программирование для Windows Phone 7

Материалы для разработки программ для Windows Phone 7 можно найти на сайте Освой программирование играючи! Windows Phone


Разное

Windows Vista cannot obtain an IP address from certain routers or from certain non-Microsoft DHCP servers

Если ваш компьютер под управлением Windows Vista не может получить IP-адрес от роутера или DHCP-сервера, то необходимо создать в разделе HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{GUID} (где GUID является номером вашего адаптера) параметр DWORD DhcpConnEnableBcastFlagToggle со значением 1. В этом случае вы отключаете флаг BROADCAST в Windows Vista.

Если вы знаете, что роутер или DHCP-сервер не поддерживает флаг BROADCAST, то можете попробовать другой вариант. В этом же разделе создайте параметр DWORD DhcpConnForceBroadcastFlag со значением 0.

Этот вариант описан в Базе Знаний Microsoft под номером 928233


Восстановление реестра

При работе с реестром надо соблюдать осторожность. Удаление каких-либо важных данных случайно или по незнанию может привести к краху операционной системы. Тогда спасти положение может только восстановление последней работоспособной копии.

Перед редактированием реестра необходимо экспортировать разделы, в которые будут внесены изменения, или создать резервную копию всего реестра. Это позволит в случае необходимости восстановить прежнее состояние реестра.

Чтобы экспортировать раздел реестра, выполните следующие действия. Этот пример не предназначен для экспортирования кустов реестра (например, HKEY_CURRENT_USER). В случае такой необходимости следует создавать резервную копию всего реестра.

  • Запустите редактор реестра regedit.exe.
  • Найдите и выделите подлежащий сохранению раздел реестра.
  • В меню Файл выберите команду Экспорт.
  • Укажите место для хранения файла реестра (REG) и имя файла. Нажмите кнопку Сохранить.

Создание резервной копии всего реестра

Для сохранения всего реестра необходимо с помощью программы архивации создать резервную копию состояния системы. При архивировании состояния системы сохраняются реестр, база данных регистрации классов COM+ и загрузочные файлы. Дополнительные сведения о создании резервной копии состояния системы с помощью средства архивации данных см. в следующих статьях базы знаний Майкрософт:

  • 308422 (http://support.microsoft.com/kb/308422/) Как пользоваться программой «Архивация данных» в Microsoft Windows XP
  • 320820 (http://support.microsoft.com/kb/320820/) Использование программы архивации для создания резервных копий файлов и папок в Windows XP Home Edition
  • 326216 (http://support.microsoft.com/kb/326216/) Создание резервных копий и восстановление данных в Windows Server 2003 с помощью программы архивации

Восстановление системного реестра

Чтобы восстановить экспортированные разделы реестра, необходимо запустить файл с расширением REG, созданный с помощью команды Экспорт или восстановить весь реестр с помощью резервной копии. Для восстановления всего реестра необходимо восстановить состояние системы. Дополнительные сведения о восстановлении состояния системы см. в следующей статье базы знаний Майкрософт:

309340 (http://support.microsoft.com/kb/309340/) Как восстановить файлы и папки с помощью программы архивации в Microsoft Windows XP

Примечание. В процессе создания резервной копии состояния системы обновленные копии файлов реестра записываются в папку %SystemRoot%\Repair. Если не удается запустить Windows XP после внесения изменений в реестр, воспользуйтесь инструкциями в разделе «Этап 1» указанной ниже статьи базы знаний Майкрософт для подстановки сохраненных файлов реестра:

307545 (http://support.microsoft.com/kb/307545/) Восстановление поврежденного системного реестра, препятствующего запуску Windows XP


Структура reg-файлов

Знание реестра Windows будет не полным без умения написать reg-файл. Reg-файл - это файл, имеющий определенную структуру и содержащий информацию, которая может быть импортирована в реестр. Если была заблокирована работа с редактором реестра , то наиболее легким способом подредактировать реестр будет создание и импортирование reg-файла (конечно, можно выйти в DOS, в защищенный режим, воспользоваться другими программами, но это все гораздо сложнее, а главное дольше).

К reg-файлам предъявляются определенные требования по структуре. Начнем с того, что в первой строке файла обязательно должно быть введено

Windows Registry Editor Version 5.00. (В старых версиях Windows использовалась строка REGEDIT4, которая действительна, в целях совместимости).

Обратите внимание на то, что буквы должны быть большие. Кроме этого в первой строке ничего быть не должно. После этого текста ОБЯЗАТЕЛЬНО должна быть пустая строка. Затем, указывается раздел реестра, в котором надо прописать или изменить какие-то параметры. Название раздела должно быть заключено в квадратные скобки [...]. Ниже прописываются параметры, которые надо добавить, по одному параметру в строке. Если вам надо провести изменения в нескольких разделах, то вы должны оставлять одну пустую строку между последним параметром предыдущего раздела и названием следующего раздела. Может немного запутанно, но вот как это должно выглядеть:

REGEDIT4

[Раздел]
"param1"="значение1"
"param2"="значение2"
"param3"="значение3"

[Раздел2]
"param_1"="значение_1"

Последняя строка в файле должна быть ПУСТОЙ. После того, как вы создали такой файл, просто запустите его как обычную программу, вам будет выдан запрос о необходимости провести изменения в реестре, и после положительного ответа информация из файла будет импортирована. О результатах импортирования Windows сообщит в появившемся после этого окне.

Примечание: Windows 2000/XP обладает обратной совместимостью и может обрабатывать файлы, созданные в Windows 9x. Но если вы экспортировали файл в Windows XP и перенесли его на Windows 9x, то вручную измените первую строчку на REGEDIT4

Теперь пару слов о параметрах, которые можно добавлять. Как вы, наверное, обратили внимание, в приведенном выше примере добавляются параметры с помощью строк типа "param1"="znachenie1". Т.е. таким образом добавляется СТРОКОВЫЙ параметр с именем "param1" и значением "znachenie1". Но ведь существуют еще и параметры двоичные и DWORD. Формат записи для их добавления несколько другой. Для параметров типа DWORD используется строка

"param"=dword:XXXXXXXX

Здесь "param" - имя параметра, dword - указывает на тип этого параметра (буквы должны быть обязательно маленькие!) и после двоеточия следует значение из восьми цифр в шестнадцатеричном (!) формате. Однако большинство параметров DWORD имеют значение либо 0, либо 1, значит, вы должны написать соответственно либо 00000000, либо 00000001 вместо значков ХХХХХХХХ. Пробелы в строке не допускаются.

Для добавления двоичного параметра формат записи несколько иной:

"param"=hex:XX,XX,XX,....

Теперь расшифрую эту строку. Ну, с названием параметра все ясно, после знака "=" идет hex, т.е. указывается, что это будет двоичный параметр, затем идут шестнадцатеричные числа, отделенные запятой. Например, если вам надо добавить двоичный параметр равный "be 00 00 00", то вы пишете строку

"param"=hex:be,00,00,00

В реестре существуют параметры "По умолчанию" ("Default"). Чтобы присвоить им какое-то значение через reg-файл, надо добавить такую строку:

@="znachenie"

Здесь значок @ показывает, что у нас присваивается значение параметра "По умолчанию". Обратите внимание на то, что он не заключается в кавычки.

Теперь я приведу пример простенького reg-файла, который прописывает в реестр сайт, устанавливающий домашнюю страничку в Internet Explorer'e:

REGEDIT4

[HKEY_CURRENT_USER\Software\ Microsoft\Internet Explorer\Main]
"Start Page" = "http://winchanger.narod.ru/"

Удаление параметров

С помощью reg-файлов можно не только устанавливать новые параметры, но и удалять их. Например, для удаления раздела из реестра надо перед его именем в квадратных скобках поставить символ "-". Вот как это выглядит:

[-HKEY_LOCAL_MACHINE\Software\ QuickSoft\QuickStart]

Благодаря этой записи, подраздел "QuickStart" из раздела "QuickSoft" будет удален со всем содержимым.

Для удаления отдельных параметров используйте следующий синтаксис:

REGEDIT4

[HKEY_CURRENT_USER\Software]
"xxx"=-

Параметры командной строки

Редактор реестра можно запускать с некоторыми ключами

  • /s (импортирует значения из reg-файла без вывода диалогового окна)
  • /e (экспортирует параметры в reg-файл. Пример: regedit /e myfile.reg HKEY_USERS\.DEFAULT


Утилиты для работы с реестром

Программ для работы с реестром имеется множество программ. Дополнительную информацию о них можно найти на сайте http://winchanger.narod.ru/registry/regsoft.htm


Благодарности

Признательность

Авторы Александр Климов и Игорь Чеботарев использовали самые разные источники при составлении справочника: интернет, книги, журнальные и газетные публикации

Отдельное спасибо хочется сказать следующим людям, помогавшим нам в работе над справочником

  • Евгений Соболев (SOFTODROM) - за дельные замечания
  • Korsar - за отдельные статьи


Замена фона в панели инструментов в Проводнике

Существует возможность установки своего фона для панели инструментов в Проводнике. Для этого в разделе реестра HKEY_CURRENT_USER \SOFTWARE\ Microsoft\Internet Explorer\Toolbar создайте строковый параметр BackBitmapShell, значением которого будет полное имя BMP-файла с нужной картинкой - она и замостится мозаикой на панелях окон.

Для замены фона не только в Проводнике, но и в Internet Explorer смотрите Замена фона в панели инструментов в Internet Explorer


Домашняя страница

Сайт Справочника по реестру

Последние версии справочника вы можете скачать по адресу
user.alexanderklimov.ru


Версия Internet Explorer

Начиная с Internet Explorer 4.0, номер версии браузера можно найти в разделе

HKLM\Software\Microsoft\Internet Explorer
в строковом параметре Version