WOW.js + Animate.CSS
itspec.org

  itspec@itspec.org    +7 (926) 697-78-81

ѕоследние —татьи

 от 1с

¬се —татьи

—тать€ на ƒзен

 ак € создавал VPN сервер

¬ свое врем€ мне нужен был некий удаленный сервер, что можно было его использовать дл€ себ€ и работы.

“о есть, если у клиента нет ¬нешнего ip адреса то € бы мог спокойно подключитьс€ туда по RDP.

Ќастроить и админить на Ћинукс мне не удобно. ј € работаю с роутерами микротик. ѕо этому выбор пал на него.

” данного роутера имеетс€ цифрова€ лицензи€ дл€ установки на программный продукт. “ем самым не нужно покупать железку и куда то ее везти и платить за ее размещение.

¬ итоге, € купил самый дешевый VDS и установил туда Debian.

ѕосле чего € начал устанавливать софт микротика

«аходим в консоль и вводим следующие команды:

# wget https://download2.mikrotik.com/routeros/6.39.2/chr-6.39.2.img.zip
# echo u > /proc/sysrq-trigger && gunzip -c chr-6.39.2.img.zip | dd of=/dev/vda
# reboot

ѕерва€ строка - загрузка образа микротика

¬тора€ строка - установка на VDS

“реть€ строка - перезагрузка

ѕосле перезагрузки нужно открыть VNC консоль. “ем самым мы попадаем уже в консоль микротика. “ак как он устанавливаетс€ как бы поверх Ћинукса.

“еперь нам нужно настроить сетевой интерфейс. ƒл€ этого вводим сетевые настройки VDS.

ƒл€ этого тут же в консоли вводим:

/ip address add address=xxx.xxx.xxx.xxx/24
/ip route add gateway=xxx.xxx.xxx.yyy

ѕерва€ строка - назначение ip адреса и маски

¬тора€ строка - шлюз

ѕосле чего к роутеру можно будет подключитьс€ уже через Winbox и по внешнему ip адресу.

ƒалее нужно настроить VPN сервер

¬ключаем L2tp сервер.

ѕуть PPP - Interface - L2TP Sever

¬о вкладке IPsec Secret нужно задать ключ



“ут же во вкладке Secrets настраиваем учетные записи дл€ подключени€



¬ыше пример подключени€

¬ Quick Set нужно добавить DNS адрес. ћожно добавить DNS от google

“ак же нужно сн€ть галку Dhcp сервер, так как задавать настройки € буду вручную



ќткрываем вкладку IP- Addresses

ether1 - это адрес провайдера (интернет)

Bridge1 - это внутренний адрес роутера в локальной сети



Dhcp сервер € создал, но не активировал. Ќо можно активировать и пользоватьс€ автоматическими настройками. » добавить пул адресов дл€ Dhcp сервера




«аказ VpN

ƒалее настраиваем Firewall

ѕереходим в настройки NAT и добавл€ем правило





Ёто правило даст пользоватьс€ интернетом тем учеткам, что по VPN подключаютс€ к роутеру.

√отово.

ћожно тестировать скорость и качество работы.

“еперь другой вопрос. Ёто лицензирование

ѕриобрести лицензию на такой роутер можно на оф. сайте производител€.

Ќо скорее всего вам будет отказ. ћикротик же ушел из –оссии. Ќо попробовать можно, при желании.

P.S. “ак как роутер находитьс€ и в интернете желательно озаботитьс€ о его безопасности. «акрыть лишние порты и прочее.



≈сли есть желание поблагодарить за помощь, просьба поддержать просмотрами видео и подпиской на яндекс ƒзен

ѕодписатьс€ на “еграмм  анал

»ли можете помочь проекту материально

–Ф–ї—П —В–µ–Ї—Г—Й–µ–є —Б—В—А–∞–љ–Є—Ж—Л –љ–µ—В –Ї–Њ–Љ–Љ–µ–љ—В–∞—А–Є–µ–≤

–Ю—Б—В–∞–≤–Є—В—М –Ї–Њ–Љ–Љ–µ–љ—В–∞—А–Є–є

–Ш–Љ—П:
Email:
–Ъ–Њ–Љ–Љ–µ–љ—В–∞—А–Є–є:
- —П –љ–µ —А–Њ–±–Њ—В
- –њ–Њ–і–њ–Є—Б–∞—В—М—Б—П –љ–∞ –Њ–±–љ–Њ–≤–ї–µ–љ–Є—П
eComment v.1.9.0